Bug Hunting Session
Bug 61218 - UI shows "Transpose" checked for Past-Special-Link although pasted contents will not be transposed
Summary: UI shows "Transpose" checked for Past-Special-Link although pasted contents w...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-21 09:30 UTC by Rainer Bielefeld Retired
Modified: 2015-08-22 14:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-21 09:30:05 UTC
Steps how to reproduce with  "LibreOffice 3.6.5.2 " German UI/ German Locale [Build-ID: 5b93205] {pull date 2013-01-18} on German WIN7 Home Premium (64bit) 

1. Open New empty Spreadsheet from LibO Start Center
2. Open arbitrary simple ExistingSpreadsheet.ods on same HDD oon your PC
3. Select a simmple small column range (C3:C8) in ExistingSpreadsheet.ods
4. copy with <control+c>
5. Switch to new empty spreadsheet
6. Click cell C10
7. Menu 'Edit -> Paste Special - Paste All []checked -  Transpose []checked - 
   Link [] checked' <ok>
   > Contents appears
   Expected: Column contents will be pasted as row contents, because 
             checkbox in greyed 'Transpose' still checked
   Actual: pasted to column

That's unintuitive, if intended result is the "paste to column cells" the 'Transpose' checkbox should become unchecked when 'Link' chechbox becomes checked.
Comment 1 Rainer Bielefeld Retired 2013-02-21 09:30:35 UTC
Similar problem as "Bug 60430 - UI shows "Delete comment" in context menu althoug it's impossible because of protected section"
Comment 2 Rainer Bielefeld Retired 2013-02-21 09:34:51 UTC
Still Reproducible  with "Version 4.1.0.0.alpha0+ (Build ID: 0a967d4cb4468785ed3d302104642353b93232f) TinderBox: Win-x86@6, Branch:master, Time: 2013-02-21_00:36:59"

Already REproducible with LibO 3.3.3 and AOOo 3.4.0, so I think this one is inherited  from OOo
Comment 3 Rainer Bielefeld Retired 2013-03-11 05:07:09 UTC
No objections, so NEW
Comment 4 QA Administrators 2015-02-19 15:45:54 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.0.3 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-02-19
Comment 5 Jean-Baptiste Faure 2015-02-27 05:59:50 UTC
Column copy is still reproducible with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10.

But, now, it is expected: paste special dialog has been reworked since this bug report has been filled. When cheking the [] Link check box, all others checkboxes are grayed out. So, there is no ambiguity anymore in the behavior of this function.

So closing as WorksForMe. Please, feel free to reopen if you disagree

Best regards. JBF
Comment 6 David Fischer 2015-08-22 14:34:31 UTC
Works for me as well.

LO: 5.0.0.5
OS: Linux Mint 17.2