Bug 61272 - Incorrect EMF pictures visualization
Summary: Incorrect EMF pictures visualization
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0.0.beta2 tar...
Keywords:
Depends on:
Blocks: mab4.0
  Show dependency treegraph
 
Reported: 2013-02-22 11:51 UTC by Ilya Ermolin
Modified: 2013-11-27 12:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (46.72 KB, application/vnd.oasis.opendocument.text)
2013-02-22 11:51 UTC, Ilya Ermolin
Details
View of document (85.42 KB, image/png)
2013-02-22 11:52 UTC, Ilya Ermolin
Details
Image original 1 (108.96 KB, image/x-emf)
2013-02-22 11:53 UTC, Ilya Ermolin
Details
Image original 2 (492.64 KB, image/x-emf)
2013-02-22 11:53 UTC, Ilya Ermolin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Ermolin 2013-02-22 11:51:20 UTC
Created attachment 75303 [details]
Sample document

Incorrect display of EMF files in LO Writer.

I try to open one program generated report in RTF format and almost all emf pictures there was corrupted.

I can reproduce such view in new document by inserting EMF file from report by hand. Same result.

LO version: 4.0.0.3
Platform: Windows 8 64-bit
Comment 1 Ilya Ermolin 2013-02-22 11:52:36 UTC
Created attachment 75304 [details]
View of document
Comment 2 Ilya Ermolin 2013-02-22 11:53:28 UTC
Created attachment 75305 [details]
Image original 1
Comment 3 Ilya Ermolin 2013-02-22 11:53:50 UTC
Created attachment 75306 [details]
Image original 2
Comment 4 BorosIstvan 2013-04-12 10:48:36 UTC
Thanks your report, I can reproduce your problem.
Comment 5 mathias.supp 2013-11-14 09:29:02 UTC
Is this really a "medium"-important issue?
In fact emf is a standard-format on the Window-Platform and there is no known workaround, yet. (Note: AOO doesn't have that problem currently)
For me it's a least "high" and "critial".

Any chance to handle this issue like that and get it fixed soon?
Comment 6 Owen Genat (retired) 2013-11-18 10:18:48 UTC
(In reply to comment #5)
> Is this really a "medium"-important issue?
> In fact emf is a standard-format on the Window-Platform and there is no
> known workaround, yet. (Note: AOO doesn't have that problem currently)
> For me it's a least "high" and "critial".

Please understand that these fields are largely set by the QA team to ensure fair and accurate reporting across the entire LO community and bug pool, rather than the effect on an individual. In this case there are alternate formats to EMF e.g., SVG.
Comment 7 mathias.supp 2013-11-18 17:31:12 UTC
No offence but:
1. I didn't change the importance but questioned it
2. you should reconsider if a certain amount of Windows users represents one individual
3. as MS Office won't provide SVG as clipboard-format and export-quality it very poor, it isn't an alternative

So tell me: what should a Windows user do, when he owns an EMF and wants to include it into a LibO-Writer document without loosing informations or if he wants to copy/paste from PowerPoint to LibO-Writer and not a single paste-format (CTRL+Shift+V) brings up a correct representation?

If I've overseen something I really want to know and this issue can be "downgraded" to minor - with pleasure. :-)
Comment 8 Owen Genat (retired) 2013-11-19 09:19:06 UTC
(In reply to comment #7)
> No offence but:
> 1. I didn't change the importance but questioned it

I know. I did not mean to imply you had, so I am sorry if it sounded that way. I was just trying to provide some clarity.

> So tell me: what should a Windows user do, when he owns an EMF and wants to
> include it into a LibO-Writer document without loosing informations or if he
> wants to copy/paste from PowerPoint to LibO-Writer and not a single
> paste-format (CTRL+Shift+V) brings up a correct representation?

EMF+ support is steadily improving (http://opengrok.libreoffice.org/history/core/cppcanvas/source/mtfrenderer/emfplus.cxx), but you will need patience. There are numerous EMF-related bugs, including this one. Simply because MS has billions and are unwilling to improve open format support, does not mean that those working on a largely volunteer basis are somehow obligated to see supporting MS formats as critical.
Comment 9 mathias.supp 2013-11-19 14:48:18 UTC
> Simply because MS has billions and are unwilling to improve open format
> support, does not mean that those working on a largely volunteer basis are
> somehow obligated to see supporting MS formats as critical.

Oh yes, you can think about it that way on a community-level.
Comment 10 Commit Notification 2013-11-25 13:12:36 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=198b17dc5e182dfb2e5c930458764c7b3e6c914f

Related fdo#61272: Revert "wmf-mm-text-1.diff: Fix WMF rendering, n#417818"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2013-11-25 13:12:52 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9d3c0aa1e64ae97ddc305df3873f977051f0b317

Related fdo#61272: Revert "wmf-mm-text.diff: Fix WMF rendering, n#417818"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2013-11-25 13:13:10 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4ba2b2ae62276ab7b40ba5730d631ad4b3fd6ac8

fdo#61272: Do the mapping correctly both for WMF and EMF.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Jan Holesovsky 2013-11-25 13:18:40 UTC
Fixed in master now.
Comment 14 Commit Notification 2013-11-25 15:06:21 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8614fbc8e68aae5790b7ee06021393ea95e92ed7&h=libreoffice-4-2

Related fdo#61272: Revert "wmf-mm-text-1.diff: Fix WMF rendering, n#417818"


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2013-11-25 15:06:40 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cca0ae43e58f875116fd922c2b70ef6c89305fcf&h=libreoffice-4-2

Related fdo#61272: Revert "wmf-mm-text.diff: Fix WMF rendering, n#417818"


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2013-11-25 15:06:59 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ec27d36b2adea77201c03ae88ee71ac259e847be&h=libreoffice-4-2

fdo#61272: Do the mapping correctly both for WMF and EMF.


It will be available in LibreOffice 4.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Commit Notification 2013-11-26 10:06:13 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a39079ec9c3a017c912e45126ae980ff56127099&h=libreoffice-4-0

fdo#61272: Do the mapping correctly both for WMF and EMF.


It will be available in LibreOffice 4.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2013-11-27 12:39:08 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=22f63e3e7be99f13fd719ffc03aa78e34bd545af&h=libreoffice-4-1

fdo#61272: Do the mapping correctly both for WMF and EMF.


It will be available in LibreOffice 4.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.