Bug 61429 - LibreOffice doesn't remember the setting "Hierarchy" of the Styles and Formatting dialog
Summary: LibreOffice doesn't remember the setting "Hierarchy" of the Styles and Format...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:4.1.0 target:4.0.5 target:...
Keywords: regression
: 30917 63232 65875 66207 67661 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-25 08:30 UTC by NWinkler
Modified: 2017-09-29 18:56 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot-stylist (22.54 KB, image/png)
2013-05-11 08:07 UTC, Olivier R.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description NWinkler 2013-02-25 08:30:34 UTC
1. press F11 to get the list
2. choose "Hierarchy" 
3. close LibO
4. start it again
5. press F11 
6. --> LibO choose "user templates" again
Operating System: Windows 7
Version: 4.0.0.3 release
Last worked in: 3.6.5.2 release
Comment 1 Thomas van der Meulen 2013-02-25 11:26:00 UTC
Thank you for reporthing this bug,
I can reproduce this bug running LibreOffice 4.0.1.1 on Mac osx 10.6.8.
Comment 2 Elgo 2013-03-10 11:26:07 UTC
I can reproduce this bug too, with LO 4.0.1.2 on Win 7.

No need to restart LibO though. If you choose "Hierarchy" and double-press F11, the list is automatically set up to the last setting you used that is not "Hierarchy".
Comment 3 Michael Stahl (CIB) 2013-03-26 10:54:03 UTC
so there is a "int" configuration setting for the whole dialog;
i've encoded a new "hierarchical" flag in there which is
quite ugly but i'm not sure what else is possible...

fixed on master
Comment 4 Commit Notification 2013-03-26 10:55:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=44dd8b838b8dfa74b895a870a68200cf4f3574e0

fdo#61429: Stylist: save selection of "Hierarchical" entry



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Olivier R. 2013-03-26 12:40:11 UTC
Glad to see this bug fixed. Thanks Michael. :)

Just for memo, there was another patch waiting for a license statement that never came:
https://bugs.freedesktop.org/show_bug.cgi?id=30917
Comment 6 Olivier R. 2013-03-26 12:41:42 UTC
*** Bug 30917 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2013-03-27 12:32:21 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5c5b6f1e9e3341726d6870af74912bb9db374b5f&h=libreoffice-4-0

fdo#61429: Stylist: save selection of "Hierarchical" entry


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Jorendc 2013-04-07 22:20:41 UTC
*** Bug 63232 has been marked as a duplicate of this bug. ***
Comment 9 Olivier R. 2013-04-18 17:28:44 UTC
Just installed Version 4.0.3.1 (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) on Windows 7.

It doesn’t work.

Launch LO. Set Stylist to “hierarchical view”.
Close LO.
Launch LO. Stylist has changed of view.
Comment 10 Olivier R. 2013-05-10 13:31:40 UTC
I’ve asked to several people if they still reproduce the bug.

Windows 7 64 bits - yes, this bug is still there.
Linux Mint 14 - yes, the bug is still there.
Fedora 17 - no, it works properly, “the hierarchy view” is persistent.
Ubuntu 13.04 - no, it works properly, “the hierarchy view” is persistent.

Everyone use LO 4.0.3.3
Comment 11 ktos.obcy+freedesktop 2013-05-10 13:35:32 UTC
MacOSX - Version 4.0.3.3, Selection of the "Hierarchical" is persistent, but after subsequent launch the list is all flat (i.e. I have all items but not in a tree form - just plain list)
Comment 12 Olivier R. 2013-05-11 08:07:57 UTC
Created attachment 79130 [details]
screenshot-stylist
Comment 13 Olivier R. 2013-05-11 08:08:30 UTC
It’s getting confusing.

On Ubuntu 12.10, with the same version of LO (4.0.3.3 - Build ID:
0eaa50a932c8f2199a615e1eb30f7ac74279539), it works for one user and it doesn’t work for another user.

Note: if you select the hierarchical view. At restart, the drop-down list displays “Hierarchical” but the view is not hierarchical.

See screenshot attached.

Finally, it does not work on Ubuntu 13.04. The user get confused by the contradictory statement of the stylist.
Comment 14 ktos.obcy+freedesktop 2013-05-11 08:50:53 UTC
Just tested on win8 x64 EN.

Same behaviour - select "hierarchical" from the dropdown, restart LO. Afterwards in the dropdown selection is correct ("hierarchical") but the view is "All styles".

Observation - this works for all the other selection ("indexes" and so forth) except for the first one - "hierarchical"
Comment 15 Olivier R. 2013-05-20 07:35:02 UTC
This is worse than before.

I have to switch to the Hierarchical view each time I open a document (not once at the opening of LO) and the displayed information is incorrect (“hierarchical” statement of the drop-down list, but flat view).

The patch should be reverted.
Comment 16 NWinkler 2013-05-23 13:11:57 UTC
Same behavior in my 4.0.3.3 version.
What a pity, I've to use 3.6. some time longer.
Comment 17 Olivier R. 2013-05-23 13:25:56 UTC
This bug has been fixed in Apache OpenOffice. It should be possible to take the patch from here.
Comment 18 Jorendc 2013-06-26 13:43:52 UTC
*** Bug 66207 has been marked as a duplicate of this bug. ***
Comment 19 Kevin Suo 2013-06-28 02:12:41 UTC
I believe this is a "Hierarchy" issue, rather than a "remember" issue. As I described in Bug 65875,

* Open a component;
* Click the "styles and formatting" icon to open the styles list window;
* It shows "hierarchical" by default, but actually was "Automatic", see the attachment.
* Select "hierarchical" again shows correct result.

* When select "hierarchical" and then press F11 to hide and show the styles list, it come to "Automatic" again rather than "hierarchical", while the selection box still show hierarchical.
* This does not happen when select other styles. (Select any styles except hierarchical, then F11 and F11 again, the result is correct).

So, this is only related between "Hierarchy" and "Automatic" selection.
Comment 20 Kevin Suo 2013-06-28 02:14:47 UTC
*** Bug 65875 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2013-07-02 19:05:32 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f04b172c5c78fa80c3692a729f0191425195869

fdo#61429: Stylist: try a little harder to restore "hierarchical"



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2013-07-03 08:18:45 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6906a700c436892429032fce0c7e055dd97b083a&h=libreoffice-4-1

fdo#61429: Stylist: try a little harder to restore "hierarchical"


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 23 Commit Notification 2013-07-03 08:19:24 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8c51ceb7166e63950cd7284fd59e8971c43605ee&h=libreoffice-4-0

fdo#61429: Stylist: try a little harder to restore "hierarchical"


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Olivier R. 2013-07-04 12:21:48 UTC
Works on Version: 4.2.0.0.alpha0+
Build ID: e703b429cf448deddc7682a33c3e6221889efe98

I’ll try with 4.1 when Windows builds will be available.
Comment 25 Olivier R. 2013-07-06 10:12:13 UTC
Also works on Version: 4.1.1.0.0+
Build ID: 03c0f9976dc1c77973658aa02db2823bfc9a09a
TinderBox: Win-x86_9-Voreppe, Branch:libreoffice-4-1, Time: 2013-07-05_09:14:47
Windows 7
Comment 26 Mike Kaganski 2013-08-04 13:09:07 UTC
*** Bug 67661 has been marked as a duplicate of this bug. ***