Bug Hunting Session
Bug 61588 - LOCALHELP: Misleading for Ctrl+Shift+Arrow
Summary: LOCALHELP: Misleading for Ctrl+Shift+Arrow
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other All
: medium normal
Assignee: Olivier Hallot
URL:
Whiteboard: target:6.4.0
Keywords:
Depends on:
Blocks: Help-Changes-Features
  Show dependency treegraph
 
Reported: 2013-02-28 06:31 UTC by Rainer Bielefeld Retired
Modified: 2019-08-15 10:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-02-28 06:31:05 UTC
Steps how to reproduce with Server Installation of "LibO  4.0.2.0+   -  English UI / German Locale  [Build ID: 01f8d0a1dffce854a66c0f957e81e6df6d361a8)]"  {tinderbox: @6, pull time  2013-02-26 09:45:35} on German WIN7 Home Premium (64bit) with newly created user profile ….\LODev\4\:

Under "Shortcut Keys for Spreadsheets" - "Navigating in Spreadsheets" you see:

Current Help
------------
Ctrl+Shift+Arrow: Selects all cells containing data from the current cell to the end of the continuous range of data cells, in the direction of the arrow pressed. If used to select rows and columns together, a rectangular cell range is selected.

Problems
--------
a) That is very incomplete, see below and Bug 61586


Correct Help:
------------
Moves the cursor due to "Ctrl+Arrow" and selects a range including start and end position of the cursor. If the cursor was in a joint selected cells range, the selection will be spread rectangular including the cell where the cursor stops.

Additional Info:
----------------
There is a special case for unjoint selections, but I believe with "as in a joint selected" no further explication is necessary.

Example:
1. open Attachment 75594 [details] for Bug 61478
2. Click cell C1
3. <control+click> cell B1
4. <control+click> cell A1
5. <control+shift+down arrow>
   Result: Selected will be A1:A5 and additionally B1:C1
Comment 1 tmacalp 2013-04-09 20:15:06 UTC
Currently, your suggested correction is wrong too.  That might be how it should, and did, behave, but for a long time now, ctrl-shift-arrow no longer moves the cursor cell like ctrl-arrow does. 

It now just extends the selection range, but uses the original (unmoving) cursor cell to base all actions.  This means that it *seems* to work fine in most cases, but if you start your selection in a blank cell, or are working with data that has uneven gaps in it, you'll get weird results.

These are the bug reports I've seen so far for problems affected by this new behavior:

bug 52239
and 
bug 61534
Comment 2 Rainer Bielefeld Retired 2013-04-10 08:35:39 UTC
May be we should use this Bug to get a correct help for 3.6 (even describing buggy behavior correctly) and open separate Bugs for function problems.
Comment 3 QA Administrators 2015-03-04 02:21:16 UTC Comment hidden (obsolete)
Comment 4 jteera5 2015-03-04 13:22:54 UTC
The issue is still there for LibreOffice 4.4.1.2 and Windows XP, 7.
Comment 5 tommy27 2016-04-16 07:25:06 UTC Comment hidden (obsolete)
Comment 6 jteera5 2016-04-21 11:08:41 UTC
The bahavior of Ctrl+Shift+Arrow in LibreOffice, from version 3.3 to 5, is based on the origin of the cell range. That of OpenOffice is based on the current cell where Ctrl+Shift+Arrow is pressed, which is more useful.

For example, if I have data in A1:A100 and I want to paste some text in cells C1:C100, in OpenOffice I can do this by starting at C1, press Shift+Left twice to A1 (selected A1:C1), then Ctrl+Shift+Down to A100 (select A1:C100), Shift+Right twice back to C100. Not that I have C1:C100 selected, then I can paste my data into C1:C100.

In LibreOffice I won't be able to do this because the extent of the cell range is based on the starting cell.

I use this keyboard shortcut a lot and it's an important reason why I don't switch to use LibreOffice, inspite of tons of other improvements.

I don't see any reasons why its behavior should be changed from the original OpenOffice. Instead of changing Help to correspond to the software, I think it's better to change the software behavior back to that of OpenOffice, and then improve the Help.
Comment 7 QA Administrators 2017-05-22 13:26:33 UTC Comment hidden (obsolete, spam)
Comment 8 Olivier Hallot 2019-08-14 22:05:27 UTC
The current behaviour of Ctrl+Shift+Arrow
Comment 9 Commit Notification 2019-08-14 22:22:47 UTC
Olivier Hallot committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/+/d2c1339bef89ad0074810728c580cb14d8db4b40%5E%21

tdf#61588 Clarify usage of Shift+Ctrl+Arrows in Calc