Bug Hunting Session
Bug 61952 - FORMATTING: crash when switching between left and right page
Summary: FORMATTING: crash when switching between left and right page
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:4.1.0 target:4.0.2
Keywords: regression
: 60260 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-07 09:37 UTC by Tom Adriaensen
Modified: 2016-05-04 07:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Adriaensen 2013-03-07 09:37:38 UTC
Problem description: 

Steps to reproduce:
1. set a page to left page
2. switch the page to right page
3. crash LibreOffice, document can be recovered

If you switch to another profile like standard, then there is no problem. 



              
Operating System: Windows 7
Version: 4.0.1.2 release
Last worked in: 3.6.3.2 release
Comment 1 Julien Nabet 2013-03-09 20:34:41 UTC
Tom: sorry if it's obvious for you but what do you mean "set a page to left page", etc.
Could you give Menu, options, etc.?
Comment 2 Tom Adriaensen 2013-03-11 08:01:17 UTC
I'm sorry that is was a bit unclear.
It is called "stijlen en opmaak" in Dutch, you can get it via the F11 key.
I don't known how it's called in English.
You can set a page to standard, left page, right page, landscape, ...
Comment 3 Michael Stahl (CIB) 2013-03-15 21:56:28 UTC
page style code is very confused about first page when it is a left-only or a right-only style...

fixed on master
Comment 4 Commit Notification 2013-03-15 21:59:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4dc78aee9bcdb6ea5e9dc47ebb4a4b9e590c725a

fdo#61952: sw: fix left/right-only page styles and first-page



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-03-15 21:59:26 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2832da0f5982f6b5d6d96346a5db9460d59b7e2e

fdo#61952: add unit test



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2013-03-16 22:01:01 UTC
*** Bug 60260 has been marked as a duplicate of this bug. ***
Comment 7 Commit Notification 2013-03-18 09:04:00 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=75d6eec4be88194126d31fc0f235cd3a303936bd&h=libreoffice-4-0

fdo#61952: sw: fix left/right-only page styles and first-page


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2013-03-18 14:51:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-0-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5df8397041f15a6c8aea6e4088ba3999606a0c51&h=libreoffice-4-0-2

fdo#61952: sw: fix left/right-only page styles and first-page


It will be available already in LibreOffice 4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.