Bug Hunting Session
Bug 62047 - Blocks Middle Mouse Key Under GNU/Linux
Summary: Blocks Middle Mouse Key Under GNU/Linux
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-09 06:41 UTC by xcomm
Modified: 2017-08-04 13:52 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xcomm 2013-03-09 06:41:05 UTC
Hi Community,

This issue is with LibreOffice for years now. Under GNU/Linux it is the usual work flow to mark text with the left mouse key and to paste it with the middle key. This is much faster as the CTRL+C and CTRL+V copy and paste. There is only one program I know which is interrupting this under GNOME, which is LibreOffice. This is not special to any version, it is for all Versions I know, from OO on and from Debian stable squeeze till Debian unstable sid (which should be very near to the actual versions of the software).

So the issue is, that LibreOffice is blocking the common work flow at least under GNOME on GNU/Linux.

Please see also this German thread where it was discussed in length:

http://debianforum.de/forum/viewtopic.php?f=29&t=141050&start=15#p920469

Let me cite and try to translate the summary from this post:

works: mark with left mouse key in LibreOffice  -> insert in other program with middle mouse key
works not: mark with left mouse key in other program -> than paste in LibreOffice with middle mouse key     
works not: mark with left mouse key in LibreOffice -> paste in LibreOffice with middle mouse key 
works: mark with left mouse key in other program -> insert in other program with middle mouse key

It was assumed that maybe nobody recognized the faster GNU/Linux copy and paste method?

Thanks, xcomm
Comment 1 manuelsoukup 2013-04-19 12:14:19 UTC
Hi

I can confirm this. It is also happening with KDE or XFCE.

Also this is happening since I Libreoffice or OO know. At leat since version 3.1 OpenOffice. I did not try other version. It is happening on x64 and x86. Have seen it happen on different Linux Distros as well. (Gentoo, Debian,Ubuntu, SuSE)

I want to clarify the bug a bit more from my perspective:


For me there are two problems: 

1. when i mark something it needs to stay marked so you are able to paste it with middel mouse in Libreoffice again (copy from one place in document to another), so it does __not__ get copied to clipboard. This is inconvinient but bearable, but still i have to be very carfully not no de-mark it otherwise i cant paste it in again.

2. when i pass something with the middle mouse button, the page jumps back to the place where i marked something, so i have to scroll back to the place i actually work on because i passed something in at this place not on the marked spot!
This is really annoying when you have a big document with more than 3 pages!

Inother thing: i cant precisly set the point for inserting because this would demark the stuff (as i have to click at some place to set the cursor there) i wanted to paste and it will not get passed because it got demarked.

Proposal for solution:
Just make Linreoffice behave like any other Linux app and save the marked text in the clipboard, without make it necessary that it needs to stay marked. Then we could just paste it with the middle mouse button. Also delete this page jumping to the copied/marked place when we are working in a whole different place in the document.

Thanks

PS: I hope the status of this bug gets not set to "FIXED" after i post this. There is no option available to just comment i think. This bug is _not__ FIXED!!
Comment 2 sasha.libreoffice 2013-09-23 11:25:49 UTC
Thanks for bugreport
Please, change this option:
Tools->Options->LibreOffice->View->field "Mouse", option "Middle mouse button"
After changing this option middle mouse will work even on Windows.
Comment 3 Owen Genat (retired) 2014-08-02 06:00:19 UTC
Under Crunchbang 11 x86_64 with Openbox using v4.2.5.2 this is what I experience with some basic tests:

(In reply to comment #0)
> works: mark with left mouse key in LibreOffice  -> insert in other program
> with middle mouse key

Calc -> Geany   = WORKSFORME.
Writer -> Geany = Does work but for multiple paragraphs it seems to depend on speed / rate of highlighting. Slow highlighting results in only a partial paste i.e., first paragraph.

> works not: mark with left mouse key in other program -> than paste in
> LibreOffice with middle mouse key

Geany -> Calc/Writer      = WORKSFORME.
Iceweasel -> Calc/Writer  = WORKSFORME.
Terminator -> Calc/Writer = WORKSFORME.

> works not: mark with left mouse key in LibreOffice -> paste in LibreOffice
> with middle mouse key 

Writer -> Writer = WORKSFORME.
Calc -> Calc     = On same sheet WORKSFORME. Not possible between sheets (refer bug 59260 - added to See Also list).
Writer -> Calc   = WORKSFORME.
Calc -> Writer   = WORKSFORME.

> works: mark with left mouse key in other program -> insert in other program
> with middle mouse key

Geany -> Terminator     = WORKSFORME.
Geany -> Iceweasel      = WORKSFORME.
Iceweasel -> Geany      = WORKSFORME.
Iceweasel -> Terminator = WORKSFORME.
Terminator -> Geany     = WORKSFORME.
Terminator -> Iceweasel = WORKSFORME.

(In reply to comment #1)
> 1. when i mark something it needs to stay marked so you are able to paste it
> with middel mouse in Libreoffice again 

For me, in Writer the original highlight remains, allowing re-pasting, while in Calc the pasted content is highlighted (which also allows re-pasting).

So, apart from the multiple Writer paragraph (partial paste) issue and paste between Calc sheets issue (separate bug), under Crunchbang 11 x86_64 + Openbox at least, this WORKSFORME.
Comment 4 Robinson Tryon (qubit) 2014-10-20 09:12:30 UTC
TESTING with LO 4.3.2.2 + Ubuntu 14.04 (and Gnome 3.9.90)
GEdit 3.10.4
FF 33.0

(In reply to manuelsoukup from comment #1)
> 1. when i mark something it needs to stay marked so you are able to paste it
> with middel mouse in Libreoffice again

Highlighting the text works fine (and the text will stay highlighted after multiple paste action via the middle mouse button)

> but bearable, but still i have to be very carfully not no de-mark it
> otherwise i cant paste it in again.

De-marking (or perhaps to be more precise, un-highlighting) a section does appear to preclude further pasting of that text via the middle mouse button. Firefox doesn't show this behavior, but GEdit does.

> 2. when i pass something with the middle mouse button, the page jumps back
> to the place where i marked something, so i have to scroll back to the place
> i actually work on because i passed something in at this place not on the
> marked spot!
> This is really annoying when you have a big document with more than 3 pages!

CONFIRMED

Both Firefox and GEdit keep the current position in the file. LO is the only application I've tested so far with this behavior. It makes using the paste-via-middle-mouse-button much more difficult.

> Inother thing: i cant precisly set the point for inserting because this
> would demark the stuff (as i have to click at some place to set the cursor
> there) i wanted to paste and it will not get passed because it got demarked.

CONFIRMED
It is hard to accurately paste w/the middle mouse button under these constraints.
Comment 5 Robinson Tryon (qubit) 2014-10-20 09:17:25 UTC
(In reply to manuelsoukup from comment #1)
> I can confirm this. It is also happening with KDE or XFCE.
> 
> Also this is happening since I Libreoffice or OO know. At leat since version
> 3.1 OpenOffice. 

Version -> Inherited from OOo
Comment 6 QA Administrators 2015-12-20 16:10:37 UTC Comment hidden (obsolete, spam)
Comment 7 QA Administrators 2017-01-03 19:47:31 UTC Comment hidden (obsolete, spam)
Comment 8 haenig 2017-07-19 10:58:08 UTC
the bug is back again in LibreOffice 5.4.1

OS is openSuSE Tumbleweed 64bit with XFCE
thomas@thomas:~> rpm -qi libreoffice
Name        : libreoffice
Version     : 5.4.0.1
Release     : 1.2
Architecture: x86_64

what
works: mark with left mouse key in LibreOffice  -> insert in other program with middle mouse key
works not: mark with left mouse key in other program -> than paste in LibreOffice with middle mouse key
works not: mark with left mouse key in LibreOffice -> paste in LibreOffice with middle mouse key
works: mark with left mouse key in other program -> insert in other program with middle mouse key

therefore the behaviour is identically to what the thread starter wrote.

the bug was _NOT_ present in LibreOffice 5.0.6.3 as well as in some 4.x Versions (used/checked with openSuSE 13.2 with XFCE too)
Comment 9 Paul Menzel 2017-08-04 12:59:14 UTC
(In reply to haenig from comment #8)
> the bug is back again in LibreOffice 5.4.1
> 
> OS is openSuSE Tumbleweed 64bit with XFCE
> thomas@thomas:~> rpm -qi libreoffice
> Name        : libreoffice
> Version     : 5.4.0.1
> Release     : 1.2
> Architecture: x86_64
> 
> what
> works: mark with left mouse key in LibreOffice  -> insert in other program
> with middle mouse key
> works not: mark with left mouse key in other program -> than paste in
> LibreOffice with middle mouse key
> works not: mark with left mouse key in LibreOffice -> paste in LibreOffice
> with middle mouse key
> works: mark with left mouse key in other program -> insert in other program
> with middle mouse key
> 
> therefore the behaviour is identically to what the thread starter wrote.
> 
> the bug was _NOT_ present in LibreOffice 5.0.6.3 as well as in some 4.x
> Versions (used/checked with openSuSE 13.2 with XFCE too)

We are having the same problem with LibreOffice 5.4.0.3. I created the new bug  #111339 [1].

[1] https://bugs.documentfoundation.org/show_bug.cgi?id=111339
Comment 10 Julien Nabet 2017-08-04 13:35:50 UTC
*** Bug 111339 has been marked as a duplicate of this bug. ***
Comment 11 Aron Budea 2017-08-04 13:52:38 UTC
My experience is indeed that it's working in 5.3, but there is a regression in 5.4. Therefore since the original issue was fixed, I'm closing this report.

The regression can be followed in bug 110988.