Bug Hunting Session
Bug 62073 - editing/formatting: pasting formatted font messes up formatting of bullets
Summary: editing/formatting: pasting formatted font messes up formatting of bullets
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: x86-64 (AMD64) All
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-09 18:12 UTC by kaesezeh
Modified: 2017-12-24 07:23 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
step1 (5.98 KB, image/png)
2013-03-09 18:12 UTC, kaesezeh
Details
step2 (6.05 KB, image/png)
2013-03-09 18:13 UTC, kaesezeh
Details
step3 (5.37 KB, image/png)
2013-03-09 18:13 UTC, kaesezeh
Details
odp example (11.13 KB, application/vnd.oasis.opendocument.presentation)
2013-04-08 20:57 UTC, kaesezeh
Details
step 1 in example (4.59 KB, image/png)
2013-04-08 20:58 UTC, kaesezeh
Details
step 2 in example (8.63 KB, image/png)
2013-04-08 20:58 UTC, kaesezeh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kaesezeh 2013-03-09 18:12:48 UTC
Created attachment 76234 [details]
step1

This may be related to

- Bug 34660 - FORMATTING bullets change font.
- Bug 49103 - EDITING: Changing font colour on a bullet list does not change the colour of bullet points or list numbering

I have a slideshow with a bulleted list from my master slide. I change the formatting of one letter in indentation level 3 and paste that letter into another line with indentation level 3 and it messes up the bullet point, which becomes a bit bigger. Worse even, if you undo this, the bullet becomes even bigger! See sequence of screenshots
Comment 1 kaesezeh 2013-03-09 18:13:03 UTC
Created attachment 76235 [details]
step2
Comment 2 kaesezeh 2013-03-09 18:13:16 UTC
Created attachment 76236 [details]
step3
Comment 3 Joel Madero 2013-04-08 20:34:51 UTC
Please provide an actual document that we can do the copy/paste to and see the bullet style changes.


Marking as NEEDINFO, once you attach document mark as UNCONFIRMED and we will investigate


Thanks!
Comment 4 kaesezeh 2013-04-08 20:57:37 UTC
Created attachment 77637 [details]
odp example
Comment 5 kaesezeh 2013-04-08 20:58:00 UTC
Created attachment 77638 [details]
step 1 in example
Comment 6 kaesezeh 2013-04-08 20:58:19 UTC
Created attachment 77639 [details]
step 2 in example
Comment 7 Joel Madero 2013-04-08 21:17:51 UTC
So I'm still confused about what you're saying. 

you only have one line at level 3 so when you say "paste that letter into another line with indentation level 3" what are you referring to?
Comment 8 kaesezeh 2013-04-10 02:23:59 UTC
You can paste it into the same line or another one you generated with ENTER.


On Mon, Apr 8, 2013 at 2:17 PM, <bugzilla-daemon@freedesktop.org> wrote:

>  Joel Madero <jmadero.dev@gmail.com> changed bug 62073<https://bugs.freedesktop.org/show_bug.cgi?id=62073>
>  What Removed Added  Status NEEDINFO UNCONFIRMED  Ever confirmed 1
>
>  *Comment # 7 <https://bugs.freedesktop.org/show_bug.cgi?id=62073#c7> on bug
> 62073 <https://bugs.freedesktop.org/show_bug.cgi?id=62073> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> So I'm still confused about what you're saying.
>
> you only have one line at level 3 so when you say "paste that letter into
> another line with indentation level 3" what are you referring to?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 9 Joel Madero 2013-04-15 02:35:54 UTC
For me the issue is even worse, no need to change font size at all, just copy/paste that last line onto another line and you'll see the bad behavior.

As far as I can tell this has always been broken but I confirmed on 3.6.5.2

I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Normal - prevents high quality work
High - very common task, copy paste a line, expect result to be identical


Also adding to 3.6 MAB.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 10 tommy27 2013-08-09 15:27:39 UTC
same findings reported by Joel Madero.

tested on Windows 7 64bit with LibO 3.3.4, 4.0.4 and 4.1.0

I change version and platform accordingly and move this from mab3.6 to mab4.0 list since 3.6.x is EOL.
Comment 11 Cor Nouws 2013-09-06 15:22:21 UTC
ah well, as work around: Paste Special > Text only (which is my default way of pasting anyway ..)
Comment 12 Björn Michaelsen 2014-01-17 09:58:25 UTC Comment hidden (obsolete)
Comment 13 stragu 2014-02-13 23:14:13 UTC
Moving to mab4.1 (Bug 60270) because:
- 4.0 reached EOL (End Of Life)
- bug confirmed in later version
Comment 14 tommy27 2014-05-03 08:09:32 UTC
still reproducible with 4.2.3.3 and 4.3.0.0alpha1

moving to the mab4.2 list since 4.1.x is END OF LIFE
Comment 15 tommy27 2014-12-08 09:14:12 UTC
still reproducible under Win8.1 x64 using LO 4.3.4.1 and 4.5.0.0.alpha0+
Build ID: 6b096f273ac9d7bbe93d2cb083958b3a04866d73
TinderBox: Win-x86@42, Branch:master, Time: 2014-12-04_22:57:23

moving to mab4.3 list since 4.2.x is EOL
Comment 16 QA Administrators 2016-11-08 11:20:55 UTC Comment hidden (obsolete)
Comment 17 Mark Hung 2017-12-22 06:48:00 UTC
I can't reproduce in 
Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 8; OS: Windows 6.2; UI render: default; 
Locale: zh-TW (zh_TW); Calc: group

Maybe this has been resolved.
Comment 18 tommy27 2017-12-24 07:23:34 UTC
norepro anymore using LibO 5.3.6. bug is gone.