Download it now!
Bug 62091 - Impress crashes while trying to add video in avi format (MPEG-4 codec)
Summary: Impress crashes while trying to add video in avi format (MPEG-4 codec)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 08:55 UTC by Aleksey
Modified: 2015-01-13 14:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aleksey 2013-03-10 08:55:22 UTC
Greetings.

When I try in insert into presentation video file in avi format (MPEG-4 codec) LO Impress crashed. Terminal output:


LibreOffice(29706) KSambaSharePrivate::testparmParamValue: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf
Loaded services file OK.
ERROR: pid directory /var/run/samba does not exist
" 
libva: VA-API version 0.33.0
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib64/dri/i965_drv_video.so
libva: Found init function __vaDriverInit_0_33
libva error: /usr/lib64/dri/i965_drv_video.so init failed
libva: va_openDriver() returns -1

ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib64/gstreamer-0.10/libgstffmpeg.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap --gst-disable-registry-fork and debug.


I have both versions of gstreamer (both 0.10 and 1.0) installed. I also have both gstreamer-0_10-plugins-ffmpeg and gstreamer-plugins-libav packages installed.

OS: OpenSUSE 12.2 64 bit
Source of LO installation: http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_12.2/


Best regards,
Aleksey
Comment 1 Julien Nabet 2013-03-16 17:00:15 UTC
Aleksey: just to be sure, is the avi file on local or on a Samba share?
If on a Samba share, can you copy the file on local and give it a new try?
Comment 2 Aleksey 2013-03-16 17:04:08 UTC
(In reply to comment #1)
> Aleksey: just to be sure, is the avi file on local or on a Samba share?
> If on a Samba share, can you copy the file on local and give it a new try?

Thanks for paying attention to this issue. I tried with local files. No network things.

Best regards,
Aleksey.
Comment 3 Aleksey 2013-03-16 17:06:07 UTC
In fact, I was a bit surprised that gstreamer-0.10 library was used (/usr/lib64/gstreamer-0.10/libgstffmpeg.so). As I read in LO 4.0 preview, LO has migrated to Gstreamer 1.0...
Comment 4 Julien Nabet 2013-03-16 17:09:00 UTC
Aleksey: ok, thank you for the quick feedback. I asked because saw KSambaSharePrivate.

Could you try to retrieve a backtrace by following this link? (see https://wiki.documentfoundation.org/BugReport#How_to_get_a_backtrace_on_Linux)

Michael: I put you on cc, you might be interested in this one.
Comment 5 Aleksey 2015-01-13 14:28:18 UTC
This bug is not reproducible in latest versions of LO. Thanks!