Download it now!
Bug 62106 - UI: User field and date format
Summary: UI: User field and date format
Status: RESOLVED DUPLICATE of bug 30873
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.5.2 release
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 15:05 UTC by Filippo Maguolo
Modified: 2015-03-22 16:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
On my computer (77.17 KB, image/jpeg)
2013-04-15 20:33 UTC, crazyskeggy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Filippo Maguolo 2013-03-10 15:05:07 UTC
Problem description: 

Editing a user field with date format, show different value on dialog compared to previously inserted value.

Steps to reproduce:
1. new text document
2. select menu "Insert" -> "Fields..." -> "Other..."
3. select tab "Variables" -> Type "User field"
4. select Format "Additional formats..." 
5. select Category "Date" then select "Ok"
6. insert "Name" and "Value"
7. select "Insert" and "Close"

8. double clock on field, then on "Value" appear a strange number

Current behavior:

Show wrong date value

Expected behavior:

To view date value inserted by user


              
Operating System: All
Version: 4.0.1.2 release
Comment 1 crazyskeggy 2013-04-15 20:33:16 UTC
Created attachment 78017 [details]
On my computer

I'm not sure what you mean - is it like this?
Comment 2 Filippo Maguolo 2013-04-16 08:06:20 UTC
(In reply to comment #1)
> Created attachment 78017 [details]
> On my computer
> 
> I'm not sure what you mean - is it like this?

Yes, this is the function I meant, but if you change date value and click "OK" without click on "V" icon next to the value, then when you re-edit field odd numbers appear.
Comment 3 Joel Madero 2013-04-16 20:49:39 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version 3.6.5.2 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm this problem on an earlier release I am changing the version number as version is the earliest version that we can confirm the bug, we use comments to say that the bug exists in newer versions as well.

Marking as:

New (confirmed)
Trivial - doesn't affect the page at all, just showing the number value of the date instead of the date in the "value" field. On the page itself you see the correct date formatting.

Low - doesn't affect professional work at all, furthermore you can still edit the value as a date (ie. change the number to something like 01/01/2012) and it will work fine.

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 4 QA Administrators 2015-03-04 02:20:56 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 5 Buovjaga 2015-03-22 13:54:43 UTC
Yep, put 31.12.99 as the value and double clicking showed 36525 in the value input field.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 6 Joel Madero 2015-03-22 16:07:18 UTC
This is a dupe of a much older bug - marking as such.

*** This bug has been marked as a duplicate of bug 30873 ***