Download it now!
Bug 62114 - Link to linked picture.jpg lost after FILESAVE as .xlsx
Summary: Link to linked picture.jpg lost after FILESAVE as .xlsx
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
: 97914 (view as bug list)
Depends on:
Blocks: XLSX
  Show dependency treegraph
 
Reported: 2013-03-10 16:13 UTC by Rainer Bielefeld Retired
Modified: 2018-12-18 11:30 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (230.09 KB, application/x-zip-compressed)
2013-03-10 16:13 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-03-10 16:13:05 UTC
Created attachment 76276 [details]
Test Kit

Steps how to reproduce:

1. open SampleDocument.ods from attached test kit
   > shows the .jpg from test kit
2. Save as SampleDocument.xlsx (MSO2007)
3. Close / Reopen
   Bug: only placeholder shown, menu 'Edit -> Links' greyed out

[Reproducible] with "LibreOffice Portable 3.3.0  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:6) tag libreoffice-3.3.0.4]" 

Still a problem with parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 61add5c77de1ff963b839020c77f67f14ef07de) TinderBox: Win-x86@6, Branch:master, Pull Time:  2013-03-05_00:20:08" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile 

I believe this one is related to or DUP of "Bug 45286 - FILESAVE as .xlsx destroys link to linked contents"

Dataloss, so Major
Comment 1 A (Andy) 2013-03-30 09:03:57 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

@Kohei: Could this issue maybe be something for you?
Comment 2 QA Administrators 2015-02-19 15:41:25 UTC Comment hidden (obsolete)
Comment 3 A (Andy) 2015-02-20 20:46:23 UTC
Reproducible with LO 4.4.0.3, Win 8.1
Comment 4 Xisco Faulí 2015-08-25 15:50:43 UTC
Problem still present in

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)
Comment 5 raal 2016-02-16 19:55:20 UTC
*** Bug 97914 has been marked as a duplicate of this bug. ***
Comment 6 QA Administrators 2017-03-06 15:10:01 UTC Comment hidden (obsolete)
Comment 7 Roman Kuznetsov 2018-12-18 11:30:02 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: 3c964980da07892a02d5ac721d80558c459532d0
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-12-12_02:07:45
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

reopened xlsx file in LO and in MSO 2010 shows me an image

Status->WFM