Bug Hunting Session
Bug 62197 - PRINTING: Page and table borders print in wrong place
Summary: PRINTING: Page and table borders print in wrong place
Status: RESOLVED DUPLICATE of bug 60280
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-03-12 06:01 UTC by A D
Modified: 2013-12-15 23:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
photo of page with wrong borders (1.56 MB, image/jpeg)
2013-03-12 06:01 UTC, A D
Details
screen of normal looking page in writer (59.23 KB, image/png)
2013-03-12 06:03 UTC, A D
Details
normal-looking page in writer (59.23 KB, image/png)
2013-03-12 06:06 UTC, A D
Details
.odt file with print bug (37.63 KB, application/vnd.oasis.opendocument.text)
2013-03-19 12:33 UTC, A D
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A D 2013-03-12 06:01:38 UTC
Created attachment 76357 [details]
photo of page with wrong borders

Problem description: after installing 4.0.1.2 (ID сборки: 84102822e3d61eb989ddd325abf1ac077904985) and russian langpack page  and tables borders prints in wrong place on any printer


              
Operating System: Windows XP
Version: 4.0.1.2 release
Last worked in: 4.0.0.3 release
Comment 1 A D 2013-03-12 06:03:25 UTC
Created attachment 76358 [details]
screen of normal looking page in writer
Comment 2 A D 2013-03-12 06:06:31 UTC
Created attachment 76360 [details]
normal-looking page in writer

previous attachment wrong
Comment 3 Cor Nouws 2013-03-19 12:23:34 UTC
Hi AD,
Can you pls attach a sample file?
thanks,
Comment 4 A D 2013-03-19 12:33:40 UTC
Created attachment 76749 [details]
.odt file with print bug

from this file wrong prints all borders - page, all tables. It looks like borders increased by 5-10 from left-top page corner
Comment 5 Cor Nouws 2013-03-19 13:41:41 UTC
I cannot reproduce this on Linux with 4.0.1rc2 and 4.0.2rc1. 
However, I didd not install the Russian languagepack
Comment 6 A D 2013-03-19 14:46:47 UTC
tomorrow I try make clean reinstall of LO and reproduce bug on on another win comps
Comment 7 A D 2013-03-20 06:19:32 UTC
after reinstall 4.0.1.2 and on anather compwith 4.0.0.3 LO some bug with printing
Comment 8 Timur 2013-03-27 12:03:14 UTC
Please see https://bugs.freedesktop.org/show_bug.cgi?id=62719#c4.
Comment 9 A D 2013-03-27 12:13:26 UTC
I can confirm bug 62719, printed tables have no borders, also i use HP printers
Comment 10 tiberX 2013-04-11 14:09:06 UTC
Same problem.
4.0.2.2
Either lines of a table in the wrong place or not a bit printed
Printer: new BROTHER, older SAMSUNG
Comment 11 Laurent 2013-04-14 15:54:56 UTC
Hello,
I have a similar problem (w7 64bits / epson B40W)
The borders of the header are printed more low by in the page.
Also vertical border between columns becomes horizontal.
The problem disappears when switching to LO 3.6

On the other hand, there's no problem when converting to pdf.


(Please excuse me for my approximate English)
Comment 12 Joel Madero 2013-04-15 03:45:16 UTC
This is almost undoubtedly NOTOURBUG, the reason I say this is because the print to pdf works. 

Within LibreOffice Print -> Options -> Print to File

Click Print, name the pdf, push print to file..

If the result of that is right, then it's not our bug. This is EXACTLY what we send to the printer, if the outcome is bad is is more than likely a driver problem for the printer. 

To test further, if the PDF is right, print from your pdf viewer, if the result is bad again, this is further proof that it's the print driver.


Marking as NOTOURBUG - if:

1. You print to file and it looks funky too, mark as UNCONFIRMED and we will reinvestigate

2. You print to pdf, looks fine, prints fine, mark as UNCONFIRMED

If you find that it's your driver, I recommend reporting a bug against your printer driver.
Comment 13 Timur 2013-04-16 12:51:54 UTC
I can't agree it's a problem with drivers. I have the same problem with Lexmark printer.
Comment 14 Joel Madero 2013-04-16 14:21:12 UTC
what about a print to pdf?
Comment 15 Timur 2013-04-19 08:25:58 UTC
Similar to https://bugs.freedesktop.org/show_bug.cgi?id=62719#c4, Export as PDF works fine, and Print doesn't. I tested with libreoffice-4-0~2013-04-19_04.53.00_LibO-Dev_4.0.4.0_Win_x86 on Windows 7 64bit with direct print to printer Lexmark and printing to PDF with PDFill and BullZip software.
Comment 16 Timur 2013-04-26 08:37:25 UTC
Can you please respond? I suggest it be set as NEW and given some higher importance. 
I find that "Importance" is not clear for end-user, nor is it explained at https://bugs.freedesktop.org/page.cgi?id=fields.html#importance, so I kindly ask you to add an explanation.
Comment 17 Joel Madero 2013-04-26 13:55:31 UTC
Getting another QA person involved.

Bjoern - tough one here, thoughts?
Comment 18 Björn Michaelsen 2013-04-26 15:25:44 UTC
(In reply to comment #12)
> Click Print, name the pdf, push print to file..

This still isnt anwsered, right? Does generating a pdf and then physically printing it work?
Comment 19 Timur 2013-04-26 15:38:21 UTC
(In reply to comment #18)
> (In reply to comment #12)
> > Click Print, name the pdf, push print to file..
> 
> This still isnt anwsered, right? Does generating a pdf and then physically
> printing it work?

Yes, it works. 
Can you please explan why it doesn't work both for direct print and printing to PDF software?
Comment 20 Panos Stokas 2013-04-27 05:31:07 UTC
Contains OLE objects. Thankfully, it's been recently fixed.

*** This bug has been marked as a duplicate of bug 60280 ***