Bug 62281 - About box is missing a window title
Summary: About box is missing a window title
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: All All
: medium trivial
Assignee: Adolfo Jayme
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-13 10:04 UTC by ibramlab
Modified: 2020-01-02 07:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Bug's screenshot (1.03 MB, image/png)
2013-03-13 10:04 UTC, ibramlab
Details
Screenshot for 4.2.4.2 version (42.00 KB, image/png)
2014-07-01 12:30 UTC, ibramlab
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ibramlab 2013-03-13 10:04:31 UTC
Created attachment 76460 [details]
Bug's screenshot

'About' window in LibreOffice doesn't have a caption. This is also reflected in taskbar panel (I don't know how it is exactly called in english. Just a panel which is on bottom with default settings and all Windows are shown there as a small panels). I attached a screenshot with it.
Comment 1 Jorendc 2013-05-21 19:59:04 UTC
hi,

Thanks for reporting, but I can not reproduce this anymore using Linux Mint 15 x64 with LibreOffice 4.0.3.3. There is now 'LibreOffice 4.0' in the window title. Can you verify that?

Kind regards,
Joren
Comment 2 ibramlab 2013-05-21 22:08:55 UTC
Jorendc, I updated LO via update manager in Lubuntu 12.04 to 4.0.3.3. But problem still exists. I have same situation with GUI. Only version was changed in About dialog.
Comment 3 QA Administrators 2013-12-22 21:58:50 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 4 tommy27 2014-02-19 06:36:56 UTC
@ibramlab
do you still experience this bug with current 4.1.5 or 4.2.0 final releases?
Comment 5 ibramlab 2014-02-19 08:06:52 UTC
tommy27, yes I still experience with 4.2.0.4 Build ID: 420m0(Build:4)
Comment 6 retired 2014-05-07 12:46:09 UTC
4.2.3.3 shows "LibreOffice 4.2" in the title of the about window under ubuntu 14.04.

If this persists with that or a newer version, please re-open.
Comment 7 ibramlab 2014-07-01 12:30:25 UTC
Created attachment 102067 [details]
Screenshot for 4.2.4.2 version
Comment 8 ibramlab 2014-07-01 12:31:21 UTC
Still has this bug active with 4.2.4.2 version with Xubuntu 12.04. Screenshot  updated.
Comment 9 retired 2014-07-03 01:20:26 UTC
Looks like this is Xubuntu related or Ubuntu 12.x specific. Thanks for the update.
Comment 10 Maxim Monastirsky 2014-07-03 08:03:10 UTC
Reproducible with 4.3.0.2 under Windows 7. Indeed this dialog doesn't have a title - have a look at http://opengrok.libreoffice.org/xref/core/cui/uiconfig/ui/aboutdialog.ui. The title "LibreOffice 4.2" mentioned here is set by the window manager (for any window without a title), not by LO.
Comment 11 Commit Notification 2014-09-23 09:25:10 UTC
Adolfo Jayme Barrientos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=333c5c1b8b3283d5f5ebe77f16532a84b6d07d70

fdo#62281 Add a title to the About dialog



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.