Bug Hunting Session
Bug 62456 - Vertically flipped shape anchored to cell at wrong position and wrong size when reopen .ods
Summary: Vertically flipped shape anchored to cell at wrong position and wrong size wh...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2013-03-18 07:51 UTC by Rainer Bielefeld Retired
Modified: 2019-09-08 16:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (8.09 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2013-03-18 07:51 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2013-03-18 07:51:03 UTC
Created attachment 76675 [details]
Sample Document

I found this one during my tests for "Bug 62448 - FILESAVE .ods with wrong double size of vertically flipped (triangle) drawing shape anchored to cell"

Steps how to reproduce with Server Installation of "LibreOffice 3.3.3  English UI/ German Locale [OOO330m19 (Build:301) tag libreoffice-3.3.3.1] on German WIN7 Home Premium (64bit):
1. Open new spreadsheet from LibO Start Center:
2. draw a Basic Shape Triangle with cell width and similar height, bas line 
   = bottom border of cell D24
3. 'Rightclick shape -> Flip -> Vertically'
4. If necessary ''Rightclick shape -> Anchor -> To Cell'
5. Save -> Close -> Reopen
   Expected: Shape at old position
   Actual: shifted approximately 1 shape width to the left and 1 shape height up

Already a problem with OOo 2.0

I can't tell whether it's a FILEOPEN or a FILESAVE problem. But Later versions show an additional Fileopen problem.

Until 
server installation of "LibO  4.0.1.2 release   -  German UI / German Locale  [Build ID: 84102822e3d61eb989ddd325abf1ac077904985)]"  {tinderbox: @6, pull time  2013-02-28 08:53(?)} on German WIN7 Home Premium (64bit) with newly created user profile ….\LibreOffice\4012\ 
the shape in attached sample document will be shown in D16D19 (instead of D20:D23).

Parallel Dev-installation of  "Version 4.1.0.0.alpha0+ (Build ID: 61add5c77de1ff963b839020c77f67f14ef07de) TinderBox: Win-x86@6, Branch:master, Pull Time:  2013-03-05_00:20:08" ENGLISH UI / German Locale  on German WIN7 Home Premium (64bit) with LODev/4 Masters User Profile 
Shows the shape in the sample document more shifted in B12:B15
Comment 1 Rainer Bielefeld Retired 2013-03-18 07:54:26 UTC
Related: "AOOo#18868 - vertical flipped custom shape opens with wrong position"

Relation to Cell anchor, flipping and so on can be seen in Attachment 76673 [details] for Bug 62448
	

@Spreadsheet Team
Please change  Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf (and remove others in team from CC).
Comment 2 QA Administrators 2015-03-17 00:07:25 UTC Comment hidden (obsolete)
Comment 3 Faisal Menawer 2015-03-17 05:02:59 UTC
the bug still reproduced
i use Libreoffice Version: 4.5.0.0.alpha0+
on Linux mint 17 cinnamon 64-bit
Comment 4 tommy27 2016-04-16 07:23:10 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-05-22 13:22:49 UTC Comment hidden (obsolete)
Comment 6 Timur 2017-11-13 18:02:52 UTC
Behavior is different from scratch and with attachment 76675 [details]. Anyway, repro.
Comment 7 QA Administrators 2018-11-14 03:45:50 UTC Comment hidden (obsolete)
Comment 8 Regina Henschel 2019-09-08 16:16:34 UTC
I cannot reproduce it with Version: 6.4.0.0.alpha0+ (x64)
Build ID: 396869e0e71bd33f5d962779abf72f35d01245e5
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win; 
Locale: de-DE (en_US); UI-Language: en-US
Calc: threaded