Bug 62480 - UI Display corruption
Summary: UI Display corruption
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-18 17:24 UTC by DOS286
Modified: 2013-04-18 16:24 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Calc (48.99 KB, image/jpeg)
2013-03-18 17:24 UTC, DOS286
Details
about (49.17 KB, image/jpeg)
2013-03-18 17:25 UTC, DOS286
Details
Main (48.70 KB, image/jpeg)
2013-03-18 17:25 UTC, DOS286
Details

Note You need to log in before you can comment on or make changes to this bug.
Description DOS286 2013-03-18 17:24:37 UTC
Created attachment 76691 [details]
Calc

UI display becomes corrupt and illegible if Ubuntu has font anti-aliasing selected. Un-checking anti-aliasing options in Menu/Tools/Options/LibreOffice/View does not help, only turning off sytem-wide anti-aliasing helps. But of course, then my system fonts are ugly.

System: Intel(R) Pentium(R) 4 CPU 3.00GHz
Fequency: 2992.504 MHz
Memory: 3023 MiB
Video: NVIDIA UNIX x86 Kernel Module  304.64
OS: Ubuntu 12.04 (precise)
Kernel: 3.2.0-38-generic-pae
LibreOffice: Version 4.0.1.2 (Build ID: 84102822e3d61eb989ddd325abf1ac077904985)

I've attached a couple of screen shots.
Comment 1 DOS286 2013-03-18 17:25:20 UTC
Created attachment 76692 [details]
about
Comment 2 DOS286 2013-03-18 17:25:45 UTC
Created attachment 76693 [details]
Main
Comment 3 Jorendc 2013-03-19 17:08:20 UTC
Hi,

Thanks for reporting!
That looks really bad. I see you tested already the anti-aliasing options, so I can't suggest anything more. Because this is not reproducible anymore if you turn off the anti-aliasing of your OS, I assume unchecking Menu>Tools>Options>LibreOffice>View "Use hardware acceleration" would not resolve this issue?

@Bjoern: OS = Ubuntu; This is a know problem? Any suggestions?

Kind regards,
Joren
Comment 4 DOS286 2013-03-19 18:11:35 UTC
(In reply to comment #3)
> Hi,
> 
> Thanks for reporting!
> That looks really bad. I see you tested already the anti-aliasing options,
> so I can't suggest anything more. Because this is not reproducible anymore
> if you turn off the anti-aliasing of your OS, I assume unchecking
> Menu>Tools>Options>LibreOffice>View "Use hardware acceleration" would not
> resolve this issue?
> 
> @Bjoern: OS = Ubuntu; This is a know problem? Any suggestions?
> 
> Kind regards,
> Joren

unchecking Menu>Tools>Options>LibreOffice>View "Use hardware acceleration" did not help.
Comment 5 Björn Michaelsen 2013-03-19 19:00:32 UTC
Does it work with neither the closed source, nor the open source nouveau drivers?
Comment 6 DOS286 2013-03-19 19:37:55 UTC
(In reply to comment #5)
> Does it work with neither the closed source, nor the open source nouveau
> drivers?

The problem seems to disappear with the open source drivers. I'll post again if it re-occurs.
Comment 7 DOS286 2013-04-04 18:21:04 UTC
I switched back to the closed source drivers. I was getting system hangs with the open source that don't happen with the closed source.

Any way to fix this with the closed source drivers?
Comment 8 Joel Madero 2013-04-18 02:09:08 UTC
Is this an issue with every release of LibreOffice? Or is this a regression? This is quite bad :(
Comment 9 Björn Michaelsen 2013-04-18 11:26:52 UTC
(In reply to comment #7)
> Any way to fix this with the closed source drivers?

Yes: nag Nvidia about it.
Comment 10 DOS286 2013-04-18 13:17:08 UTC
It seems odd to nag Nvidia when only one program is affected. If it's a driver issue, how come no other program has an issue?
Comment 11 Joel Madero 2013-04-18 13:44:13 UTC
Unfortunately since their driver is closed source we really don't know and have no way of finding out.

Marking as NOTOURBUG -- apologies, if you go back to the open source driver and report bugs against it, you'll probably have much better luck getting it fixed.
Comment 12 DOS286 2013-04-18 16:10:44 UTC
Ah... the joys of mixing open and closed source. Sometimes I'm amazed that all these puzzle piece fit together as well as they do; that anything works at all!

It's a tribute to all of you who donate your time and talents to freeware. Thanks!
Comment 13 Joel Madero 2013-04-18 16:24:33 UTC
Indeed - is 3.6 an issue for you as well? If we see an actual regression of some kind in our product, maybe we can dig further but as of now it seems 100% to be Nvidia's issue