Bug 62542 - EDITING: Strange behavior when pasting text from Writer into Impress
Summary: EDITING: Strange behavior when pasting text from Writer into Impress
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Paste
  Show dependency treegraph
 
Reported: 2013-03-19 23:10 UTC by Pericle Perazzo
Modified: 2019-01-10 10:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
A presentation where I copied a text into. (19.75 KB, application/vnd.oasis.opendocument.presentation)
2013-03-19 23:10 UTC, Pericle Perazzo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pericle Perazzo 2013-03-19 23:10:24 UTC
Created attachment 76784 [details]
A presentation where I copied a text into.

This is actually a 3-in-1 bug.

If I copy&paste some text from Writer to Impress, it exhibits some strange behaviors:
1) It does not copy the text, as expected, but a Writer object containing the text. This may be or not a desired behavior, but:
2) The Writer object is littler than the text it contains. So only a part of the text is displayed.
3) If I "open" the Writer object (by double-clicking it), resize it and close it, the text is not in the same position as before. In particular it moves toward the bottom-right angle. I think it's a problem of the rulers which are displayed when the Writer object gets opened.

The bug #1 could be a feature, though IMHO it should not be the default copy&paste behavior, but rather a "special paste" behavior.
I found bugs #1 and #2 also in OpenOffice 3.3.0.
On the contrary, bug #3 is LibreOffice-specific. Note that bug #3 is not present if I special-paste a Draw object inside an Impress presentation.

Operating System: Windows 7
Version: 4.0.1.2 release
Comment 1 Thorsten Behrens (CIB) 2013-03-20 08:19:45 UTC
(In reply to comment #0)
> This is actually a 3-in-1 bug.
> 
Please only one problem per filed bug report.
Comment 2 Pericle Perazzo 2013-03-20 08:48:24 UTC
I think problem #2 and #3 are quite the same bug about Writer object sizeing. Problem #1 is different.

Should I split the bug by cloning it?
Comment 3 ign_christian 2013-06-03 07:58:22 UTC
Hi Pericle 

As mentioned on Comment 1, you should only report 1 bug per bug report. So this bug should be splitted.

I suggest you do search first, perhaps someone has been reported:
https://bugs.freedesktop.org/query.cgi?format=advanced
Comment 4 Rob Snelders 2013-10-05 11:27:22 UTC
Pericle Perazzo: Yes please split the bugs. If parts are duplicates please add the bugs to see also. If a bug is new then create a new bug for it and put also in the see also. The user can be added as cc to the bugs. Then this bug can be closed as invalid.

Thanks.
Comment 5 immanuelg 2014-07-27 20:30:50 UTC
TESTING
Win7x64
LO 4.3.0.3



> If I copy&paste some text from Writer to Impress, it exhibits some strange
> behaviors:
> 1) It does not copy the text, as expected, but a Writer object containing
> the text. This may be or not a desired behavior, but:
CONFIRMED - paste from clipboard results in text box


> 2) The Writer object is littler than the text it contains. So only a part of
> the text is displayed.
CONFIRMED - text box does not auto-resize to source text length (not all text is visible)


> 3) If I "open" the Writer object (by double-clicking it), resize it and
> close it, the text is not in the same position as before. In particular it
> moves toward the bottom-right angle. I think it's a problem of the rulers
> which are displayed when the Writer object gets opened.

CONFIRMED -  double-click on the object opens new window. When resizing the object to fit the text, and closing, the object moves towards the slide edge.
Comment 6 QA Administrators 2015-09-04 02:49:19 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-11-30 13:22:55 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.2.0.0.alpha0+
Build ID: a7c3a2a9be83686657c06f37d521f9f6d2004ddd
Threads 4; Ver: Windows 6.1; Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2015-11-28_04:39:18
Locale: fi-FI (fi_FI)
Comment 8 QA Administrators 2017-01-03 19:36:02 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.6 or 5.2.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170103