Bug 62702 - OLE object cannot be inserted as an executable Icon
Summary: OLE object cannot be inserted as an executable Icon
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium enhancement
Assignee: Caolán McNamara
QA Contact:
URL:
Whiteboard: BSA target:5.4.0 target:5.3.4
Keywords:
Depends on:
Blocks: Matters-to-Caolan
  Show dependency treegraph
 
Reported: 2013-03-24 16:00 UTC by Zdenek
Modified: 2017-05-09 14:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Document with details of OLE object behaviour in LibreOffice (157.95 KB, application/vnd.oasis.opendocument.text)
2013-03-24 16:00 UTC, Zdenek
Details
example (178.50 KB, application/msword)
2017-05-04 11:59 UTC, Zdenek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zdenek 2013-03-24 16:00:03 UTC
Created attachment 76968 [details]
Document with details of OLE object behaviour in LibreOffice

Problem description:
When one inserts any PDF, Writer, Calc or Impress file as an OLE object into a Writer, Calc or Impress, it is inserted as a frame with visible content of the attached OLE object each time but not as an executable icon.
If I create such OLE objects in MS Office, I can see it in Calc or Writer as expected (icons) and this OLE Object is opened with associated software when it's double clicked.
I do not want to insert Icon of File type as a picture or file as hyperlink. That's not my goal. I need to insert file represented with program icon and send it to other people who can open/see the content of the attached OLE object with doubleclick.


Steps to reproduce:
Please see attached document. All steps are there with screenshots


Current behaviour:
OLE object is not attached as an executable icon but as a frame with visible content.


Expected behaviour:
OLE object is attached as an icon of file type and file name. This object can be opened by anyone with doubleclick


Other information:
1) System info - Fedora 17, kernel 3.8.3-103.fc17.x86_64

2) Tested with 
LibreOffice 3.5.7.2 (default LO from Fedora repository)
LibreOffice 4.0.2.1 (currently installed LO from your web)

3) Previous version of LO was uninstalled and config files were deleted (config files in home dir). After that I installed LibreOffice_4.0.2.1_Linux_x86-64_rpm.tar.gz

4) I experience this bug for several LO releases (probably even from the beginning)
Operating System: Fedora
Version: 4.0.2.1 rc
Comment 1 Owen Genat (retired) 2014-01-06 09:44:45 UTC
Tested under Ubuntu 10.04 x86_64 using:

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.4.2 Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72

In each case Insert > Object > OLE Object > Create New only lists the five usual document types (Chart, Drawing, Presentation, Formula, Text) and omits the required "Further Objects" entry. This additional entry is how OLE objects may be inserted in icon form under Windows, as indicated in the Calc Guide v4.1, p.289 or ch10, p.23. 

This would seem to be an enhancement, although this is not entirely clear, given it may be a MSO compatibility issue. Version set to Inherited From OOo.
Comment 2 Owen Genat (retired) 2014-01-07 00:22:49 UTC
Added related Apache OO issue to See Also list. Although that particular enhancement gives the example of inserting a spreadsheet into a Writer document in icon form, the principle is the same.
Comment 3 Joel Madero 2015-05-02 15:40:54 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-06-20 10:28:08 UTC
Setting to enhancement.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 5 zKnittingCellist 2015-09-25 14:27:52 UTC
This is still a problem. I am using LibreOffice v5.0.1.2 on Ubuntu 15.04. I do not see any changes in the bug behavior as far as creating an icon for an embedded document, it is still only able to create the object in a frame showing the content rather than the icon. 

However, the bug has been fixed to see an icon for an embedded document in a document created by MS Office.
Comment 6 Zdenek 2016-08-05 11:27:42 UTC
I use LibreOffice 5.1.5 now (Fedora 24). I cannot any longer open existing OLE object like I was able to do in the older LO versions.
Is there any chance to have the possibility to open existing OLE documents at least? (If OLE creation is not possible)
Comment 7 Caolán McNamara 2017-05-04 09:40:42 UTC
There now seems to be two problems, the original problem about the inability to insert ole objects in iconified mode, and a newer problem that documents from other formats with iconified objects can no longer launch them ?

Can I get an example attached of something which used to work, but no longer does ?
Comment 8 Zdenek 2017-05-04 11:59:51 UTC
Created attachment 133066 [details]
example

Yes, I confirm - with actual LO versions (5.2, 5.3), I cannot any longer open the existing OLE objects if they exist in the document.
I do not have example from the past (something that worked before but doesn't work now), but I created such example now (under MS Office). This example document "bug.doc" contains the original document attached in this bug report "OLE.Object.bug.odt"

Please try to open this odt file inserted in the example doc. It does nothing in my case.
Comment 9 Buovjaga 2017-05-04 15:11:50 UTC
(In reply to Zdenek from comment #8)
> Please try to open this odt file inserted in the example doc. It does
> nothing in my case.

Do we have to have MS Office installed for it to work? Nothing happens when double-clicking the icon on 4.4.7.2, 5.0.2.2 on a Win 10 without MSO.
Comment 10 Caolán McNamara 2017-05-08 16:14:32 UTC
gio: file:///tmp/lu15905gbra8w.tmp/lu15905gbraas.tmp: No application is registered as handling this file
gsf list /tmp/lu15905gbra8w.tmp/lu15905gbraas.tmp
/tmp/lu15905gbra8w.tmp/lu15905gbraas.tmp:
d                                0 *root*
f                              109 CompObj
f                                6 ObjInfo
f                                0 OCXNAME
f                                0 contents
f                           161740 EmbeddedOdf

this *nearly* worked, we dumped the content to a file and ask the desktop if it was able to open it with anything, which it wasn't. We may be able to extend the dumping hacks for at least this EmbeddedOdf case
Comment 11 Commit Notification 2017-05-09 08:27:04 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8db9cfd2973b3e6f0c682fe8961540d528e6d493

Related: tdf#62702 handle EmbeddedOdf like CONTENTS on ole activate attempt

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2017-05-09 08:35:15 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=013e34d875aeb75d9660af7c18967c2d468cbd74

Related: tdf#62702 also try various other known streams for object content

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2017-05-09 12:39:37 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f505f95d466d4d3348f41dfd93e5c243d15c6c71

Resolves: tdf#62702 allow ole objects to be inserted as icons

It will be available in 5.4.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2017-05-09 13:48:31 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f45915b6c76ace7aeffaa042d487e8e2d7f4d89&h=libreoffice-5-3

Related: tdf#62702 handle EmbeddedOdf like CONTENTS on ole activate attempt

It will be available in 5.3.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 Zdenek 2017-05-09 14:53:11 UTC
Thanks a lot for all the effort and work. I really appreciate it!