Bug Hunting Session
Bug 62708 - EDITING: Format Paintbrush doesn't format all of the selected lines
Summary: EDITING: Format Paintbrush doesn't format all of the selected lines
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-24 21:39 UTC by IgnitorDetonate
Modified: 2013-10-29 05:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example paragraph styles to test format paintbrush against. (32.33 KB, application/vnd.oasis.opendocument.text)
2013-10-26 10:40 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description IgnitorDetonate 2013-03-24 21:39:20 UTC
When using the Format Paintbrush on several lines of text, either only the last line will have it's formatting changed, or the last line will not have it's formatting changed while the rest of the lines will. Which one of these happens appears to be semi random, as the same text with the same formatting will react the same each time.

The text was indented to a custom tab and lines were separated by a manual line breaks. The problem didn't occur when this was not the case 


Side suggestion: allow the Format Paintbrush to be used several times if the shift key is being held.
Operating System: Ubuntu
Version: (See in Summary)
Comment 1 tommy27 2013-08-20 17:09:42 UTC
which LibO version do you experience this bug? have you tried with recent 4.0.4 or 4.1.0 releases?

do you have a test file to upload and step-to-step instruction to reproduce the bug? otherwise it will be hard to help.
Comment 2 Owen Genat (retired) 2013-10-26 10:40:51 UTC
Created attachment 88146 [details]
Example paragraph styles to test format paintbrush against.

This bug is not reproducible under Ubuntu 10.04 running LO v4.1.2.2. The attached ODT contains four paragraphs of text, set in the Default Style, Quotations, Preformatted Text, and List 1 paragraph styles. Placing the cursor on any paragraph, selecting the Format Paintbrush tool, and then highlighting another paragraph while holding down the CTRL key[1] results in all lines of the destination paragraph taking the style of the source paragraph.

>Side suggestion: allow the Format Paintbrush to be used several times if the shift key is being held.

The Format Paintbrush toolbar button can be double-clicked to allow the function to be applied to multiple ad hoc selections (again hold CTRL while painting to copy paragraph attributes). Use ESC to exit this mode.

[1] The instructions in bug #59029 (comments 5 and 11 in particular) indicate that the format paintbrush facility has been altered to now only copy character attributes by default. CTRL is required to copy paragraph attributes.
Comment 3 tommy27 2013-10-27 04:50:42 UTC
@IgnitorDetonate@Gmail.com
do you still reproduce the bug on Ubuntu or could we label this as RESOLVED WORKSFORME?
Comment 4 IgnitorDetonate 2013-10-28 21:16:47 UTC
I am no longer able to reproduce this bug


On Sun, Oct 27, 2013 at 12:50 AM, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 3 <https://bugs.freedesktop.org/show_bug.cgi?id=62708#c3> on bug
> 62708 <https://bugs.freedesktop.org/show_bug.cgi?id=62708> from tommy27<barta@quipo.it>
> *
>
> @IgnitorDetonate@Gmail.com
> do you still reproduce the bug on Ubuntu or could we label this as RESOLVED
> WORKSFORME?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 5 tommy27 2013-10-29 05:44:21 UTC
ok, set status to RESOLVED WFM