Bug Hunting Session
Bug 63323 - Comments in RTL sheet don't point to the appropriate cell
Summary: Comments in RTL sheet don't point to the appropriate cell
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.2.0 target:4.1.0.0.beta2 tar...
Keywords:
: 63252 (view as bug list)
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-04-09 15:50 UTC by Lior Kaplan
Modified: 2013-05-29 05:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
comments location in RTL sheet (76.07 KB, image/png)
2013-04-09 15:51 UTC, Lior Kaplan
Details
testdoc (7.39 KB, application/vnd.sun.xml.calc)
2013-04-09 15:53 UTC, Lior Kaplan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2013-04-09 15:50:26 UTC
When the sheet is RTL, inserting a comment shows it in a wrong location far from the cell. It seems the comment tool tip appear in it's LTR location, although the sheet is RTL.

Steps to reproduce:
1. Open a new sheet, make sure it's RTL.
2. Insert a comment in cell C5, and notice that the tool tip appears near cell H4.
3. Switch the sheet to LTR, and notice the comment tool tip actually points to the cell.

This bug might be relevant for other objects such as graphs.
Comment 1 Lior Kaplan 2013-04-09 15:51:56 UTC
Created attachment 77676 [details]
comments location in RTL sheet
Comment 2 Lior Kaplan 2013-04-09 15:53:28 UTC
Created attachment 77677 [details]
testdoc
Comment 3 Urmas 2013-04-10 03:53:08 UTC

*** This bug has been marked as a duplicate of bug 63252 ***
Comment 4 Lior Kaplan 2013-04-10 06:06:05 UTC
I'm reopening this bug and marking bug 63252 as duplicate to this bug. Cosmetic change, to reuse the attachments here and the fact it was already documented in the RTL bug lists,
Comment 5 Lior Kaplan 2013-04-10 06:06:36 UTC
*** Bug 63252 has been marked as a duplicate of this bug. ***
Comment 6 Faisal Menawer 2013-05-13 06:27:03 UTC
can't confirm with master

I think this has been fixed When Bug 63878 was fixed

can anyone make it sure?
Comment 7 Lior Kaplan 2013-05-17 08:05:01 UTC
I can still reproduce this with master (after the fix for Bug 63878).
Comment 8 Faisal Menawer 2013-05-28 11:09:12 UTC
part of this bug has been fix after the fix for bug 63878.

i upload a patch that will fix the rest

https://gerrit.libreoffice.org/#/c/4069/
Comment 9 Commit Notification 2013-05-28 14:21:22 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3f923bf9cf9b6fe728e7804fdb13aabe620d3dbc

fdo#63323 fix the comment position when the mouse over cell



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Lior Kaplan 2013-05-28 18:35:35 UTC
Fix verified on a build from master.
Comment 11 Commit Notification 2013-05-29 05:36:54 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a0b061bfbd0e87e59a3aa59a07085198868ec62&h=libreoffice-4-1

fdo#63323 fix the comment position when the mouse over cell


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2013-05-29 05:45:40 UTC
Faisal M. Al-Otaibi committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d158bdce41ce0a199ef0e862f667399b571704b6&h=libreoffice-4-0

fdo#63323 fix the comment position when the mouse over cell


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.