Bug 63521 - FILESAVE: LibreOffice Draw - retaining slant and corner radius values
Summary: FILESAVE: LibreOffice Draw - retaining slant and corner radius values
Status: RESOLVED DUPLICATE of bug 39907
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-14 10:15 UTC by frda999-bugzilla
Modified: 2013-07-03 18:33 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description frda999-bugzilla 2013-04-14 10:15:59 UTC
Problem description: 
Rectangular shapes given slant and corner radius values show curved corners on the screen, but these values are not retined when the document is save, closed and reopened.
 
Steps to reproduce:
1. Draw a rectangle
2. From format menu, choose poistion and size
3. Select slant and corner radius tab
4. Give a value for the radius, click OK
5. Observe rounded corners on screen
6. Save document
7. Close document
8. Reopen document
9. Observe that the rectangles no longer have rounded corners

Current behavior:
as above

Expected behavior:
values are retained in the saved document

              
Operating System: Windows 7
Version: 4.0.1.2 release
Comment 1 Szuhánszky Tamás 2013-04-15 11:41:44 UTC
Hi!

I could reproduce this problem, with 4.0.1.2 and 4.0.2.2.
In the master version this option is locked.

Operatin system: Windows 7 64 bit

Ui.: In my opinion it's very important to deal with this problem, but first of all someone else have to confirm my results,
Comment 2 Thomas van der Meulen 2013-04-15 18:31:18 UTC
Hello, I can repoduce this bug running LibreOffice 4.0.2.2 on Mac osx 10.8.3.\
This is very anoying  and importent to fix it.
Comment 3 whoever 2013-04-23 09:39:08 UTC
I can reproduce this bug with 4.0.3.1 (test version) as well. Thus, the problem is still existing. Tested on Mac OS X 10.6.8
Comment 4 Thomas van der Meulen 2013-04-27 09:30:37 UTC
*** Bug 63970 has been marked as a duplicate of this bug. ***
Comment 5 Thomas van der Meulen 2013-04-27 09:33:00 UTC
It looks like this bug also accurs in the Presention program. according to bug report 63970, whit is have tested out. and marked as a duplicate.
Comment 6 kuko 2013-04-30 17:24:00 UTC
My Bad. I recheck and find that I where using an old LANPACK. Sorry for the time I make you lose.
Comment 7 kuko 2013-04-30 17:25:39 UTC
Forget abuot the last comment. Wrong BUG ID.
Comment 8 Jan Kirchner 2013-05-11 13:31:47 UTC
I can confirm that the bug exist probably a long time and I tested it on the versios:
XinXP LO 4.0.2; 4.0.3; Ubuntu 11 LO 3.4.3
Comment 9 Mohith Manoj 2013-07-03 06:24:17 UTC
I have confirmed this behaviour in LO 4.0.4.2 in Win7 x64
Comment 10 retired 2013-07-03 08:59:39 UTC
*** Bug 66536 has been marked as a duplicate of this bug. ***
Comment 11 Regina Henschel 2013-07-03 18:33:29 UTC
The bug is fixed in Version: 4.1.0.0.beta2
(I've got Build ID: 33224f4f11a05cfad2249e812fcc2975fbb61f6)

For background discussion see bug 39907.

*** This bug has been marked as a duplicate of bug 39907 ***