Bug Hunting Session
Bug 64027 - Add ability to set highlight color for text in drawing objects (Writer)
Summary: Add ability to set highlight color for text in drawing objects (Writer)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.1 rc
Hardware: All All
: high enhancement
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords:
Depends on:
Blocks: 78760
  Show dependency treegraph
 
Reported: 2013-04-28 19:16 UTC by KOEHLER Christophe
Modified: 2016-10-25 19:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description KOEHLER Christophe 2013-04-28 19:16:15 UTC
I create a rectangle in Writer.
I remove backroung of this rectangle to invisible.
I double clic to add text.
I add somme text.
I want to highlight a part of this text with a background color like yellow, it's impossible.
Can someboby add this functionnality in a next version ?

Thanks.
Comment 1 Joel Madero 2013-04-30 04:53:36 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.1.0.0.alpha0+Build ID: 6e3e6ef7257e93743a72719581ef6fe0016e58e
Date:   Thu Apr 11 15:24:38 2013 +0200 
Platform: Bodhi Linux 2.2 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Highest - this seems like a very functional thing that is missing

@Koehler - very unlikely next release as it could be very difficult to implement & there are thousands of bug/enhancement reports - but I do think this would be functional

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 Björn Michaelsen 2014-01-17 00:43:51 UTC Comment hidden (obsolete)
Comment 3 dg1727 2014-02-02 14:44:00 UTC
This may be a duplicate of bug 59506.
Comment 4 Maxim Monastirsky 2014-02-02 15:11:21 UTC
(In reply to comment #3)
> This may be a duplicate of bug 59506.
No. Bug 59506 is about font color, which is present, just hidden by default. This bug is about highlight color.
Comment 5 Norbert X 2014-10-04 19:34:22 UTC
I can confirm this bug on LibO 4.3.2.2.
Comment 6 Norbert X 2015-08-05 16:19:47 UTC
Bug exists in LibreOffice 5.0 (Ubuntu 12.04.5 with PPA, 1:5.0.0~rc5-0ubuntu1~precise1).
Comment 7 Commit Notification 2015-10-27 12:54:26 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=96d03636a5f932151c7842ae34631258891fe807

tdf#64027 sw: Make the text background color button work

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-11-02 21:17:11 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4b8ebbd7838921cce837acb353f81df1a6d2996&h=libreoffice-5-0

tdf#64027 sw: Make the text background color button work

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.