Bug 64069 - : Cannot paste to outside program after copying content from Libre Writer.
Summary: : Cannot paste to outside program after copying content from Libre Writer.
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-30 04:25 UTC by Ivan Dossev
Modified: 2014-01-31 13:57 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Dossev 2013-04-30 04:25:15 UTC
Problem description: 
Cannot paste to another program (ex: notepad or Firefox) after copying content from a Libre Writer docx. The reverse works fine.

Steps to reproduce:
Open Libre Writer document.
Highlight text.
Copy. (either via keyboard shortcut or context menu)
Switch to another program.
Paste. (either via keyboard shortcut or context menu)

Current behavior:
Nothing pastes to the other program.

Expected behavior:
To paste to the other program.
              
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Joel Madero 2013-04-30 04:32:33 UTC
Florian - this one looks quite serious, can you test on Windows?
Comment 2 Ivan Dossev 2013-04-30 04:46:05 UTC
I had libre office 4.0.0 and had the same problem so I just downloaded 4.0.2
I'm using Windows 7.

I've determined that there is a "delay" of 6-7 seconds before it will paste.
This delay happens every time I copy something new, until then it's as if
the clipboard is empty.
I've also done a system reboot just in case, problem still persists.
Hope that helps.


On Tue, Apr 30, 2013 at 12:32 AM, <bugzilla-daemon@freedesktop.org> wrote:

>  Joel Madero <jmadero.dev@gmail.com> changed bug 64069<https://bugs.freedesktop.org/show_bug.cgi?id=64069>
>  What Removed Added  CC   jmadero.dev@gmail.com, reisi007@gmail.com
>
>  *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=64069#c1> on bug
> 64069 <https://bugs.freedesktop.org/show_bug.cgi?id=64069> from Joel
> Madero <jmadero.dev@gmail.com> *
>
> Florian - this one looks quite serious, can you test on Windows?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 3 Joel Madero 2013-04-30 05:02:58 UTC
Did you see similar problems with 3.6? 

Please respond with with FDO itself vs. via email as we get a bunch of extra text in the comment. Thanks!
Comment 4 Ivan Dossev 2013-04-30 05:11:21 UTC
I did not use 3.6 and am a fairly new user to LibreOffice.
Prior to a month or two ago I only used Calc on a regular basis and without problems.
Comment 5 Florian Reisinger 2013-04-30 12:28:12 UTC
Can't confirm with a docx and 4.0.3.1 @Win 7x64
Comment 6 Ivan Dossev 2013-04-30 18:04:17 UTC
I did some more testing.
This may be related to having another program open, SmartFTP.
The issue goes away when SmartFTP is closed.
The issue does not happen if Writer is opened first.
The issue does happen if Writer is opened after SmartFTP.

In addition to the no-pasting, I cannot switch to the SmartFTP Window right after copying from writer for the same time interval as the no-paste.

Please note I can't paste into ANY other program during this time interval. But it is only SmartFTP that seems unresponsive.

Maybe the two programs are sharing a dll or API and it's causing unexpected behavior? Or is SmartFTP is to blame?

The reverse issue (copying from SmartFTP after/before writer is open) does not happen.
Comment 7 Florian Reisinger 2013-04-30 18:15:53 UTC
Hmm, this sounds like a problem of SmartFTP (--> Notourbug)
Comment 8 Ivan Dossev 2013-04-30 22:06:37 UTC
I've submitted the bug to the SmartFTP guys.
We were able to determine it goes away when I disable one of SmartFTP's advanced features "URL Watcher", however they are unable to reproduce the bug as I am experiencing it. They let me know the next version changes the way the program will subscribe to the clipboard events and it may cure this strange issue.

So yea.. (notyourbug)
Comment 9 Marek 2014-01-31 13:57:32 UTC
Under LO 4.2.0.4 the problem pertains to copying text from Writer/Calc and pasting it into another program that seems to retain information on the text formatting (at least the character settings) such as Firefox or MS Word. In most cases (not always), however, it is possible to paste the text as plain text (i.e. without formatting preserved – which constitutes a serious drawback). Pasting text into an editor not allowing form character formatting (e.g. notepad) works smoothly. Since such behaviour was not observed before (earlier LO releases) it seems to be LO bug. (by the way I was successful in pasting this note from LO via Firefox as this form does not preserve formatting – only plain text).