Bug 64115 - : UI: menus are not dynamically changing under unity
Summary: : UI: menus are not dynamically changing under unity
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-01 15:19 UTC by Eliyahu Orzitzer
Modified: 2013-05-21 08:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the undo feature in the menu is grayed out instead of enabled (258.20 KB, image/png)
2013-05-01 15:19 UTC, Eliyahu Orzitzer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eliyahu Orzitzer 2013-05-01 15:19:36 UTC
Created attachment 78724 [details]
the undo feature in the menu is grayed out instead of enabled

Problem description: 
Under Ubuntu 12.04 (installed via the "official" PPA), the menus are freezing and not changing after LibreOffice starts, most notably I can not see whether I can undo or what will it do if I undo (using Ctrl-Z).
This is unity bug. If I remove the libreoffice-gtk package everything is ugly but works as expected.

Steps to reproduce:
1. Open Writer (for example)
2. file->new->text document
3. write some letters

Current behavior:
the undo option in the menu is grayed out.

Expected behavior:
the ability to press the undo (e.g. enabled) and the description the last operation near the undo in the menu.
              
Operating System: Ubuntu
Version: 4.0.2.2 release
Comment 1 Michael Meeks 2013-05-07 10:33:33 UTC
Bjoern - one for you ? :-)
Comment 2 Björn Michaelsen 2013-05-07 18:05:44 UTC
Hmmm, I cant reproduce this in 13.04, I thus suspect this to be a bug in unity or indicator-appmenu in the precise release.

Obviously, I cant support backports of indicator-appmenu to precise (LibreOffice alone is enough work), so if this is indeed not happening in 13.04, the only way out might be to disable the unity integration on precise (thus allowing you to use libreoffice-gtk with a classic menu).

Can you confirm this is no issue in Ubuntu 13.04 (raring)?
Comment 3 Eliyahu Orzitzer 2013-05-08 14:51:41 UTC
I did a clean install of 12.04 on VirtualBox, fully updated. same problem.
I also did a clean install of 13.04, fully updated. no problem.

So I can confirm that this problem is only on precise.

(BTW, it works very slowly (tested on VirtualBox). I can see the old menu and then after a split second I see the updated one. The new menu should appear immediately)
Comment 4 Björn Michaelsen 2013-05-08 18:31:29 UTC
Downstreamed as:

https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1177913

note that it will be marked fix released as it is working on 13.04. You would need to get a backport of the fix for precise.
Comment 5 Eliyahu Orzitzer 2013-05-19 19:55:42 UTC
Does it mean that you will disable the unity integration on precise?
Comment 6 Björn Michaelsen 2013-05-21 08:19:06 UTC
@Eliyahu: Yes, unfortunately we will have to do that. If you absolutely want unity menus on 12.04 you can still try lo-menubar -- it should mostly work.