Bug 64194 - Text in some Option Dialogs is bad displayed (KDE/Italian)
Summary: Text in some Option Dialogs is bad displayed (KDE/Italian)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: (target:4.3.3)
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-03 19:02 UTC by Valter Mura
Modified: 2015-02-08 11:23 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
screenshot #1 (64.98 KB, image/png)
2013-05-03 19:02 UTC, Valter Mura
Details
screenshot #2 (69.26 KB, image/png)
2013-05-03 19:04 UTC, Valter Mura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Valter Mura 2013-05-03 19:02:48 UTC
Created attachment 78818 [details]
screenshot #1

If you look at some text option strings in the Option Dialogs, you may note that some strings are cut.

Versions: all, up to the latest one ( 4.0.2.2 (Build ID: 400m0(Build:2))
Environment: KDE 4.10.2 (Kubuntu 13.04)

I provide also screenshot, if you need them (I have more).

One question: is it possible to adopt an dinamic adaptive UI?
Comment 1 Valter Mura 2013-05-03 19:04:01 UTC
Created attachment 78819 [details]
screenshot #2
Comment 2 Adolfo Jayme Barrientos 2013-05-03 22:11:14 UTC
> One question: is it possible to adopt an dinamic adaptive UI?

Yes. In fact, LibreOffice already did: Caolán McNamara has written a parser that reads GTK+’s .ui files and translates them to VCL. For more information, have a look at https://wiki.documentfoundation.org/Development/WidgetLayout

So this issue is essentially already fixed for 4.1.
Comment 3 Andras Timar 2013-05-09 11:52:49 UTC
(In reply to comment #2)
> So this issue is essentially already fixed for 4.1.

Print page has been converted to .ui, but Language page hasn't.
Comment 4 Mihkel Tõnnov 2013-09-12 19:55:04 UTC
Isn't this a duplicate of bug 67227 (and partly bug 61544)?
Comment 5 Julien Nabet 2014-08-17 19:33:16 UTC
With the ongoing UI conversion and following fix of fdo#61544 (put in See Also), any update with 4.2.6 or 4.3.0?
Comment 6 Julien Nabet 2015-02-08 09:15:15 UTC
No feedback since several months.
Let's put this one to WFM.

If you still reproduce this with last stable LO version (4.3.5), don't hesitate to reopen this tracker.
Comment 7 Valter Mura 2015-02-08 10:00:21 UTC
Seems to be ok now

Checked in LibreOffice 4.3.3.2
Linux Ubuntu 14.10 / KDE 4.14.1

(Sorry for the delay in the feedback)
Comment 8 Julien Nabet 2015-02-08 11:23:12 UTC
No problem :-) Thank you for your feedback.