Bug Hunting Session
Bug 64222 - FORMATTING: A DOCX-file in Writer shows different size of list elements (numbering)
Summary: FORMATTING: A DOCX-file in Writer shows different size of list elements (numb...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:6.4.0
Keywords: filter:docx
: 77797 112146 126719 (view as bug list)
Depends on:
Blocks: DOCX-Bullet-Number-Outline-Lists
  Show dependency treegraph
 
Reported: 2013-05-04 21:06 UTC by niks
Modified: 2019-09-19 09:11 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
A document to check this bug (10.94 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-05-04 21:06 UTC, niks
Details
Word output (185.78 KB, application/pdf)
2019-08-30 06:09 UTC, Samuel Mehrbrodt (CIB)
Details
LO output (7.48 KB, application/pdf)
2019-08-30 07:54 UTC, Samuel Mehrbrodt (CIB)
Details
More examples (DOCX) (12.10 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2019-09-02 07:01 UTC, Samuel Mehrbrodt (CIB)
Details
More examples (PDF from Word) (566.06 KB, application/pdf)
2019-09-02 07:02 UTC, Samuel Mehrbrodt (CIB)
Details
A document and More Examples compared in MSO and LO (110.26 KB, image/jpeg)
2019-09-19 08:34 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description niks 2013-05-04 21:06:09 UTC
Created attachment 78859 [details]
A document to check this bug

Problem description: 

Steps to reproduce:
1. Open MS Word
2. Make a numbered list with a few elements. 
3. Now select a title (don't select a number of element) and change its font size and after that save the document as .docx.
4. Open this document in Libre Office Writer.

I did steps 1-3 and sent a document to you. You can open my document and see a bug.

Current behavior:
A number of element in list and a title have different size of font. They have everything different even if you make title bold in step 3, a number won't be.

Expected behavior:
They are supposed to look the same. It shouldn't really be different.
Operating System: Windows 7
Version: 4.0.2.2 release
Comment 1 Thomas van der Meulen 2013-05-08 16:58:32 UTC
Thank you for your bug report, 
I can confirm this bug running LibreOffice 4.0.3.3 on Windows 7.
Comment 2 niks 2013-05-09 19:51:24 UTC Comment hidden (no-value)
Comment 3 QA Administrators 2015-03-04 02:19:49 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-03-22 12:58:18 UTC
Reproduced from scratch.

Win 7 Pro 64-bit, LibO Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: fi_FI
Comment 5 tommy27 2016-04-16 07:28:14 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-05-22 13:26:00 UTC Comment hidden (obsolete)
Comment 7 Zineta 2018-10-09 11:34:42 UTC
Tested in :
Version: 6.2.0.0.alpha0+ (x64)
Build ID: 89a60912bba7ffd6f65ea99f4664f343c5025c95
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-01_03:18:33
OS: Win 7


..... still can reproduce
Comment 8 Samuel Mehrbrodt (CIB) 2019-08-30 06:09:35 UTC
Created attachment 153740 [details]
Word output
Comment 9 Samuel Mehrbrodt (CIB) 2019-08-30 07:54:36 UTC
Created attachment 153745 [details]
LO output
Comment 10 Samuel Mehrbrodt (CIB) 2019-08-30 12:15:56 UTC
For reference, the feature to handle direct formatting for numbering was added in https://cgit.freedesktop.org/libreoffice/core/commit/?id=df07d6cb9f62c0a2c4b29bd850d4efb4fcd4790b .
Comment 11 Samuel Mehrbrodt (CIB) 2019-09-02 07:01:41 UTC
Created attachment 153810 [details]
More examples (DOCX)
Comment 12 Samuel Mehrbrodt (CIB) 2019-09-02 07:02:07 UTC
Created attachment 153811 [details]
More examples (PDF from Word)
Comment 13 Commit Notification 2019-09-05 06:52:39 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/2c0d3ce5292b45a8897758508ee61801e4e8340d%5E%21

tdf#64222 Consistently apply direct formatting to numbering

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Mike Kaganski 2019-09-05 09:01:31 UTC
Please see attachment 152672 [details] from bug 51168. The attachment (created with LibreOffice) has first two numbers small - both in LibreOffice 6.3.1.2 and in MS Word 2016; but these two numbers are shown in the same font size as the rest of line in master with commit 2c0d3ce5292b45a8897758508ee61801e4e8340.
Comment 15 Jan-Marek Glogowski 2019-09-05 17:41:29 UTC
FYI this also affects bug 49785. Just read comment 17 of it. It's probably not really related, but fixing this bug might be a part of a fix for bug 49785, independent from the underlying problem.
Comment 16 Gabor Kelemen 2019-09-08 21:22:09 UTC
*** Bug 112146 has been marked as a duplicate of this bug. ***
Comment 17 Gabor Kelemen 2019-09-09 08:43:32 UTC
*** Bug 126719 has been marked as a duplicate of this bug. ***
Comment 18 Michael Stahl (CIB) 2019-09-09 09:12:16 UTC
https://gerrit.libreoffice.org/#/c/78729/

fixes the example of comment #12 at least
Comment 19 Xisco Faulí 2019-09-09 23:53:32 UTC Comment hidden (obsolete)
Comment 20 Justin L 2019-09-10 21:52:24 UTC
*** Bug 77797 has been marked as a duplicate of this bug. ***
Comment 21 Commit Notification 2019-09-17 08:46:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5ba30f588d6e41a13d68b1461345fca7a7ca61ac%5E%21

tdf#64222 sw: better DOCX import/export of paragraph marker formatting

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 22 Timur 2019-09-19 08:34:04 UTC
Created attachment 154283 [details]
A document and More Examples compared in MSO and LO

Original document and later More examples compared in MSO 2016 and LO 6.2.7 and 6.4+ before and after the last fix.
I'm not sure what's going on here, but it look OK to me.
Comment 23 Michael Stahl (CIB) 2019-09-19 08:39:09 UTC
yeah i think it's fixed now