Bug 64368 - Viewing a DOCX-file created by "Converter PDF to DOCX", is displayed not properly
Summary: Viewing a DOCX-file created by "Converter PDF to DOCX", is displayed not prop...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: interoperability
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2013-05-08 17:52 UTC by Volker
Modified: 2017-11-02 10:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF- DOCX-file and screenshots of viewing (143.33 KB, application/zip)
2013-05-08 17:52 UTC, Volker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volker 2013-05-08 17:52:25 UTC
Created attachment 79030 [details]
PDF- DOCX-file and screenshots of viewing

A PDF-file converted by "Wondershare PDF to Word Converter 4.0.1" to a docx-file is display properly by "Microsoft Office Word Viewer 2003" with Winows-7, but bad with LibreOffice Version 4.0.2.2 (Build ID: 4c82dcdd6efcd48b1d8bba66bfe1989deee49c3)
Comment 1 Thomas van der Meulen 2013-05-09 08:20:07 UTC
Thank you for your bug report, I can confirm this bug running LibreOffice 4.0.3.3 on Mac os x 10.8.3. The text is all over just like shown on the Picture.
Comment 2 Julien Nabet 2013-05-11 14:27:57 UTC
Comment on attachment 79030 [details]
PDF- DOCX-file and screenshots of viewing

Mimetype fixed
Comment 3 Alexandr 2014-08-10 08:22:59 UTC
I test the document with LibreOffice 4.2.5 and 4.3.1 on Debian. The representation is much better now. The only problem I see is an additional page.
Comment 4 QA Administrators 2015-09-04 02:48:05 UTC Comment hidden (obsolete)
Comment 5 Alexandr 2015-09-19 16:31:47 UTC
The document has 2 pages, but LibreOffice 5.0.1 open it with 8 pages.
Comment 6 Robinson Tryon (qubit) 2015-12-13 12:18:26 UTC Comment hidden (obsolete)
Comment 7 Justin L 2017-11-02 10:10:15 UTC
The fix mentioned in comment 3 was in LO 4.2 for bug 67498 with commit c7884509a84d46a9d99b2950159d949589862f3a by Author: Miklos Vajna on CommitDate: Mon Aug 5 17:38:20 2013 +0200
        fdo#67498 RTF import: fix missing margins vs continuous section breaks

It all fits on two pages since LO 5.3 for bug 64372 with commit a60b2f7c227709d27d6294558fd396557a9ffd20 by author Justin Luth on 2016-07-08 07:24:10 (GMT)
    tdf#64372 docx import: don't ignore continuous section break

The contents aren't exactly right for me, but I also don't have the exact fonts.