Download it now!
Bug 64380 - Allow explicit docking for dockable windows
Summary: Allow explicit docking for dockable windows
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 83543 (view as bug list)
Depends on:
Blocks: UI
  Show dependency treegraph
 
Reported: 2013-05-09 06:04 UTC by Urmas
Modified: 2019-03-12 10:21 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2013-05-09 06:04:45 UTC
There should be a widget or a window menu command for docking LO tool windows. The dragging mechanism used now is very unreliable and frustrating.
Comment 1 Joel Madero 2013-05-10 18:34:31 UTC
well for me I don't think it's unreliable nor frustrating but it's still a valid request, marking as NEW
Comment 2 Joel Madero 2013-05-10 18:35:14 UTC
Urmas - are you part of UX mailing list - might be good to get their input. This is unlikely to move forward without their explicit thumbs up
Comment 3 Urmas 2014-09-06 04:29:20 UTC
*** Bug 83543 has been marked as a duplicate of this bug. ***
Comment 4 Jean-Baptiste Faure 2014-09-06 09:16:46 UTC
There is another mechanism to dock / undock toolbars, navigator and stylist, it is to double-click on a grey part of the window.
It works too for the sidebar if you double-click on its vertical border.

I agree that it would be helpful to have a right-click menu entry "undock" as we already have "dock the toolbar" and "dock all toolbars".

Best regards. JBF
Comment 5 Yousuf Philips (jay) (retired) 2014-09-06 10:37:23 UTC
With the double-clicking, it only docks them to the left, when many people would like to dock the navigator to the left and styles to the right. You have the shortcut key which only docks it to the left as well.

https://help.libreoffice.org/Common/Showing,_Docking_and_Hiding_Windows
Comment 6 Thomas Lendo 2018-11-19 19:24:51 UTC
Adding needsUXEval, as this should be discussed.

I find "Dock Toolbar" commands in floating toolbars and "Undock" or "Dock" in the sidebar. Is there another place in the UI where such command is missing now?

Tested with 6.3.0.0.alpha0+ from today.
Comment 7 Heiko Tietze 2019-03-12 10:21:12 UTC
With the intended change of bug 92484 the request is less needed. Plus, we have dock (docks at the last position) as well as dock all and you can double click. Sounds sufficient to me.