Bug Hunting Session
Bug 64397 - Wiki Publisher: Unknown certificate message, when trying to add TDF wiki to "Tools - Options - Internet - MediaWiki"
Summary: Wiki Publisher: Unknown certificate message, when trying to add TDF wiki to "...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-09 16:44 UTC by Thomas Hackert
Modified: 2017-05-27 14:00 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb of the crash (3.14 KB, application/zip)
2013-07-21 03:24 UTC, Thomas Hackert
Details
bzipped strace (1.13 MB, application/zip)
2013-07-21 03:24 UTC, Thomas Hackert
Details
New backtrace with fresh profile (3.13 KB, application/zip)
2013-07-21 12:47 UTC, Thomas Hackert
Details
New strace with new profile (1.17 MB, application/zip)
2013-07-21 12:48 UTC, Thomas Hackert
Details
console logs (3.74 KB, text/plain)
2014-02-22 04:34 UTC, Julien Nabet
Details
console logs (3.16 KB, text/plain)
2014-03-30 15:07 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Hackert 2013-05-09 16:44:49 UTC
Hello @ll,
I hope, I have chosen the right (sub)component and the like. If not, feel free to change it ... ;)

I have tried to add https://wiki.documentfoundation.org with my user name and password to "Tools - Options - Internet - MediaWiki" (I use the Germanophone version of LO, so I hope, I have translated it the right way ... ;) In German it is "Extras - Optionen - Internet - MediaWiki, then click on „Hinzufügen..." ... ;) ). When I have entered all data and click on "OK", then I get the message

<quote>
Das Zertifikat der gewählten Webseite ist nicht bekannt.
</quote>

(roughly translated: The certificate of the chosen website is not known.) ... :( I have tested it with http://wiki.documentfoundation.org, but this leads only to a long loading LO without any further reaction (I stopped it after nearly 30 minutes). In comparison, I can add the Germanophone Wikipedia with my user name and password there without any problem ... ;)

Steps to reproduce:
1. Go to "Tools -> Options -> Internet -> MediaWiki"
2. Click on "Add..."
3. Enter "https://wiki.documentfoundation.org" in the field "URL", your user name of the Wiki in "Username" (in German: Nutzername) and your password in "Password"
4. Press enter or click on "OK"

Found it in LO Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) under Debian Testing AMD64.

Sorry for the inconvenience and have a nice evening
Thomas.
Comment 1 Julien Nabet 2013-05-10 21:04:34 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.
Perhaps a temporary problem, could you give a try again?
Comment 2 Thomas Hackert 2013-05-11 05:52:30 UTC
Good morning Julien, *,
thank you for your interest in my bug :)

(In reply to comment #1)
> On pc Debian x86-64 with master sources updated today, I don't reproduce
> this.
> Perhaps a temporary problem, could you give a try again?

I have tried it, but still to no avail ... :( Are there any deb packages from master to test? I have neither the time nor the disc space to checkout the master source and compile it ... :( And I have not found any since months ... :(
Sorry for the inconvenience and have a nice day
Thomas.
Comment 3 Julien Nabet 2013-05-11 05:56:26 UTC
thackert: you may find some daily builds here: http://dev-builds.libreoffice.org/daily/master/

You can also give a try after having renamed your LO directory profile (see https://wiki.documentfoundation.org/UserProfile)
Comment 4 Thomas Hackert 2013-05-11 08:01:15 UTC
Hello Julien, *,
(In reply to comment #3)
> thackert: you may find some daily builds here:
> http://dev-builds.libreoffice.org/daily/master/

I know this site, thanks :) But ... If you look for http://dev-builds.libreoffice.org/daily/master/Linux-x86_64_11-Release-Configuration/, the last change there was on December 12th ... :(
And I have not found any other Debian builds there ... :(

> You can also give a try after having renamed your LO directory profile (see
> https://wiki.documentfoundation.org/UserProfile)

Maybe later. Today (and maybe tomorrow) I have not time to test it, sorry ... :(
Thanks again
Thomas.
Comment 5 Thomas Hackert 2013-07-19 17:13:48 UTC
Hello Julien, *;
this bug still exists in LO Version: 4.1.0.3 Build ID: 0f08a823567f802c29cbaf2b327db19aaf72016 with installed Germanophone lang- as well as helppack under Debian Testing AMd64 ... :( But now I stumbled upon a crash, when I

1. start LO from commandline as "soffice -backtrace"
2. click to Tools - Options - Internet - MediaWiki
3. try to add wiki.documentfoundation.org with my user name and password to LO

LO immediately crashes, when I click on OK ... :( Interestingly, when I start "soffice -strace", it does not ... :(

Would it be helpful to attach both log files to this bug?
Sorry for the inconvenience
Thomas.
Comment 6 Julien Nabet 2013-07-20 22:46:15 UTC
thackert: yes it may help you attach the logs you have. Before this, did you try to rename your LO directory profile as suggested in my previous comment?
Comment 7 Thomas Hackert 2013-07-21 03:24:02 UTC
Created attachment 82757 [details]
gdb of the crash
Comment 8 Thomas Hackert 2013-07-21 03:24:42 UTC
Created attachment 82758 [details]
bzipped strace
Comment 9 Thomas Hackert 2013-07-21 03:25:22 UTC
Hello Julien, *,
(In reply to comment #6)
> thackert: yes it may help you attach the logs you have. Before this, did you
> try to rename your LO directory profile as suggested in my previous comment?

I have attached both zipped log files :)
HTH
Thomas.
Comment 10 Julien Nabet 2013-07-21 06:48:06 UTC
thackert: thank you for the attached files but you didn't answer about LO directory profile (or I missed this part), did you try to rename your LO directory profile?
Comment 11 Thomas Hackert 2013-07-21 07:23:07 UTC
Hello Julien, *,
(In reply to comment #10)
> thackert: thank you for the attached files but you didn't answer about LO
> directory profile (or I missed this part), did you try to rename your LO
> directory profile?

oh, sorry ... :( Really forgot it ... :(

I use https://wiki.documentfoundation.org/Installing_in_parallel to install test/pre-release versions of LO (especially https://wiki.documentfoundation.org/Installing_in_parallel#Step_4_-_Optional.2C_but_Recommended_when_Testing:_Changing_the_User_Profile_location to get a clean, new profile ... ;) ). Should this not be enough, I am willing to move my ~/.config/$whatever to ~/.config/whatever_old, if really needed ... ;)
Sorry for the inconvenience
Thomas.
Comment 12 Julien Nabet 2013-07-21 07:54:13 UTC
thackert: ok never tried parallel installation, it could be interesting you rename anyway just for the test. If there's still the problem, change back the name of your LO directory profile.
Comment 13 Thomas Hackert 2013-07-21 12:46:39 UTC
Hello Julien, *,
(In reply to comment #12)
> thackert: ok never tried parallel installation, it could be interesting you
> rename anyway just for the test.

during a parallel install, you change opt/libreoffice4.1/program/bootstraprc to use "UserInstallation=$ORIGIN/.." as your user profile. This leads to a freshly installed profile under opt/libreoffice4.1/user, so this does not interfere with your tests ... ;)

> If there's still the problem, change back
> the name of your LO directory profile.

The problem still exists ... :( I have done a freshly install, after Thorsten has announced a new "hotfix" build for Debian with all the changes needed. If I start LO for itself, it does not crash, but I am not able to add my https://wiki.documentfoundation.org account (the same goes, when I start soffice --strace). If I start with "soffice -backtrace" and want to add my wiki.documentfoundation account, it crashes immediately ... :( I will attach two newly created log files afterwards.
Sorry for the inconvenience
Thomas.
Comment 14 Thomas Hackert 2013-07-21 12:47:23 UTC
Created attachment 82780 [details]
New backtrace with fresh profile
Comment 15 Thomas Hackert 2013-07-21 12:48:31 UTC
Created attachment 82781 [details]
New strace with new profile
Comment 16 Julien Nabet 2013-07-21 13:17:05 UTC
Comment on attachment 82780 [details]
New backtrace with fresh profile

Mimetype and filename fixed
Comment 17 Julien Nabet 2013-07-21 13:32:43 UTC
thackert: I gave a new try and reproduced this for both with 4.0.3 and master sources updated yesterday!

with 4.0.3, here are console logs:
javax.net.ssl.SSLPeerUnverifiedException: peer not authenticated
	at sun.security.ssl.SSLSessionImpl.getPeerCertificates(SSLSessionImpl.java:371)
	at org.apache.commons.httpclient.protocol.SSLProtocolSocketFactory.verifyHostName(SSLProtocolSocketFactory.java:250)
	at org.apache.commons.httpclient.protocol.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:108)
	at org.apache.commons.httpclient.protocol.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:149)
	at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:707)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.open(MultiThreadedHttpConnectionManager.java:1361)
	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:387)
	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
	at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:346)
	at com.sun.star.wiki.Helper.ExecuteMethod(Helper.java:718)
	at com.sun.star.wiki.WikiEditSettingDialog.DoLogin(WikiEditSettingDialog.java:215)
	at com.sun.star.wiki.WikiEditSettingDialog$1.run(WikiEditSettingDialog.java:372)


with master sources:
warn:legacy.tools:15255:13:toolkit/source/helper/unowrapper.cxx:177: UnoWrapper::SetWindowInterface: there already *is* a WindowInterface for this window!
warn:legacy.tools:15255:13:toolkit/source/awt/vclxtoolkit.cxx:1151: VCLXToolkit::createWindow: did #133706# resurge?
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: CA key usage check failed: keyCertSign bit is not set
	at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
	at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1715)
	at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:257)
	at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:251)
	at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1168)
	at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:153)
	at sun.security.ssl.Handshaker.processLoop(Handshaker.java:609)
	at sun.security.ssl.Handshaker.process_record(Handshaker.java:545)
	at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:963)
	at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1208)
	at sun.security.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:674)
	at sun.security.ssl.AppOutputStream.write(AppOutputStream.java:119)
	at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
	at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
	at org.apache.commons.httpclient.HttpConnection.flushRequestOutputStream(Unknown Source)
	at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.flushRequestOutputStream(Unknown Source)
	at org.apache.commons.httpclient.HttpMethodBase.writeRequest(Unknown Source)
	at org.apache.commons.httpclient.HttpMethodBase.execute(Unknown Source)
	at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(Unknown Source)
	at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(Unknown Source)
	at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
	at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
	at com.sun.star.wiki.Helper.ExecuteMethod(Helper.java:716)
	at com.sun.star.wiki.WikiEditSettingDialog.DoLogin(WikiEditSettingDialog.java:218)
	at com.sun.star.wiki.WikiEditSettingDialog$1.run(WikiEditSettingDialog.java:375)
Caused by: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: CA key usage check failed: keyCertSign bit is not set
	at sun.security.validator.PKIXValidator.doValidate(PKIXValidator.java:288)
	at sun.security.validator.PKIXValidator.doValidate(PKIXValidator.java:271)
	at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:181)
	at sun.security.validator.Validator.validate(Validator.java:235)
	at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:147)
	at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:230)
	at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:270)
	at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1147)
	... 20 more
Caused by: java.security.cert.CertPathValidatorException: CA key usage check failed: keyCertSign bit is not set
	at sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:153)
	at sun.security.provider.certpath.PKIXCertPathValidator.doValidate(PKIXCertPathValidator.java:327)
	at sun.security.provider.certpath.PKIXCertPathValidator.engineValidate(PKIXCertPathValidator.java:187)
	at java.security.cert.CertPathValidator.validate(CertPathValidator.java:267)
	at sun.security.validator.PKIXValidator.doValidate(PKIXValidator.java:283)
	... 27 more

It's quite weird since I hadn't reproduced it first time.
Jan: any idea?
Comment 18 Thomas Hackert 2013-07-21 14:14:36 UTC
(In reply to comment #17)
> thackert: I gave a new try and reproduced this for both with 4.0.3 and
> master sources updated yesterday!
> 
> with 4.0.3, here are console logs:

oh, that is, what I get from console:
<quote>
21.07.2013 13:52:16 org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: I/O exception (java.net.SocketException) caught when processing request: java.security.NoSuchAlgorithmException: Error constructing implementation (algorithm: Default, provider: SunJSSE, class: sun.security.ssl.DefaultSSLContextImpl)
21.07.2013 13:52:16 org.apache.commons.httpclient.HttpMethodDirector executeWithRetry
INFO: Retrying request
javax.net.ssl.SSLHandshakeException: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: CA key usage check failed: keyCertSign bit is not set
        at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
        at sun.security.ssl.SSLSocketImpl.fatal(SSLSocketImpl.java:1715)
        at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:257)
        at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:251)
        at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1168)
        at sun.security.ssl.ClientHandshaker.processMessage(ClientHandshaker.java:153)
        at sun.security.ssl.Handshaker.processLoop(Handshaker.java:609)
        at sun.security.ssl.Handshaker.process_record(Handshaker.java:545)
        at sun.security.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:963)
        at sun.security.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1208)
        at sun.security.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:674)
        at sun.security.ssl.AppOutputStream.write(AppOutputStream.java:119)
        at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:82)
        at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:140)
        at org.apache.commons.httpclient.HttpConnection.flushRequestOutputStream(Unknown Source)
        at org.apache.commons.httpclient.MultiThreadedHttpConnectionManager$HttpConnectionAdapter.flushRequestOutputStream(Unknown Source)
        at org.apache.commons.httpclient.HttpMethodBase.writeRequest(Unknown Source)
        at org.apache.commons.httpclient.HttpMethodBase.execute(Unknown Source)
        at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(Unknown Source)
        at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(Unknown Source)
        at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
        at org.apache.commons.httpclient.HttpClient.executeMethod(Unknown Source)
        at com.sun.star.wiki.Helper.ExecuteMethod(Helper.java:715)
        at com.sun.star.wiki.WikiEditSettingDialog.DoLogin(WikiEditSettingDialog.java:218)
        at com.sun.star.wiki.WikiEditSettingDialog$1.run(WikiEditSettingDialog.java:375)
Caused by: sun.security.validator.ValidatorException: PKIX path validation failed: java.security.cert.CertPathValidatorException: CA key usage check failed: keyCertSign bit is not set
        at sun.security.validator.PKIXValidator.doValidate(PKIXValidator.java:288)
        at sun.security.validator.PKIXValidator.doValidate(PKIXValidator.java:271)
        at sun.security.validator.PKIXValidator.engineValidate(PKIXValidator.java:181)
        at sun.security.validator.Validator.validate(Validator.java:235)
        at sun.security.ssl.X509TrustManagerImpl.validate(X509TrustManagerImpl.java:147)
        at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:230)
        at sun.security.ssl.X509TrustManagerImpl.checkServerTrusted(X509TrustManagerImpl.java:270)
        at sun.security.ssl.ClientHandshaker.serverCertificate(ClientHandshaker.java:1147)
        ... 20 more
Caused by: java.security.cert.CertPathValidatorException: CA key usage check failed: keyCertSign bit is not set
        at sun.security.provider.certpath.PKIXMasterCertPathValidator.validate(PKIXMasterCertPathValidator.java:153)
        at sun.security.provider.certpath.PKIXCertPathValidator.doValidate(PKIXCertPathValidator.java:327)
        at sun.security.provider.certpath.PKIXCertPathValidator.engineValidate(PKIXCertPathValidator.java:187)
        at java.security.cert.CertPathValidator.validate(CertPathValidator.java:267)
        at sun.security.validator.PKIXValidator.doValidate(PKIXValidator.java:283)
        ... 27 more
</quote>
... :(

> It's quite weird since I hadn't reproduced it first time.
> Jan: any idea?

But should this bug not set to "NEW" in this case?
Thanks for changing the file type for my last attachment (not sure, what I have done to produce a zip file without its ending ... :( ) as well as confirming this bug
Thomas.
Comment 19 Julien Nabet 2014-02-22 04:34:42 UTC
Created attachment 94551 [details]
console logs

On pc Debian x86-64 with master sources updated yesterday, I still reproduce this problem.
I attached the console logs but should be the same as the previous logs retrieved.
Comment 20 Julien Nabet 2014-02-22 04:36:43 UTC
Michael: Reading http://stackoverflow.com/questions/10267968/error-when-opening-https-url-keycertsign-bit-is-not-set, I wonder if it could be a cert problem on https://wiki.documentfoundation.org.
I can log it manually to the website but perhaps the problem is due to a stricter checking by Java (when using LO), do you know who may help here?
Comment 21 Julien Nabet 2014-03-30 15:07:49 UTC
Created attachment 96618 [details]
console logs

I gave a new try (still on pc Debian x86-64 with master sources updated today), I could add the mediawiki website!

It could be thanks to upgrades of:
- apache-commons-lang (http://cgit.freedesktop.org/libreoffice/core/commit/?id=1731f6e692bb0a07a2bca4b1b190163f209d2b9e
- apache-commons-codec (http://cgit.freedesktop.org/libreoffice/core/commit/?id=3dad9b1019bebcc6db63a424afa146e007f768d2)
- apache-commons-logging (http://cgit.freedesktop.org/libreoffice/core/commit/?id=2b15c85a8cd83e71ca344fa90357f845aaf29f1b)
Comment 22 Julien Nabet 2014-03-30 15:09:09 UTC
thackert: for the test, could you give a new try with a recent daily build (see http://dev-builds.libreoffice.org/daily/master/)?
Comment 23 Thomas Hackert 2014-03-31 06:19:23 UTC
Good morning Julien, *,
(In reply to comment #22)
> thackert: for the test, could you give a new try with a recent daily build
> (see http://dev-builds.libreoffice.org/daily/master/)?

I cannot confirm it with LO Version: 4.3.0.0.alpha0+ Build ID: c176cb8907530a795cb0e38de8193df931f891fb TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-03-31_03:13:50 (parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel) under Debian Testing i686 ... :( I still get the error message

<quote>
The certificate of the selected site is unknown.
</quote>

... :(

Have a nice day
Thomas.
Comment 24 Julien Nabet 2014-03-31 18:28:40 UTC
thackert: thank you for your feedback. I put it back to NEW.
Comment 25 Julien Nabet 2015-11-08 09:31:45 UTC
thackert: any update with recent LO version? (min 5.0.3 or better with last master sources)
Indeed apache-commons libraries seem to be not used anymore (see http://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=apache)
Comment 26 Thomas Hackert 2015-11-17 18:24:02 UTC
Hello Julien,
sorry for the relay, but I had too much stress the last weeks ... And then I forgot, that I wanted to answer here ... :(

(In reply to Julien Nabet from comment #25)
> thackert: any update with recent LO version? (min 5.0.3 or better with last
> master sources)
> Indeed apache-commons libraries seem to be not used anymore (see
> http://cgit.freedesktop.org/libreoffice/core/log/?qt=grep&q=apache)

Tested with LO
Version: 5.0.3.2
Build-ID: 00m0(Build:2)
Gebietsschema: de-DE (de_DE.UTF-8)
(Debian's own version)

and

Version: 5.1.0.0.alpha1
Build-ID: a8e4f75fe264f6ece37c154951cff53f2f4fa3e4
Gebietsschema: de-DE (de_DE.UTF-8)

(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)

under Debian Testing AMD64. It is still reproducible ... :(
Thanks for your reminder and have a nice evening
Thomas.
Comment 27 Ákos 2016-04-18 14:27:48 UTC
I can reproduce with LibreOffice 5.1.2.2 on Windows 10 x64.
I try to add the en.wikipedia.org server.

I think the good solution for this problem is a CeckBox that skip the certificate validation process.
Comment 28 QA Administrators 2017-05-22 13:26:42 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.2.7 or 5.3.3  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170522