Download it now!
Bug 64447 - base start wizard: second page not in sync with first one
Summary: base start wizard: second page not in sync with first one
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.1.0.0.alpha0+ Master
Hardware: Other All
: high normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: target:4.2.0 target:4.1.0.0.beta2 tar...
Keywords: regression
Depends on: 62937
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-05-10 22:15 UTC by Lionel Elie Mamane
Modified: 2013-07-01 13:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Elie Mamane 2013-05-10 22:15:14 UTC
Start LibreOffice.

If it opens a writer document, close that document.

This gets you to the Start Center.

Click on "Database"

The Database wizard appears.

Note that "Create a new database" is selected.

Click on "Next".

PROBLEM 1: One gets the page to setup a JDBC connection. Wrong page.

Click on back.

Click on "Open an existing (...)"

Click on "Create a new (...)"

Click next.

*Now* the second page is the right one.

Click on back.

Click on "Connect to an existing database"

Note that JDBC is selected.

Click "next"

PROBLEM 2: Wrong second page. One still gets the one for "create a new database".

Click on back.

Click on JDBC to "make" the selection

Click on next.

*Now* this is the right second page for JDBC connection.


I blame this commit; @mathias, if you could take a look I'd be grateful. Thanks in advance.

commit f3f512bdfd664ea27ff2b51175dcf85d1949d06b
Author:     Mathias Hasselmann <mathias@openismus.com>
AuthorDate: Thu Mar 21 09:04:55 2013 +0100
Commit:     Petr Mladek <pmladek@suse.cz>
CommitDate: Wed Mar 27 15:02:26 2013 +0000

    Use UI builder for database wizard's start page
Comment 1 Julien Nabet 2013-05-11 10:06:10 UTC
dup of https://bugs.freedesktop.org/show_bug.cgi?id=62937 but I let you choose the one you prefer :-)
Comment 2 Lionel Elie Mamane 2013-05-11 14:07:45 UTC

*** This bug has been marked as a duplicate of bug 62937 ***
Comment 3 Lionel Elie Mamane 2013-06-05 04:44:54 UTC
Only *half* of this bug was a DUP of bug 62937.

From comment 0:

 - PROBLEM 1 is solved (is bug 62937)

 - PROBLEM 2 is still present
Comment 4 Commit Notification 2013-06-05 08:34:05 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5d81b207e8c4dd96c34836d29bc82275f0a1c2c8

fdo#64447 when changing setup mode, trigger changed DatasourceType event



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-06-05 10:12:16 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=29e79344add06fed1ff764a6d24036a768cb688e&h=libreoffice-4-1

fdo#64447 when changing setup mode, trigger changed DatasourceType event


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2013-07-01 13:17:10 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0a94f9210ca74ea959a59dbb4cb6ea05b6450118&h=libreoffice-4-0

fdo#64447 when changing setup mode, trigger changed DatasourceType event


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.