Bug 64481 - [Template Manager] Buttons for actions on selected template overlap with View action buttons on the right (depending on width of dialog)
Summary: [Template Manager] Buttons for actions on selected template overlap with View...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 68653 70757 73568 78578 79779 (view as bug list)
Depends on:
Blocks: Template-Manager
  Show dependency treegraph
 
Reported: 2013-05-11 21:23 UTC by Richard
Modified: 2017-10-08 20:08 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Image file showing overlapping buttons in Templat Manager (37.43 KB, image/jpeg)
2013-05-11 21:23 UTC, Richard
Details
default window size in 4.3 beta (41.53 KB, image/png)
2014-06-08 08:45 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Richard 2013-05-11 21:23:27 UTC
Created attachment 79183 [details]
Image file showing overlapping buttons in Templat Manager

When a template is single clicked on in Template Manager, the Delete button overlap the Search button.
Comment 1 Adolfo Jayme 2013-05-13 22:33:20 UTC
Reproducible with LibreOffice 4.0.3.3 under Ubuntu 13.04, marking as NEW.
Comment 2 Adolfo Jayme 2013-08-30 20:40:06 UTC
*** Bug 68653 has been marked as a duplicate of this bug. ***
Comment 3 Cor Nouws 2014-02-04 12:52:34 UTC
*** Bug 73568 has been marked as a duplicate of this bug. ***
Comment 4 Cor Nouws 2014-05-12 07:31:46 UTC
*** Bug 78578 has been marked as a duplicate of this bug. ***
Comment 5 Cor Nouws 2014-06-08 08:34:48 UTC
*** Bug 79779 has been marked as a duplicate of this bug. ***
Comment 6 Yousuf Philips (jay) (retired) 2014-06-08 08:43:17 UTC
As stated in my duplicate bug 79779, i tested it on Linux Mint in LibO 4.0.6, 4.2.4, 4.2.6. It is fixed in 4.3 beta as the default window size its larger.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-08 08:45:22 UTC
Created attachment 100643 [details]
default window size in 4.3 beta
Comment 8 Adolfo Jayme 2014-06-09 01:05:39 UTC
Indeed, this is solved now in 4.3 when the Template Manager dialog was converted to the .ui format by Kendy.
Comment 9 Adolfo Jayme 2014-06-09 02:14:45 UTC
OK, I’ve spoken too soon. While it’s fixed for English, other locales (where UI text is longer) may still have the issue. I’ve discovered this while testing my Spanish changes in 4.3 beta 2. (And shortened the Spanish labels BTW.)
Comment 10 Yousuf Philips (jay) (retired) 2014-06-09 13:15:10 UTC
I think eliminating left icon texts should be the simplest way to go and then the dialog doesnt need to be as large and doesnt have be enlarged further. The tooltips should be enough, just like they are enough for the icons on the right.
Comment 11 steve -_- 2014-10-28 00:32:23 UTC
*** Bug 70757 has been marked as a duplicate of this bug. ***
Comment 12 QA Administrators 2015-12-20 16:08:29 UTC Comment hidden (obsolete)
Comment 13 Cor Nouws 2015-12-27 20:57:14 UTC
I'm not able to shrink the width of the dialog to such a size, that the icons overlap in 5.1.0rc1 and 5.2. master.