Bug 64500 - FILESAVE: ODT loses images and charts anchored to frame when saving as DOC or DOCX
Summary: FILESAVE: ODT loses images and charts anchored to frame when saving as DOC or...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks: OOXML-Chart DOCX
  Show dependency treegraph
 
Reported: 2013-05-12 17:19 UTC by Clemens Eisserer
Modified: 2021-09-22 11:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
the original odt document (306.07 KB, application/vnd.oasis.opendocument.text)
2013-05-12 17:20 UTC, Clemens Eisserer
Details
the document after saving as .doc (297.00 KB, application/msword)
2013-05-12 17:20 UTC, Clemens Eisserer
Details
the document saved as .docx (188.48 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-05-12 17:21 UTC, Clemens Eisserer
Details
ODT reduced (301.68 KB, application/3dr)
2017-05-04 16:50 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Clemens Eisserer 2013-05-12 17:19:22 UTC
When saving the attached test document as doc or docx, half of its graphics are lost.

When saving as doc, the border of the graphic element is preserved but the graphic is missing. For docx even the border is missing.
Comment 1 Clemens Eisserer 2013-05-12 17:20:01 UTC
Created attachment 79203 [details]
the original odt document
Comment 2 Clemens Eisserer 2013-05-12 17:20:44 UTC
Created attachment 79204 [details]
the document after saving as .doc
Comment 3 Clemens Eisserer 2013-05-12 17:21:07 UTC
Created attachment 79205 [details]
the document saved as .docx
Comment 4 ign_christian 2013-05-14 08:57:56 UTC
reproducible on LO 4.0.3.3 (Win7 Home Premium 32bit) after saving & reopening conversion file

I also see some parts of Table of Contents missing -> see Bug 64352
Comment 5 QA Administrators 2015-04-19 03:21:03 UTC Comment hidden (obsolete)
Comment 6 Clemens Eisserer 2015-04-19 18:21:57 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2016-09-20 09:33:31 UTC Comment hidden (obsolete)
Comment 8 Telesto 2016-12-10 15:25:32 UTC
Repro with:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 Timur 2017-05-04 16:50:28 UTC
Created attachment 133077 [details]
ODT reduced

One should always be specific and prepare minimal test case. 
When DOCX is open in MSO, missing charts and images are on page 5, 7, 8, 10.

Here is ODT reduced which shows the root issue: missing charts and images in DOCX had anchor set TO FRAME and those present set to TO CHARACTER, AS CHARACTER.
So I'll update the title.
Comment 10 QA Administrators 2018-05-11 02:33:02 UTC Comment hidden (obsolete)
Comment 11 Clemens Eisserer 2018-05-11 06:45:49 UTC
LibreOffice still looses images when saving the attached testcase document as .doc.

Tested with:
Version: 6.0.3.2
Build ID: 8f48d515416608e3a835360314dac7e47fd0b821
CPU threads: 4; OS: Linux 4.16; UI render: default; VCL: x11; 
Locale: de-AT (de_AT.utf8);
Comment 12 QA Administrators 2019-05-12 02:59:07 UTC Comment hidden (obsolete)
Comment 13 sdc.blanco 2019-10-30 00:25:50 UTC
Repro with:
Version: 6.3.3.1 (x64)
Build ID: f41f4c7f9507aeca13cb9df51f34d80e8ba30a99
CPU threads: 8; OS: Windows 10.0; UI render: default; VCL: win;

Timur (comment 9) has a correct analysis.

I believe this is a duplicate of bug #49184
Comment 14 Justin L 2020-04-11 17:21:06 UTC
roundtripping still leaves blanks in LO 7.0 master.
Comment 15 Roman Kuznetsov 2020-09-26 22:13:14 UTC
still repro in

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 06b9e703f536e2751e3cd584873e00907672cf2d
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Vulkan; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL
Comment 16 pb 2021-09-21 20:45:00 UTC
In Version: 6.4.3.2 (x86)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win; 
Locale: en-US (en_US); UI-Language: en-US
Calc: threaded

I observe this problem not only when saving doc (word 97) but also when saving odt.  Certain images are more likely to be lost than others, i.e., repeated attempts tend to lose the same images, not not always the same images.

In addition, I have also observed that after a save, the image in the running program is lost, but exiting and re-opening the just-saved odt restores the lost image.

This is for embedded images in Writer.

I have not yet tested with version 7.