Bug 64530 - FILEOPEN: Opening Excel File crashing LibreOffice 4
Summary: FILEOPEN: Opening Excel File crashing LibreOffice 4
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2013-05-13 10:31 UTC by irakob
Modified: 2013-05-13 12:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Excel File to Calculate the Lot Size for Forex Trading (28.17 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-05-13 10:31 UTC, irakob
Details
backtrace (98.06 KB, text/plain)
2013-05-13 11:12 UTC, Jorendc
Details
terminal output (21.99 KB, text/plain)
2013-05-13 11:12 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description irakob 2013-05-13 10:31:07 UTC
Created attachment 79239 [details]
Excel File to Calculate the Lot Size for Forex Trading

Problem description: 

Opening Excel File crashing LibreOffice 4

Steps to reproduce:
1. Just try to open Excel File
2. It crashes

Current behavior:

Crashing LibreOffice

Expected behavior:

Opening Excel File in LibreOffice
Operating System: Mac OS X
Version: 4.0.3.3 release
Comment 1 Jorendc 2013-05-13 11:11:25 UTC
Thanks for reporting.

I can reproduce a crash using Linux Mint 14 x64 with Version: 4.1.0.0.alpha1+
Build ID: 5441e509f87c96ca36913bd443152adbb8ad2c9

Therefore I mark this as NEW.

Kind regards,
Joren
Comment 2 Jorendc 2013-05-13 11:12:06 UTC
Created attachment 79241 [details]
backtrace
Comment 3 Jorendc 2013-05-13 11:12:26 UTC
Created attachment 79242 [details]
terminal output
Comment 4 Jorendc 2013-05-13 11:13:38 UTC
@Markus, Eike, Kohei: Crasher. Backtrace attached.

Kind regards,
Joren
Comment 5 Markus Mohrhard 2013-05-13 11:17:33 UTC
This file seems to be invalid. I could not open the file in Excel 2010 or the OOXML SDK. LibO master opened the file at least to some part but also shows the generic import dialog.

I'll build a 4-0 build to check why it might crash 4.0.3
Comment 6 Markus Mohrhard 2013-05-13 11:27:36 UTC
Actually it looks like you did not save your file, you seem to have saved the website showing the file.

Looking at the file with a text editor reveals that this is clearly not an Excel file. It is not even a html file where we could import a table or something like that. I'll see if I can reproduce the crash but this is clearly a minor issue.
Comment 7 irakob 2013-05-13 12:06:24 UTC
I downloaded the file in Firefox with the Option Save Link As… from a website.
The file was hosted on Dropbox. After your reports, downloading it from Dropbox Website directly, now the file could be read successfully in LibreOffice 4.0.3.

Thanks a lot,

Rainer