Bug 64613 - FILESAVE: Grouped columns disappear after saving as .xlsx
Summary: FILESAVE: Grouped columns disappear after saving as .xlsx
Status: RESOLVED DUPLICATE of bug 100347
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: All All
: medium minor
Assignee: Bartosz
URL:
Whiteboard:
Keywords: needsDevEval
: 80418 89336 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-15 06:30 UTC by carloshwa
Modified: 2016-06-19 15:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file to show disappearing groups. (6.76 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-09-23 06:36 UTC, sunbear17
Details

Note You need to log in before you can comment on or make changes to this bug.
Description carloshwa 2013-05-15 06:30:04 UTC
Problem description: Grouped columns disappear after saving as .xlsx

Steps to reproduce:
1. Create new Calc document
2. Create 3 columns & group them
3. Collapse the group
4. Save the document as a .xlsx
5. Close the document
6. Open the document

Current behavior: None of the grouped columns appear, and the control to expand grouped columns is gone. There is no way to get the data back.

Expected behavior: columns should appear just like before it was saved

Please let me know if there is a way to get my columns back, I have a very large spreadsheet and nearly all of my data is lost.

              
Operating System: Mac OS X
Version: 4.0.3.3 release
Comment 1 Joel Madero 2013-05-25 17:52:47 UTC
Can you tell us what #2 is saying? What do you mean "Create 3 columns" - in spreadsheet the columns are already there. 

Marking as NEEDINFO - please describe a bit further what you mean, also if you can attach a ODS file that looks right and then if you save it as xlsx it goes awry that would be incredibly helpful. The simpler the test document, the better


Once you clarify and hopefully attach a simple test case, mark as UNCONFIRMED and we will move it forward.


Apologies for the loss of data, I don't know of a way to recover it :(
Comment 2 Joel Madero 2013-05-25 18:17:56 UTC
oh maybe this is where it's going wrong, select all, right click on column header A, and then do "show" -> maybe your data will come back :)
Comment 3 carloshwa 2013-05-25 18:33:40 UTC
Yes I was able to get my data back that way. This is still a bug however. Do you still need me to attach a sample .ods file? I no longer have LO installed.
Comment 4 Joel Madero 2013-05-25 18:44:35 UTC
Ok so I confirmed this - your data IS NOT LOST :) It's just hidden, do as I said with highlighting all, select a column header, right click and select "show" and your data will be there.

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Bodhi Linux
Version 4.0.3.3 release

Marking as:
New (confirmed)
Minor - not a very used feature and data is not lost, just hidden, workaround quite easy
Medium - if you don't know about the workaround, can create confusion but probably not affecting many users (if any)

Whiteboard: ProposedEasyHack


++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 5 Joel Madero 2013-05-25 18:46:13 UTC
Yeah a document would be useful, just so a developer can easily see what's going on.

Basically attach the ods then anyone can:

open ODS
See + sign above column A
Save as XLS
Open file

Observed: 
No + sign, only way to show hidden data is to select all, right click on column header and do "show"

Expected:
You should see the + sign indicating that there is a hidden group in the sheet
Comment 6 Robinson Tryon (qubit) 2013-10-19 01:01:59 UTC
Removing comma from whiteboard (please use a space to delimit values in this field)
https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard#Getting_Started
Comment 7 Joel Madero 2014-02-27 23:03:40 UTC
In order to limit the confusion between ProposedEasyHack and EasyHack and to make queries much easier we are changing ProposedEasyHack to NeedsDevEval.

Thank you and apologies for the noise
Comment 8 ign_christian 2014-06-24 02:28:41 UTC
*** Bug 80418 has been marked as a duplicate of this bug. ***
Comment 9 ign_christian 2014-06-24 02:29:17 UTC
Reproduced in 4.2.5.2, 4.1.6.2, 4.0.6.2, 3.6.7.2, 3.5.7.2 (Ubuntu 12.04 32bit)
Comment 10 Winfried Donkers (retired) 2015-02-12 15:46:56 UTC
*** Bug 89336 has been marked as a duplicate of this bug. ***
Comment 11 sunbear17 2015-09-23 06:36:32 UTC
Created attachment 118962 [details]
Example file to show disappearing groups.

Open in LibreOffice Calc 5.0.1.2 on OS X and save as XLSX -> Groups disappear in columns and rows.
Comment 12 Robinson Tryon (qubit) 2015-12-13 11:21:33 UTC
Migrating Whiteboard tags to Keywords: (needsDevEval)
[NinjaEdit]
Comment 13 Bartosz 2016-06-19 15:33:19 UTC

*** This bug has been marked as a duplicate of bug 100347 ***