Download it now!
Bug 64641 - EDITING: Filtering in Mac-Addressbook is not possible
Summary: EDITING: Filtering in Mac-Addressbook is not possible
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Data-Filter
  Show dependency treegraph
 
Reported: 2013-05-15 15:30 UTC by g_winkelmann
Modified: 2019-01-14 23:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
after sorting most cells show "0" because #REF in formula (123.51 KB, image/png)
2013-05-16 15:51 UTC, g_winkelmann
Details
data to filter (234.17 KB, image/jpeg)
2013-05-17 21:04 UTC, g_winkelmann
Details
query after filter (34.59 KB, image/png)
2013-05-17 21:04 UTC, g_winkelmann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description g_winkelmann 2013-05-15 15:30:05 UTC
I can use Auto-Filter and the Search  and the words are found. But using filter criteria the result is EMPTY. Why?
It doesn't matter if I try in table or query - all the same.
Comment 1 Robert Großkopf 2013-05-15 19:52:06 UTC
Could you please write down a step-by step description? Also an attachment would be helpful.

Please don't use Importance "high" and "blocker" for a bug in base, which has nothing to do with data-loss.
Comment 2 g_winkelmann 2013-05-16 13:48:55 UTC
I gave a screen-shot and a step by step description onto the way at creation.
Where is it?
Comment 3 Robert Großkopf 2013-05-16 14:24:03 UTC
(In reply to comment #2)
> I gave a screen-shot and a step by step description onto the way at creation.
> Where is it?

Don't know. There isn't any attachment for this bug. Please add a new.
I have tried filter in tables of a LO 4.0.3.3 - Linux-rpm-version of LO. I can't find any problem.
Comment 4 g_winkelmann 2013-05-16 15:51:31 UTC
Created attachment 79434 [details]
after sorting most cells show "0" because #REF in formula

step by step:
1. 2 files in relation to 
2. sort by certain column (other than the 1st)

behaviour:
loosing relation after sorting? Sorting by 1st column not as many as before get to "0"

expected:
sorting and using these results
Comment 5 g_winkelmann 2013-05-16 16:05:09 UTC
I forgot:
I am working on a Mac. But just this moment I tested on Win XP with the same result.
Even I found that nevertheless there is no "#REF!" but the right information in the formula the result is "0".
Not the result I get in Excel or else...
Comment 6 Robert Großkopf 2013-05-16 19:20:55 UTC
I have had a look at the screenshot. It's a screenshot of Calc, not a screenshot of Base. So the screenshot shows nothing about filtering in Base.
Why do you add a screenshot for sorting in Calc to a bug for filtering in Base?
Comment 7 g_winkelmann 2013-05-17 21:04:13 UTC
Created attachment 79483 [details]
data to filter
Comment 8 g_winkelmann 2013-05-17 21:04:58 UTC
Created attachment 79484 [details]
query after filter
Comment 9 g_winkelmann 2013-05-17 21:11:21 UTC
sorry I mixed up with another problem n Calc.
I added 2 screen-shot.

step by step.
1. take any database
2. use the filter button and
3. enter any text wit or without an asterisk
4. Is the text not exactly the same as the whole text in the cell you have lost the game :-(
Comment 10 Robert Großkopf 2013-05-18 07:39:48 UTC
I have had a look at the screenshot. You will filter data from the Mac-Adressbook. This special configuration could only be tested by persons, who will use a Mac.
So I have tried it with LO under Linux and the Thunderbird-Adressbook. Couldn't get any contact to the adressbook with LO 4.0.3.3 - another bug. When I try the filter with LO 3.3.4 Base will shutdown immediately - recovering next start.
The normal filtering of internal databases work with both versions. So I will change the title to "Mac-Adressbook" to give a hint for other persons.
Comment 11 Emir Sarı 2013-06-20 14:15:01 UTC
I can reproduce the problem, OS X 10.7.5, Version: 4.2.0.0.alpha0+
Build ID: b5295b15d36198c2d1c8bf0075afe52c42f9a503
Comment 12 Urmas 2013-07-28 08:31:53 UTC
Closing a PowerPC-specific bug. Please reopen if it can be reproduced on Intel hardware too.
Comment 13 g_winkelmann 2013-07-28 08:47:21 UTC
After closing I find the bug is classified as on PowerPC platform.
But MY problem exists on Mac OSX 10.6.8!
So cannot understand how it can be marked as resolved.
STRANGE!
Comment 14 Julien Nabet 2013-09-14 08:02:06 UTC
On LO 4.1.1.2 with MacOs 10.7.5, I reproduced the problem for MacAddressBook
In comparison, I gave a try on LO 4.1.1.2 Debian package with the same syntax:
like   'A%' it worked.

Alex: put you in cc since you might be interested in this one.
Comment 15 Alex Thurgood 2015-01-03 17:40:11 UTC Comment hidden (no-value)
Comment 16 QA Administrators 2016-01-17 20:02:21 UTC Comment hidden (obsolete)
Comment 17 Alex Thurgood 2016-01-19 12:43:25 UTC
Still present in 

Version: 5.0.3.2
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale : fr-FR (fr.UTF-8)

OSX 10.11.2
Comment 18 QA Administrators 2017-03-06 13:52:50 UTC Comment hidden (obsolete)
Comment 19 eisa01 2017-08-27 00:11:40 UTC
Still present

I click standard filter, select the "First" name field, select "like", type in one of the first names in my address book, and nothing shows up

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 2; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 20 QA Administrators 2018-08-28 02:42:44 UTC Comment hidden (obsolete)
Comment 21 Alex Thurgood 2018-09-19 10:42:26 UTC
Still broken in 

Version: 6.1.1.2
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
Threads CPU : 8; OS : Mac OS X 10.13.6; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group threaded