Download it now!
Bug 64656 - FILEOPEN RTF: Bad handling of list levels
Summary: FILEOPEN RTF: Bad handling of list levels
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium minor
Assignee: Miklos Vajna
URL:
Whiteboard: BSA target:4.2.0 target:4.1.0.1 targe...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-16 00:22 UTC by Zhenbo Li
Modified: 2013-06-14 12:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The file that makes my LibreOffice WriterCrash (54.17 KB, application/rtf)
2013-05-16 00:22 UTC, Zhenbo Li
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zhenbo Li 2013-05-16 00:22:54 UTC
Created attachment 79370 [details]
The file that makes my LibreOffice WriterCrash

Problem description: 
When I tried to open a file called 'it.rtf', my LibreOffice would crash.

Steps to reproduce:
1. Open LiberOffice Writer
2. Open 'if.rtf'
3. Crash

Current behavior:
Crash
Expected behavior:
Open the file successfully
              
Operating System: Fedora
Version: 4.0.2.2 release
Comment 1 ign_christian 2013-05-16 05:29:13 UTC
Tested with LO 4.0.3.3 (Win7 32bit), file can't be opened & displaying error message : 

General Error.
General input/output error.

But that file can be previewed from windows explorer.
Comment 2 ign_christian 2013-05-16 05:40:59 UTC

*** This bug has been marked as a duplicate of bug 64637 ***
Comment 3 Urmas 2013-05-16 06:56:10 UTC
The multilevel list defined in document has an empty "\levelnumbers" array, but has no "\leveltext" string. Apparently this is a cause.
Comment 4 Commit Notification 2013-06-10 07:57:09 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2c64af529567324f4433984ed7673304d26062c8

fdo#64656 RTF import: handle levelnumbers without leveltext



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2013-06-10 08:15:28 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0cdb92107647d1e1571675b21d421d618ad90c35&h=libreoffice-4-1

fdo#64656 RTF import: handle levelnumbers without leveltext


It will be available in LibreOffice 4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2013-06-10 08:17:43 UTC
-4-0 review: https://gerrit.libreoffice.org/4219
Comment 7 Commit Notification 2013-06-14 12:01:41 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f6c8a7f90154ea7251bf7aa8eb6f2db14252060a&h=libreoffice-4-0

fdo#64656 RTF import: handle levelnumbers without leveltext


It will be available in LibreOffice 4.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.