Bug Hunting Session
Bug 64916 - [FILEOPEN] LO 4.1 beta1: missing libsqlite3.so prevents encrypted files from loading
Summary: [FILEOPEN] LO 4.1 beta1: missing libsqlite3.so prevents encrypted files from ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: Other Linux (All)
: medium major
Assignee: David Tardon
URL:
Whiteboard: target:4.2.0 target:4.1.1
Keywords: regression
: 65383 67332 67374 67385 67399 67580 67778 68017 68255 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-05-23 13:44 UTC by Mateusz
Modified: 2013-11-20 16:10 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:


Attachments
Encryped file. Password is 1111 (12.29 KB, application/vnd.oasis.opendocument.text)
2013-05-23 13:44 UTC, Mateusz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mateusz 2013-05-23 13:44:48 UTC
Created attachment 79709 [details]
Encryped file. Password is 1111

Hey

LO 4.1 beta1 can't open any encrypted document. If I try I get standard dialog ("The password is incorrect. The file cannot be opened").

If I try save encrypted file, I got:

Error saving the document Untitled2:
General Error.
General input/output error.

I attach exampled of file. Password is "1111".
Comment 1 Konrad 2013-05-23 14:08:24 UTC
In LO 4.0.3.3 password is OK but in LO 4.1 Beta1 password is invalid.
Comment 2 Mateusz 2013-05-26 20:18:45 UTC
Fixed with daily build no.

Version: 4.1.0.0.alpha1+
Build ID: 2f5a4b914daac00c8881ca69783c879d074fed9
TinderBox: Win-x86_9-Voreppe, Branch:libreoffice-4-1, Time: 2013-05-25_17:28:15
Comment 3 Mateusz 2013-06-02 17:33:47 UTC
Problem comes back with

Wersja: 4.1.0.0.beta1+
Build ID: a81f52a3367f54675c89c1fc84ca161598662bd
TinderBox: Linux-x86@34-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-05-31_21:10:40
Comment 4 Joel Madero 2013-06-21 14:33:36 UTC
Incorrect status - REOPENED is only if bug is assigned.
Comment 5 Mirosław Zalewski 2013-06-25 19:18:05 UTC
Tested with attached file.

I could NOT reproduce it on Windows 7, x86, on builds:
Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155

Version: 4.1.0.1.0+
Build ID: aaa8271292afd913b9aef20f444ef261928943d
TinderBox: Win-x86_9-Voreppe, Branch:libreoffice-4-1, Time: 2013-06-22_02:15:42

Version: 4.2.0.0.alpha0+
Build ID: c639c0931c3fed566df0a6fb3ec68d2c9884d2d4
TinderBox: Win-x86@6, Branch:master, Time: 2013-06-23_23:38:35


But I COULD reproduce it on Linux (Debian testing), amd64, on builds:
Version: 4.1.0.1
Build ID: 1b3956717a60d6ac35b133d7b0a0f5eb55e9155

Version: 4.1.0.1.0+
Build ID: 306ed04b0ac9a166a0a16f0324384d541c7fc0c
TinderBox: Linux-x86_64@31-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-06-24_19:39:47

As we can see, the same version (4.1.0rc1) works on Windows, but does not work on Linux.

We could use someone with:
- Mac OS X: is this Linux-only or all-but-Windows?
- x86 Linux: does processor architecture play important role here?
- RPM-based Linux: does it affect only Debian-based distros, or all Linuces?
Comment 6 Mirosław Zalewski 2013-06-25 19:38:44 UTC
Oh, I have misread Comment 3. It was reported against Linux x86 build.
So we only need to test Mac OS X and RPM-based distro.
Comment 7 retired 2013-06-25 23:26:01 UTC
This WORKSFORME on OS X 10.8.4.
Comment 8 Joel Madero 2013-06-26 00:04:35 UTC
This seems to be resolved. 

Tested on Bodhi Linux (based on Ubuntu, debian packages installed)

4.1 RC and 4.2 master both open file no problem
Comment 9 Mateusz 2013-06-26 08:22:00 UTC
Can't confirm.

Don't work on

Wersja: 4.1.0.1.0+
Build ID: 321447137f94c986da56dc048e40c8ce46123ac
TinderBox: Linux-x86@34-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-06-25_23:33:30

and with new profile
Comment 10 Mirosław Zalewski 2013-06-26 10:39:24 UTC
After some more checks, I have found a cause of this problem.

The root is program/libsoftokn3.so, which requires libsqlite3.so:
#v+
$ ldd /opt/libreoffice4.1/program/libsoftokn3.so 
        linux-vdso.so.1 (0x00007fff9a9fe000)
        libsqlite3.so => not found
        libnssutil3.so => /opt/libreoffice4.1/program/libnssutil3.so (0x00007f293deae000)
        libplc4.so => /opt/libreoffice4.1/program/libplc4.so (0x00007f293dca8000)
        libplds4.so => /opt/libreoffice4.1/program/libplds4.so (0x00007f293daa5000)
        libnspr4.so => /opt/libreoffice4.1/program/libnspr4.so (0x00007f293d855000)
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f293d638000)
        libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f293d434000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f293d087000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f293e34b000)
#v-

In LO 3.6 (I did not check 4.0) libsqlite3.so is shipped in libobasis3.6-core07 package. In LO 4.1, it is not.

On Debian, libsqlite3-0 is one of most common packages required by many desktop apps. So why LO can't use system one? Because it is named libsqlite3.so.0:
#v+
$ ls -lah /usr/lib/x86_64-linux-gnu/libsqlite3*
lrwxrwxrwx 1 root root   19 maj 21 23:05 /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 -> libsqlite3.so.0.8.6
-rw-r--r-- 1 root root 706K maj 21 23:05 /usr/lib/x86_64-linux-gnu/libsqlite3.so.0.8.6
#v-

If you put libsqlite3.so into system's library path (by, eg., making symlink:
ln -s /usr/lib/x86_64-linux-gnu/libsqlite3.so.0 /usr/lib/x86_64-linux-gnu/libsqlite3.so ), then LO will pick it up and open encrypted file without hassle. Tested on:
Version: 4.1.0.1.0+
Build ID: 6bb02e0113419a21b46f46885df271ea6baf4eb
TinderBox: Linux-x86_64@31-Release-Configuration-RHEL5-Baseline, Branch:libreoffice-4-1, Time: 2013-06-25_12:59:59

So, this is not LO bug per se. It is bug in building/packaging system.
Of course one can argue that this is distribution fault, as they do not provide library by name that LO expects; another one may argue that this is LO fault, as it does not expect what distribution provides. That pointless argument was silenced in previous versions by shipping libsqlite3.so with LO and perhaps it was the best solution (that file is only 453KB uncompressed).

Also: I have no idea why sqlite would be needed to decrypting of file. Perhaps this is only surface of some bigger problem that is yet to be identified.

I am changing status to UNCONFIRMED and then to NEW (as I can't go directly from RESOLVED to NEW). Also, I am setting component to "Installation", as it seems to be the closest match.


@Mateusz: could you verify that creating symlink fixes problem for you?
Comment 11 Mateusz 2013-06-26 11:18:50 UTC
>@Mateusz: could you verify that creating symlink fixes problem for you?

No. I still have the same problem although command 

sudo ln -s /usr/lib/libsqlite3.so.0 /opt/libreoffice4.1/program/
Comment 12 Mateusz 2013-06-26 11:36:20 UTC
Weird thing. I copied libsqlite3.so from LO 4.0 to 4.1 and it fixed problem, so your solution works well, Minio. :-) I have no idea why symlink doesn't work earlier.
Comment 13 Mirosław Zalewski 2013-06-26 11:48:39 UTC
@Mateusz: your command at Comment 11 would create /opt/libreoffice4.1/program/libsqlite3.so.0 file, while LO is looking for libsqlite3.so (without ".0" suffix). Correct command would be:
sudo ln -s /usr/lib/libsqlite3.so.0 /opt/libreoffice4.1/program/libsqlite3.so

This is also why copying libsqlite3.so from LO 4.0 fixes problem.
Comment 14 Mateusz 2013-06-26 12:07:01 UTC
Thanks for clarified my mistake. This solutions obviously works too.

So maybe now developers take this issue on board? :>
Comment 15 retired 2013-07-16 10:29:40 UTC
Ubuntu 13.04, LO 4.1.0.2.0 does open this document after asking for passphrase and me entering 1111.

Is this fixed? Mateusz: could you please retry using the 4.1.0.2.0 RC2? http://www.libreoffice.org/download/pre-releases/
Comment 16 Mateusz 2013-07-16 12:44:51 UTC
@James

No, it's not fixed yet. If you want to open encrypted files, you must copy libsqlite3.so to /opt/libreoffice4.1/program/.

Don't ask why developers are ignoring such a big regression.
Comment 17 David Tardon 2013-07-24 08:25:57 UTC
> Don't ask why developers are ignoring such a big regression.

Because noone has done anything to make it more visible to developers (hint: increasing severity might work. Adding the bug to 4.1 MAB is even better).

Btw, it has been a mistake. The man who committed the change apparently thought it is only relevant to MacOS X.
Comment 18 Commit Notification 2013-07-24 08:40:05 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ae0422de5b42fcf81e9d76f5a7b6ed16946fd21

fdo#64916 put libsqlite3.so into instset on linux again



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Konrad 2013-07-24 11:15:21 UTC
Why you target in only to 4.2.0? This ought be fixed before 4.1.1 as well.
Comment 20 Commit Notification 2013-07-24 11:50:39 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d08d7985c98e095fad5dca683ceeff02a671aba&h=libreoffice-4-1

fdo#64916 put libsqlite3.so into instset on linux again


It will be available in LibreOffice 4.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 David Tardon 2013-07-26 05:33:20 UTC
*** Bug 67332 has been marked as a duplicate of this bug. ***
Comment 22 Joel Madero 2013-07-26 20:50:06 UTC
*** Bug 67374 has been marked as a duplicate of this bug. ***
Comment 23 Ivan Timofeev (retired) 2013-07-27 07:00:48 UTC
*** Bug 67385 has been marked as a duplicate of this bug. ***
Comment 24 Raould 2013-07-27 08:39:40 UTC
This is resolved for me with the 4.1.1 daily build (at least the build of 26 Jul 2013).
Comment 25 Klaas Vaag 2013-07-27 09:20:31 UTC
I reinstalled version 4.1.0.4 with Build ID: 89ea49ddacd9aa532507cbf852f2bb22b1ace28

And by copying libsqlite3.so to /opt/libreoffice4.1/program from version 4.0.4 it works again.

Thank you!

Also I would like to notice that by first install of 4.1.0 that the start center is missing in the menu of cinnamon. If there is no report on this and i need to file a bugreport then i'm happy to do so. (old version (4.0.4) removed first by using apt-get remove libreoffice-*). I'm using Linux Mint 15 based on ubuntu 13.04 and as an enviorment cinnamon 1.8.*.
Comment 26 Jorendc 2013-07-27 14:29:03 UTC
*** Bug 67399 has been marked as a duplicate of this bug. ***
Comment 27 Mirosław Zalewski 2013-07-27 18:39:58 UTC
@Klaas Vaag: please report separate bug regarding start center not visible. This is (most likely) not related to missing libsqlite3.so. Since this issue has been marked as fixed, no one will be looking here anymore. By posting only here, you minimize chances of getting this issue fixed in any reasonable time.

For further advice, please read this TDF wiki page:
<https://wiki.documentfoundation.org/QA/BugReport>
Comment 28 David Tardon 2013-08-01 04:46:39 UTC
*** Bug 67580 has been marked as a duplicate of this bug. ***
Comment 29 Julien Nabet 2013-08-06 15:26:36 UTC
*** Bug 65383 has been marked as a duplicate of this bug. ***
Comment 30 Joel Madero 2013-08-06 19:22:03 UTC
*** Bug 67778 has been marked as a duplicate of this bug. ***
Comment 31 Maxim Monastirsky 2013-08-12 14:04:38 UTC
*** Bug 68017 has been marked as a duplicate of this bug. ***
Comment 32 David Tardon 2013-08-19 14:20:44 UTC
*** Bug 68255 has been marked as a duplicate of this bug. ***