Download it now!
Bug 65022 - Format -> Paragraph/Page = Silent Crash
Summary: Format -> Paragraph/Page = Silent Crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: All All
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 64995 64996 65012 65058 65062 65087 65149 65177 65245 65298 66749 69347 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-05-27 04:50 UTC by Joel Madero
Modified: 2014-02-05 20:26 UTC (History)
20 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2013-05-27 04:50:31 UTC
Steps to Reproduce: 

1. Open writer
2. Format -> Paragraph

Observed: Crash no error 

Expected: No crash
Comment 1 Joel Madero 2013-05-27 04:52:40 UTC
Happens with any component, cc'ing some of the experts

Just kind of randomly picked who to CC on this one so apologies if you're not involved and shouldn't be cc'ed. Want to make sure that this gets attention ASAP

Have not tested on Linux yet
Comment 2 Fahad Al-Saidi 2013-05-27 05:45:45 UTC
I couldn't confirm it on Kubuntu 12.04. No crash happens.
Comment 3 Joel Madero 2013-05-27 05:50:19 UTC
linux is fine, so Windows only
Comment 4 Björn Michaelsen 2013-05-27 07:53:03 UTC
just tested at master@28f2af669f01cd304994f1907de0b61245b3d37a on Linux, not reproducable here.
Comment 5 Michael Meeks 2013-05-27 08:22:24 UTC
Hi Joel, I imagine it's a duplicate of one of these UNO / migration problems: throwing some exception from somewhere.

Does it persist if you move your profile away ? :-)
Comment 6 Caolán McNamara 2013-05-27 10:36:32 UTC
Almost certainly its a wrong library name in a .ui file. I rather suspect it was fixed by http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-1&id=d601bab683779c2db47c13a965405cc1be7f9147

Does the problem persist in a recent daily ?
Comment 7 khagaroth 2013-05-27 14:05:45 UTC
(In reply to comment #6)
> Almost certainly its a wrong library name in a .ui file. I rather suspect it
> was fixed by
> http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-
> 1&id=d601bab683779c2db47c13a965405cc1be7f9147
> 
> Does the problem persist in a recent daily ?

Looks like this was it, I didn't check the daily, but applied the changes to my beta1 install manually and it stopped crashing.
Comment 8 Jorendc 2013-05-27 14:12:25 UTC
I can not reproduce a crash anymore using Windows 7 x64 with libreoffice-4-1~2013-05-27_07.07.10_LibreOfficeDev_4.1.0.0.alpha1_Win_x86_ which I download here: http://dev-builds.libreoffice.org/daily/libreoffice-4-1/Win-x86@6/

So, resolved fixed.
Comment 9 Jorendc 2013-05-27 14:20:35 UTC
*** Bug 64995 has been marked as a duplicate of this bug. ***
Comment 10 Jorendc 2013-05-27 14:21:21 UTC
*** Bug 64996 has been marked as a duplicate of this bug. ***
Comment 11 Jorendc 2013-05-27 15:02:10 UTC
*** Bug 65012 has been marked as a duplicate of this bug. ***
Comment 12 Thomas van der Meulen 2013-05-28 05:22:35 UTC
Hello all, I am not sure of fdo#65058 is fixed in the patch, I think it is but I have not al lot of coding knowledge or a windows machine to test, if it is fixed with the patch can some one please set it to a duplicate. 

thank you in advance, 
Thomas van der Meulen.
Comment 13 Thomas van der Meulen 2013-05-28 07:16:51 UTC
*** Bug 65058 has been marked as a duplicate of this bug. ***
Comment 14 Michael Stahl (CIB) 2013-05-29 12:11:23 UTC
*** Bug 65062 has been marked as a duplicate of this bug. ***
Comment 15 Jorendc 2013-05-30 08:11:27 UTC
*** Bug 65149 has been marked as a duplicate of this bug. ***
Comment 16 m.a.riosv 2013-05-30 12:17:54 UTC
*** Bug 65087 has been marked as a duplicate of this bug. ***
Comment 17 Jorendc 2013-05-30 15:19:16 UTC
*** Bug 65177 has been marked as a duplicate of this bug. ***
Comment 18 Jorendc 2013-06-01 15:34:44 UTC
*** Bug 65245 has been marked as a duplicate of this bug. ***
Comment 19 Jorendc 2013-06-03 13:36:42 UTC
*** Bug 65298 has been marked as a duplicate of this bug. ***
Comment 20 Urmas 2013-07-10 15:42:28 UTC
*** Bug 66749 has been marked as a duplicate of this bug. ***
Comment 21 Joel Madero 2013-09-11 00:57:39 UTC
I just reproduced this crash again....setting to REOPEN

LibreOffice 4.2 built just yesterday
Comment 22 Joel Madero 2013-09-11 00:58:18 UTC
Setting to ALL (reproduced in Linux) - also setting to NEW as it's not assigned so reopened is incorrect - sorry for the noise
Comment 23 tommy27 2013-09-11 04:29:00 UTC
just tested on Win7 64bit

1. Open writer
2. Format -> Paragraph

no crash in 4.1.1.2
no crash in 4.2.0.0.alpha0+
Build ID: 1ea33a8cfc5bc51d0cf83989702b8be82cf52c49
TinderBox: Win-x86@39, Branch:master, Time: 2013-09-10_06:19:34
Comment 24 Caolán McNamara 2013-09-11 09:36:25 UTC
Joel, if you can reproduce this (which I can't) can you get a backtrace from gdb of the crash, and state the git hash of the top of your tree (git show)
Comment 25 Joel Madero 2013-09-11 13:04:31 UTC
My mistake - I think it was due to a partial build that had failed. Just finished building and tested again with no problem. Thanks all
Comment 26 Michael Stahl (CIB) 2014-02-05 20:26:36 UTC
*** Bug 69347 has been marked as a duplicate of this bug. ***