Download it now!
Bug 65056 - Search and replace, with tracked changes on, changing only format of text, causes Writer to hang
Summary: Search and replace, with tracked changes on, changing only format of text, ca...
Status: RESOLVED DUPLICATE of bug 36582
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 83754 (view as bug list)
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2013-05-27 23:19 UTC by Chris BL
Modified: 2017-04-20 15:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris BL 2013-05-27 23:19:28 UTC
Create new text document with contents "Hello, World".
Turn on change tracking (under Edit).
Select Find and Replace (under Edit).
Put "Hello" (no quotes) in both the find and the replace boxes.
Click on "More".
Put cursor in Replace box.
Click on Format.
Set it to, say Italic (leave other options empty). Accept.

And now, for the fatal part: Click "Replace all".
If you just replace one, you'll see why the latter fails. The replacement value gets inserted beofre the original, so then it continues on and sees the original again... ad infinitum.

What should happen: If it just put its position after the original text when searching and replacing, it wouldn't have this problem.
Comment 1 Chris BL 2013-05-27 23:23:16 UTC
Initial report at https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1126858
where it has been confirmed
Comment 2 Christopher M. Penalver 2013-05-27 23:43:03 UTC
Reproducible in:
Version: 4.2.0.0.alpha0+
Build ID: 979def88090633bfee0e0445b19999a1dac71ed
Microsoft Windows Vista Business x86 6.0.6002 Service Pack 2 Build 6002
Comment 3 Bryan Quigley 2015-01-22 19:57:16 UTC
Still Reproducible in:  4.5.0.0.alpha0+
a8835936e9d3e19443c63b7b365174254741cf76
Comment 4 Matthew Francis 2015-04-01 09:17:50 UTC
*** Bug 83754 has been marked as a duplicate of this bug. ***
Comment 5 tommy27 2016-04-16 07:27:56 UTC Comment hidden (obsolete)
Comment 6 Chris BL 2016-04-16 12:42:09 UTC
This bug still exists, unchanged after 3 years, in version 

Version: 5.0.5.2
Build ID: 1:5.0.5~rc2-0ubuntu2
Locale: en-CA (en_CA.UTF-8)

on Ubuntu 15.10
Comment 7 Timur 2017-04-20 15:51:27 UTC
Looks like a duplicate of Bug 36582. 
If you disagree, please explain and set back to New.

*** This bug has been marked as a duplicate of bug 36582 ***