Bug 65070 - FILEOPEN: PNG background image not displayed in XLSX created with MSO 2013
Summary: FILEOPEN: PNG background image not displayed in XLSX created with MSO 2013
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 65073 83718 91302 (view as bug list)
Depends on:
Blocks: Calc-Images
  Show dependency treegraph
 
Reported: 2013-05-28 09:57 UTC by squeezechart
Modified: 2019-09-27 06:17 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description squeezechart 2013-05-28 09:57:49 UTC
Problem description: 

spreadsheet background doesn't get displayed/imported

Steps to reproduce:

Spreadsheet can be downloaded here:

http://www.squeezechart.com/SqueezeChart2013-preview.xlsx

screenshot from Excel:

http://www.squeezechart.com/spreadsheet-in-Excel-15.0.4420.png

screenshot from LibreOffice:

http://www.squeezechart.com/spreadsheet-in-LibreOffice-4.0.0.1.png

Current behavior:

spreadsheet background doesn't get displayed/imported

Expected behavior:

that background image of every tab is displayed              
Operating System: Windows 8
Version: 4.0.3.3 release
Comment 1 ign_christian 2013-05-28 15:05:26 UTC
*** Bug 65073 has been marked as a duplicate of this bug. ***
Comment 2 Ken Biondi 2013-06-17 04:59:14 UTC
I have confirmed this bug and changed the status to NEW.

I tested using:

WIN 8

Version: 4.0.3.3
Comment 3 squeezechart 2014-01-26 21:14:15 UTC
the background graphic won't be displayed with 4.2.0.3 as well,
but when you click on 'format' and then 'page' and click on the tab 'background'
you can preview the background image in that window.
Comment 4 ign_christian 2014-09-09 16:14:14 UTC
After unzipping the file, it's shown that file created with Excel 2013 (15.0300) and the background image, which seems to be repeated/tiled, is PNG format. Please correct me if I'm wrong.

Reproduced since LO 3.3.0.4, also with AOO 4.1.1 under Ubuntu 12.04 x86. Seems inherited from OOO.

*) Unfortunately, my guess, xlsx import bug not qualified for MAB
Comment 5 tommy27 2014-10-06 18:35:37 UTC
bug still reproducibile under Win7x64 using LibO 4.3.2.2 and 4.4.0.0.alpha0+
Build ID: 268b9c10c9ff27c74678ace99762f28d58d33012
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-02_23:35:24
Comment 6 squeezechart 2015-06-10 10:39:38 UTC
This issue is still present in LibreOffice 5.1.0.0 alpha tested today
Comment 7 QA Administrators 2016-09-20 10:02:03 UTC Comment hidden (obsolete)
Comment 8 squeezechart 2016-09-20 12:44:12 UTC
bug is still present - tested with LibreOffice 5.2.1 on Win10_x64
Comment 9 squeezechart 2017-12-18 10:52:16 UTC
this issue is still present in LibreOffice 6.0.0 beta 2 (win64)
Comment 10 eisa01 2018-03-17 12:27:58 UTC
*** Bug 83718 has been marked as a duplicate of this bug. ***
Comment 11 eisa01 2018-03-17 12:28:39 UTC
*** Bug 91302 has been marked as a duplicate of this bug. ***
Comment 12 squeezechart 2019-09-27 06:17:09 UTC
Confirm that this bug is still present in LibreOffice 6.3.2.1 and 6.4.0.0