Bug 65148 - Master - subDocument table with merged cell error
Summary: Master - subDocument table with merged cell error
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2013-05-29 23:51 UTC by Sgt Martinez, J
Modified: 2015-10-14 19:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Sgt Martinez, J 2013-05-29 23:51:11 UTC
When saving a master document with a subdocument with a table that has a merged cell(4cx2r table, cellA1 & cellB1 merged) document fails to save.  Error is: "Error in writing sub-document content.xml".

1.  New Master Document
2.  New Sub-document
3.  Insert new table 4c x 2r
4.  Merge cell A1 & cell B1
5.  Add text to cells
6.  Apply formatting to cells: merged cell is H1, all others H10
7.  Save sub-document
8.  Insert sub-document into master document
9.  Save Master Document.

Only remedy so far, use existing sub-document, re-write text and "Save As", then insert into master document.
Comment 1 Sgt Martinez, J 2013-05-29 23:59:18 UTC
Same issue with OpenOffice 3.4, and LibreOffice3.6, tried to use LO4.0, but just kept going to LO3.6
Comment 2 Owen Genat (retired) 2013-06-10 06:36:39 UTC
This sounds like bug #60769, which has been fixed for v4.0.2 and v4.0.3. Please try one of those versions. If it does fix the issue, then I think this bug can be RESOLVED as a DUPLICATE.
Comment 3 tommy27 2013-08-24 12:49:40 UTC
@Sgt Martinez, J
as requested before, have you tried recent LibO 4.0.x releases (4.0.5 is out)?
do you still reproduce the bug?

changing status to NEEDINFO
Comment 4 Sgt Martinez, J 2013-08-26 12:11:04 UTC

That is a negative, same error.  Just installed LO4.1 on WinXP, same error when adding document to master.
Comment 5 tommy27 2013-08-26 12:50:41 UTC
Ok. reverting status to UNCONFIRMER.
Comment 6 Jorendc 2013-11-19 18:36:07 UTC
I also fail to reproduce, tested using Mac OSX 10.9 with LibreOffice Version:
Build ID: 9c45345a680f7444df251f9403c7d56572380f21
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-18_12:43:03

On step 6 my merged cell is just A1 and others keeps their logical order (A2 and B2 in next column, etc).

Kind regards,
Comment 7 Owen Genat (retired) 2013-11-21 11:14:10 UTC
Joren, this may be a Windows-build issue. I tested also under Ubuntu 10.04 x86_64 running these LO versions without being able to reproduce:

- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a
Comment 8 Sgt Martinez, J 2013-11-21 12:54:03 UTC
Sorry took so long, been very busy with new policies, Installed LO (several weeks ago) on a WinXP and Win7 machine, inserted file with cells, no issue.

I believe that is was one of two issues, Win2k or LO3.6 issue.
Comment 9 Sgt Martinez, J 2013-11-21 13:04:18 UTC
Well, I just lied.  After adding several more documents, all with the same format, same error when closing master document "Error in writing subdocument content.xml"
Comment 10 Joel Madero 2014-11-06 17:38:51 UTC
Never confirmed - moving to UNCONFIRMED so QA looks at it. Thanks
Comment 11 A (Andy) 2014-11-06 21:09:20 UTC
For me not reproducible with LO, Win 8.1.

Is this still reproducible for you with the latest release of LO?
Comment 12 Buovjaga 2014-11-16 17:10:50 UTC
No repro here, either. Setting to NEEDINFO as we wait for the reporter's experience with 4.3.

Win 7 64-bit Version:
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 13 QA Administrators 2015-09-04 02:55:50 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-09-03
Comment 14 QA Administrators 2015-10-14 19:48:48 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INVALID due to inactivity and a lack of information which is needed in order to accurately reproduce and confirm the problem. We encourage you to retest your bug against the latest release. If the issue is still present in the latest stable release, we need the following information (please ignore any that you've already provided):

a) Provide details of your system including your operating system and the latest version of LibreOffice that you have confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED and we will attempt to reproduce the issue. 
Please do not:
a) respond via email 
b) update the version field in the bug or any of the other details on the top section of FDO

Message generated on: 2015-10-14