Download it now!
Bug 65390 - Zero value in cell displayed as ###
Summary: Zero value in cell displayed as ###
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.2.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-05 06:23 UTC by Paijo
Modified: 2014-08-08 15:18 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Partial screenshot cell formating, that zero displayed as ### (61.37 KB, image/jpg)
2013-06-05 06:23 UTC, Paijo
Details
attachment-10141-0.html (6.59 KB, text/html)
2013-06-07 02:35 UTC, Paijo
Details
attachment-10141-1.dat (1 bytes, multipart/alternative)
2013-06-07 02:35 UTC, Paijo
Details
Screenshot from 2013-06-07 10:24:57(Zero wrong display).jpg (176.32 KB, image/jpeg)
2013-06-07 02:35 UTC, Paijo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paijo 2013-06-05 06:23:31 UTC
Created attachment 80321 [details]
Partial screenshot cell formating, that zero displayed as ###

Zero value in cell displayed as "###"
When edited (pressing "F2" keyboard and following with enter), the cell format display back to normal.
Comment 1 Cor Nouws 2013-06-05 07:23:26 UTC
Hi paijo,
Thanks for the report.
The bug is known and already fixed in the latest version.
See bug 63176 and bug 60755 for details.
Kind regards,
Cor

*** This bug has been marked as a duplicate of bug 60755 ***
Comment 2 Paijo 2013-06-07 02:14:22 UTC
I think it is not related to bug 60755,
but quite similar to bug 63716. But in my case, it happen if the value is zero.

It happen in both formula resulting zero and a 0 entered in cell.

Adding column width solve the problem, but it weird that any value not equal to zero displayed correctly in current column width.
Comment 3 Paijo 2013-06-07 02:35:46 UTC
Created attachment 80445 [details]
attachment-10141-0.html

I do not think it is a duplicate of bug 60755. I did not see any relation between view formula is checked or not.

I do agree this bug similar to bug 63176.

I provide another full screenshot.
In the cell a zero (0) entered, and not a formula, but displayed as ### (Cell D94, D95)
but other cells (in cell C94 and C95), it correctly displayed. They are not formula. They are zero, have same number format.


Regards,

Yunus


________________________________
 From: "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org>
To: paijo.iseng@yahoo.com 
Sent: Wednesday, June 5, 2013 3:23 PM
Subject: [Bug 65390] Zero value in cell displayed as ###
 


 
Cor Nouws  changed bug 65390 

What
Removed
Added
Status UNCONFIRMED  RESOLVED  
Resolution ---  DUPLICATE  
CC    cno@nouenoff.nl  
Comment # 1 on bug 65390 from Cor Nouws  
Hi paijo,
Thanks for the report.
The bug is known and already fixed in the latest version.
See bug 63176 and bug 60755 for details.
Kind regards,
Cor *** This bug has been marked as a duplicate of bug 60755 ***
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 4 Paijo 2013-06-07 02:35:47 UTC
Created attachment 80446 [details]
attachment-10141-1.dat
Comment 5 Paijo 2013-06-07 02:35:47 UTC
Created attachment 80447 [details]
Screenshot from 2013-06-07 10:24:57(Zero wrong display).jpg
Comment 6 Paijo 2013-08-13 02:02:22 UTC
The 0 (zero) shown as "###' occur with ms excel files with "accounting" number format.
It fixed by modifying number format created by ms Excel to LO style (by removing the asterisk on number format),
Comment 7 ign_christian 2013-08-29 04:17:43 UTC
Halo Paijo..

I think we should raise / reopened this bug, because some limitation to read Excel's format code (you said "accounting" number format). But it's not only with zero values, and occurs after saving & reopening file. Of course I'm also suffering because of this bug..it's (almost) impossible to modify cell format of dozens/hundreds documents in the whole organization.
-> last tested on LO 4.0.5.2 (Win7 32bit) & LO 4.0.4.2 (PCLinuxOS KDE)

I have different problem but might be derived from same root cause : Bug 66089, perhaps you could help confirming.. :)

This kind of problems avoid so many users in Indonesia using LO, as XLS/X format (in other word: Excel) is hugely used in our country. (I guess we come from the same ;))

Please rechange the status if you don't agree.
Comment 8 retired 2014-06-27 20:52:22 UTC
Can we have a test file to reproduce this problem?

Also I think the html and dat files under attachments can be removed, right?

Please provide a document and exact steps to reproduce. Thanks.
Comment 9 ign_christian 2014-06-28 07:54:10 UTC
(In reply to comment #8)
> Can we have a test file to reproduce this problem?
I'll attach if find any.
 
> Also I think the html and dat files under attachments can be removed, right?
Should be..but I don't know how to do that


(In reply to comment #6)
> The 0 (zero) shown as "###' occur with ms excel files with "accounting"
> number format.
> It fixed by modifying number format created by ms Excel to LO style (by
> removing the asterisk on number format),
It's the only clue we have currently.
Comment 10 ign_christian 2014-07-05 05:54:47 UTC
I haven't found any sample file yet. I'll open new report later if I have it.

So closing this report according to comment 6