Bug 65393 - FILEOPEN: DOCX Import - Signature line doesn't show digital signature
Summary: FILEOPEN: DOCX Import - Signature line doesn't show digital signature
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Samuel Mehrbrodt (CIB)
URL:
Whiteboard: BSA target:6.0.0
Keywords: filter:docx
Depends on:
Blocks: DOCX Digital-Signatures
  Show dependency treegraph
 
Reported: 2013-06-05 07:33 UTC by Adam CloudOn
Modified: 2017-12-12 12:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test_file (14.15 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-11-20 16:40 UTC, Thomas van der Meulen
Details
Signed file (22.34 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2017-07-27 15:14 UTC, Samuel Mehrbrodt (CIB)
Details
How it looks in Word (126.83 KB, application/pdf)
2017-07-27 15:15 UTC, Samuel Mehrbrodt (CIB)
Details
How it looks in LibreOffice (29.52 KB, application/pdf)
2017-07-27 15:16 UTC, Samuel Mehrbrodt (CIB)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam CloudOn 2013-06-05 07:33:26 UTC
Problem description: 
When opening a signed DOCX in LO - the signature image is not shown.

Steps to reproduce:
1. Open Signed DOCX in LO
2. The signature image is not shown

Current behavior:
Signature image is not shown in LO

Expected behavior:
Signature image should be shown in LO

Note: I'm afraid I have no signed DOCX at this point that I can publicly add to this bug report.
If a QA guy can manage to create one and add it - it would be great. sorry for that.
              
Operating System: Windows 8
Version: 4.0.3.3 release
Comment 1 Thomas van der Meulen 2013-11-20 16:40:33 UTC
I have a tested this bug with a signature image but is open's just fine and the image is shown in 4.1.3.2, 4.1.0.4 and 4.0.3.2 and 4.2 alpha 1. maybe I am testing the wrong thing so I will attach the file that I tested with and I hope that you could give any feedback on it. 

tested with mac osx 10.9 and windows 8 (only 4.1.0.4 on windows)
Comment 2 Thomas van der Meulen 2013-11-20 16:40:53 UTC
Created attachment 89536 [details]
Test_file
Comment 3 retired 2013-11-20 19:39:08 UTC
Adam: Is this bug still valid / reproducible with the latest LO release?  Currently 4.1.3.2: http://www.libreoffice.org/download/
Comment 4 Adam CloudOn 2013-11-21 14:09:36 UTC
(In reply to comment #3)
> Adam: Is this bug still valid / reproducible with the latest LO release? 
> Currently 4.1.3.2: http://www.libreoffice.org/download/

@Thomas van der Meulen, @Foss -
The document that you have attached has a signature box (which is being shown in LO properly), but has no signature in it.
If you try adding a signature in Word to that signature box, save it and open it in LO - you will see that the actual signature is not being rendered in LO.
Comment 5 Thomas van der Meulen 2013-11-21 16:23:48 UTC
Oke tested with a new file that had a signature box and now I can see and reproduce the bug.
Version: 4.2.0.0.beta1
Build ID: f4ca7b35f580827ad2c69ea6d29f7c9b48ebbac7
os: mac osx 10.9
I am not going to share the document for my own safety
Comment 6 QA Administrators 2015-04-19 03:19:52 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2016-09-20 09:24:28 UTC Comment hidden (obsolete)
Comment 8 Telesto 2016-12-10 15:43:10 UTC
Repro with:
Version: 5.4.0.0.alpha0+
Build ID: b894104a0b02a9b074c76feb925389d7bee6a493
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-12-10_01:00:52
Locale: nl-NL (nl_NL); Calc: CL
Comment 9 Samuel Mehrbrodt (CIB) 2017-07-27 15:14:22 UTC
Created attachment 134903 [details]
Signed file
Comment 10 Samuel Mehrbrodt (CIB) 2017-07-27 15:15:32 UTC
Created attachment 134904 [details]
How it looks in Word
Comment 11 Samuel Mehrbrodt (CIB) 2017-07-27 15:16:06 UTC
Created attachment 134905 [details]
How it looks in LibreOffice
Comment 12 Samuel Mehrbrodt (CIB) 2017-07-27 15:17:39 UTC
Turns out the test file didn't even have a signature.
I signed the document and uploaded it. 

In LibreOffice you can see that there is a digital signature (File->Digital Signatures), but it is not visible in the document itself.
Comment 13 Samuel Mehrbrodt (CIB) 2017-08-11 10:29:06 UTC
WIP Patch: https://gerrit.libreoffice.org/#/c/40980/
Comment 14 Samuel Mehrbrodt (CIB) 2017-11-02 15:39:48 UTC
This ticket is about importing only.
For exporting we first need to implement the whole signature line feature (see bug 108089 and bug 83877 for that).
Comment 15 Commit Notification 2017-11-03 12:57:39 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd3c5c4c234e3dc6b89cd235321945a41a08d562

[API CHANGE] tdf#65393 Import signature line images from ooxml

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2017-11-06 11:18:30 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=193aa63a2aa697e3689eedd63775afffb6ed9ef1

tdf#65393 Test for signature line images

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.