Download it now!
Bug 65516 - Shapes modified to Polygons shown at wrong position in AOO and old LibreOffice versions
Summary: Shapes modified to Polygons shown at wrong position in AOO and old LibreOffic...
Status: RESOLVED DUPLICATE of bug 71919
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-07 17:23 UTC by Bugcruncher
Modified: 2015-06-16 16:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Demo Document (11.30 KB, application/vnd.oasis.opendocument.graphics)
2013-06-07 17:23 UTC, Bugcruncher
Details
odg that has screen shots of the results (93.18 KB, application/vnd.oasis.opendocument.graphics)
2013-06-09 12:28 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bugcruncher 2013-06-07 17:23:15 UTC
Created attachment 80483 [details]
Demo Document

Many of my drawings look like after a heavy earthquake after edits of users with old LibreOffice or OOo / AOO versions. I was able to create a demo with an old 3.3.0 Portable Version. Open it with 4.0.3, everything looks fine, all shapes touch arrow lines. Save under new name, reopen with LibreOffice 3.3.0 or AOO, most polygons are shifted to the right. Of course it might be that the different position problem is the result of a bugfix in LibreOffice, what breaks compatibility with old Versions, and I will have to live with it ...
But it makes document interchange painful.
I see such wrong to all positions in my drawings, mostly horizontally shifted, sometimes vertically.
I believe the change is long before 4.0.3 But I can't tell when.
Comment 1 Cor Nouws 2013-06-08 08:40:24 UTC
Hi there,
Thanks for the proza ;)
It's a bit unspecific to handle. And the good news I read in your report that it's fine in 4.0.3 ...

I you have a specific issue, with a sample document that behaves correct here and incorrect there, pls do report. But oh, you may also try to look if the issue already is reported. That would of course be marvellous ;)

Regards - Cor
Comment 2 Bugcruncher 2013-06-08 11:28:47 UTC
I read somewhere that criticizing staff for closing bug decisions will not be accepted, but ...

Can please someone try to reproduce who is willing to do the simple "Open with Libreoffice4  - Save - Reopen with AOO" test? And if he can reproduce the results think about interpretation? 

If Libreoffice produces Drawings what are incompatible to the rest of the ODF world (I just tried Calligra Karbon, has the same problem with documents created from  the sample due to report) at least some minimum investigation should be done.
Comment 3 Cor Nouws 2013-06-08 12:10:47 UTC
(In reply to comment #2)
> I read somewhere that criticizing staff for closing bug decisions will not
> be accepted, but ...

:) No staff here. Volunteer ;)

But sorry if I misinterpreted what you wrote. I found it too unclear. But that may be my fault.

> Can please someone try to reproduce who is willing to do the simple "Open
> with Libreoffice4  - Save - Reopen with AOO" test? And if he can reproduce
> the results think about interpretation? 

Will try later.
thanks for insisting...
Cor
Comment 4 Cor Nouws 2013-06-09 12:27:55 UTC
Hi bugcruncher,

OK I set this to new.
However, where is the bug??
           NEEDINFO 

I created a new file in LibreOffice 410beta2 and if I open that in AOO, the polygon is at the same position.

It could be possible to do more tests, e.g. create one in AOO and see how that behaves. Or create one in LibreOffice 3.5.x and 3.6.x etc..

Mind trying that? thanks,
Cor

(I'll add my results)
Comment 5 Cor Nouws 2013-06-09 12:28:47 UTC
Created attachment 80564 [details]
odg that has screen shots of the results
Comment 6 Bugcruncher 2013-06-12 05:35:56 UTC
In original sample the problem only appears with rotated shapes, but it is not related to rotation. you can also see the problem with a Isoscles Triangle Shape.

Draw it, modify it to Polygon, if you sant add a marker for the current position, save and reopen with AOO. You will see that the triangle shape has moved to the right.
When you click the triangle shape without "Edit Points Mode" active you will see that the "real triangle shape" only fill a small part of the area marked by the control points. Switching now to "Edit Points Mode" you see some strange extra points, what might be related to <https://bugs.freedesktop.org/show_bug.cgi?id=37559#c54>. It seems that extra points above or left from the "real shape" cause the wrong position (try with 4 shapes, next always rotated 90° additional before your modify to polygon. Only shapes with extra points left or above the shape are at wrong position in AOO.

So I am pretty sure that this one is an other aspect of Bug 65127. BTW, I believe it's not a good idea that Bug 65127, what seems to be the root of the problems, is a DUP of Bug 37559, what only shows a manifestation of the root problem (like this report).
Comment 7 Robinson Tryon (qubit) 2013-10-29 20:44:06 UTC
Based on my reading of this bug, we haven't been able to confirm it, so I'm returning status to UNCONFIRMED.

Cor - If you can't confirm, please RESOLVE WORKSFORME.

Bugcruncher - Do you have any more example documents or different repro steps that demonstrate this problem?
Comment 8 Dominique Boutry 2013-11-29 09:46:51 UTC
Lib0 4.1.2.3 on Win7 : I can reproduce the bug, precisely with ths described steps :
- open a new Draw document,
- draw a Isocele Triangle Shape,
- modify it to Polygon,
- save it and reopen with AOO (4.0.0 for me).

One can effectively see that :
- the triangle shape has moved to the right,
- when you click the triangle shape without "Edit Points Mode" active you will see that the "real triangle shape" only fill a small part of the area marked by the control points,
- switching now to "Edit Points Mode" you see 2 extra points, left and below.
Comment 9 Regina Henschel 2013-12-01 00:10:09 UTC
I can confirm, that the Isocele Triangle shape, which is converted to polygon, is shifted, when the file is opened in AOO. I do not see any additional point.

The polygon uses svg:path internally. And for those the way AOO and LO had drawn it, has a bug in some special cases. The bug has been fixed in LO4.1 and in a different way in LO4.2 (developer version), and in AOO4.1 (developer version). For more details see bug 71919.

If you need to use files between old and new versions, you can workaround it this way:
In LO4.1 use the save option "ODF1.2 Expanded (compat mode)". That makes is exchangeable, but you must not use the option "ODF1.2 Expanded (recommended)". When you use LO4.2 or AOO4.1 to save the file, then it is written in a way, that older versions will show it correctly, and those versions should be able to read older version correctly. Only documents that are written with LO4.1 in "ODF1.2 Expanded (recommended)" will show the error.

If you find my workaround correct, please set this bug as duplicate to bug 71919.
Comment 10 QA Administrators 2015-04-19 03:21:38 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 11 Buovjaga 2015-06-16 16:46:10 UTC
This has been sitting in limbo for 1,5 years. I'll set to dupe per comment 9 and the original reporter can dispute, if they want.

*** This bug has been marked as a duplicate of bug 71919 ***