Bug 65583 - Elements Dock window needs scroll bar.
Summary: Elements Dock window needs scroll bar.
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta2
Hardware: All All
: medium major
Assignee: Marcos Souza
URL:
Whiteboard: target:4.4.0 target:4.3.0.0.beta2 tar...
Keywords:
: 67393 78184 79215 (view as bug list)
Depends on:
Blocks: Elements-Pane 68871
  Show dependency treegraph
 
Reported: 2013-06-09 20:48 UTC by Regina Henschel
Modified: 2016-10-31 09:35 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of Elements Dock window (55.44 KB, image/png)
2013-06-09 20:48 UTC, Regina Henschel
Details
Scrollbar patch (5.18 KB, patch)
2013-11-05 10:44 UTC, Marcos Souza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2013-06-09 20:48:04 UTC
Created attachment 80587 [details]
Screenshot of Elements Dock window

Open the 'Operator' part of the Elements Dock window. Notice, that it is much higher than the monitor. The most items are unreachable, see attached screenshot. Therefore the window needs a scroll bar.
Comment 1 Jorendc 2013-06-09 22:03:03 UTC
I can confirm this using Linux Mint 15 x64 with LibreOffice Version: 4.2.0.0.alpha0+ Build ID: 55ff402fa24bcf9478e7fde94f2ab57c2223b7f
I'm struggling about that fact this is an enhancement request or not, but because this result in unreachable symbols -> bug

Kind regards,
Joren
Comment 2 Jorendc 2013-07-27 14:32:40 UTC
*** Bug 67393 has been marked as a duplicate of this bug. ***
Comment 3 Stefan Knorr (astron) 2013-07-27 15:54:57 UTC
Can reproduce on Windows 7, with 4.1.0.4.
Sorry for opening the duplicate. Also, this is definitely a bug, not an enhancement, imo.
Comment 4 Marcos Souza 2013-11-04 10:51:38 UTC
I'm implementing this feature, but when I'm changing the scrollbar dow, I'm don't see the others itens, just a blank page...

Maybe I need to paint again?
Comment 5 Thomas Arnhold 2013-11-04 18:44:33 UTC
Marcos: Yes, maybe :)
Comment 6 Marcos Souza 2013-11-05 10:44:59 UTC
Created attachment 88684 [details]
Scrollbar patch

This is not working when we change the listbox and it's not showing the elements when the dock is resized.

What we need to do here?
Comment 7 Thomas Arnhold 2013-11-11 09:21:59 UTC
Please could someone help Marcos on implementing the scrollbar? This would be awesome :)
Comment 8 Tomaz Vajngerl 2013-11-11 11:08:45 UTC
Maybe it is the best to reuse the code of Impress > Side Pane > Layouts. Layouts dock has a similar behavior than the Elements dock but it is in general complete (supports scrolling and no flickering under Windows). I would firstly locate the code and then analyze if we could reuse it easily (maybe it will be necessary to move the code to svx).
Comment 9 Tomaz Vajngerl 2014-05-02 12:53:26 UTC
*** Bug 78184 has been marked as a duplicate of this bug. ***
Comment 10 Adolfo Jayme 2014-05-27 06:03:30 UTC
*** Bug 79215 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2014-05-27 23:41:40 UTC
Thomas Arnhold committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a630c368f791a178e068fac542c00086ae594c2a

Resolves: fdo#65583 Elements Dock window needs scroll bar



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-05-27 23:44:14 UTC
Thomas Arnhold committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e9a261b6d605ead0de82397c2493254ba5815fd&h=libreoffice-4-3

Resolves: fdo#65583 Elements Dock window needs scroll bar


It will be available in LibreOffice 4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Marcos Souza 2014-05-27 23:44:52 UTC
WOW!

Nice to see this!

I assigned this to me, but I didn't had time to finish this task!

Thanks a lot for this Thomas! You're the guy :)

I'm compiling right now to see the results!
Comment 14 Thomas Arnhold 2014-05-27 23:49:44 UTC
Yeah, finally, it's there :)
Comment 15 Commit Notification 2014-05-28 15:31:11 UTC
Thomas Arnhold committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=477e1eac51cd2840472a2eab8ef68cc352742705&h=libreoffice-4-2

Resolves: fdo#65583 Elements Dock window needs scroll bar


It will be available in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Marina Latini (CIB) 2014-05-29 07:32:13 UTC
VERIFIED on:
* Version: 4.4.0.0.alpha0+
* Build ID: 0e54f1266db4722428ed8fc9d9f3cb7e3cd34fed
* TinderBox: Linux-rpm_deb-x86_64@46-TDF 
* Branch:master
* Time: 2014-05-29_04:06:52

OS: Ubuntu 14.04 x86_64
Comment 17 Stephan Bergmann 2016-10-31 09:35:22 UTC
[libreoffice@lists.freedesktop.org had been added to cc by Thomas Arnhold in 2013, for whatever reason; dropping it again to avoid spamming the mailing list]