Download it now!
Bug 65603 - Scrolling and display problem in LibreOffice 3.6 and above
Summary: Scrolling and display problem in LibreOffice 3.6 and above
Status: RESOLVED DUPLICATE of bug 58358
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest
Depends on:
Blocks:
 
Reported: 2013-06-10 10:41 UTC by cipricus
Modified: 2015-12-17 07:15 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
image of the document after scrolling down (298.90 KB, image/png)
2013-06-10 10:41 UTC, cipricus
Details
text image after scrolling down and then up again (120.44 KB, image/png)
2013-06-10 10:44 UTC, cipricus
Details
text at the zoom level where the problem disappears (85.19 KB, image/png)
2013-06-10 10:45 UTC, cipricus
Details
document view before scrolling (226.24 KB, image/png)
2013-06-10 10:49 UTC, cipricus
Details
VGA hardware details (126 bytes, text/plain)
2013-06-10 11:23 UTC, cipricus
Details
drivers details (228 bytes, text/plain)
2013-06-10 11:26 UTC, cipricus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cipricus 2013-06-10 10:41:48 UTC
Created attachment 80607 [details]
image of the document after scrolling down

This problem started with a new version of LibreOffice, 3.6.2.2. (the one with the new green splash screen instead of the old white one) and continued up to the latest 4.x versions.

My documents are not displayed properly when I scroll up or down.
 I have seen this mostly in the Writer, but Calc and Impress are also affected. Have not tested in other applications of the suite.

The problem appears only above a certain zoom level and is the same in odt or doc.

The display is completely distorted as seen in the attached image.

Clicking on the text restores it but it always goes back to the beginning which is the only part that is visible in this way - and larger documents are almost unusable!

The document can be taken under control if the zoom is equal or lower than 180%. It may vary depending on display and resolution, but it seems to me that the problem disappears as soon as the zoom goes down so that the page is largely within the margins of the maximized window.

I have experienced this with all LibreOffice versions above 3.5 in Lubuntu and Xubuntu 12.10 (have not used the suite under other OS.) When filing the bug I had to select a version, and have selected 3.6, but in fact I experience this in all the latest versions.

More images in this askubuntu question: http://askubuntu.com/q/238098/47206
Comment 1 cipricus 2013-06-10 10:44:11 UTC
Created attachment 80608 [details]
text image after scrolling down and then up again
Comment 2 cipricus 2013-06-10 10:45:22 UTC
Created attachment 80609 [details]
text at the zoom level where the problem disappears
Comment 3 cipricus 2013-06-10 10:49:54 UTC
Created attachment 80610 [details]
document view before scrolling
Comment 4 cipricus 2013-06-10 11:23:23 UTC
Created attachment 80613 [details]
VGA hardware details
Comment 5 cipricus 2013-06-10 11:26:42 UTC
Created attachment 80614 [details]
drivers details
Comment 6 cipricus 2013-06-10 11:28:51 UTC
The same experience at a certain point in Linux Mint 14 (nadia) with Xfce
Comment 7 Björn Michaelsen 2013-06-10 13:00:35 UTC
Please always specify the exact version including the source (libreoffice PPA, libreoffice.org download). Also note that this look plain simply like a graphics driver bug -- the fact that older versions of LibreOffice did not trigger it is likely pure luck.
If possible to reproduce, please bibisect this bug:
https://wiki.documentfoundation.org/Bibisect
Comment 8 cipricus 2013-06-10 13:52:03 UTC
(In reply to comment #7)
> Please always specify the exact version including the source (libreoffice
> PPA, libreoffice.org download). Also note that this look plain simply like a
> graphics driver bug -- the fact that older versions of LibreOffice did not
> trigger it is likely pure luck.
> If possible to reproduce, please bibisect this bug:
> https://wiki.documentfoundation.org/Bibisect

I have not tested this for all possible versions and sources, although I expect the bug/error to appear for any version above 3.5 no matter the source. I can state that the first version with the problem was the first stable 3.6.x which i got updating from ubuntu quantal main repos. Then I have updated until 4.0.1 expecting the issue to disappear. Beside Ubuntu repos (stable) I have indeed used the libreoffice.org download source but cannot specify exactly which. 

At a certain  point I gave up updating. Because efore 3.6 I did not have that problem I simply went back to this version: the problem was gone.

It might very well be related to the VGA hardware or driver. I was instructed on askubuntu to try and file as a bug and so I did. I will keep using 3.5 and try to see if things will change in future releases.
Comment 9 cipricus 2013-06-10 17:16:03 UTC
(In reply to comment #7)
> Please always specify the exact version including the source (libreoffice
> PPA, libreoffice.org download). Also note that this look plain simply like a
> graphics driver bug -- the fact that older versions of LibreOffice did not
> trigger it is likely pure luck.
> If possible to reproduce, please bibisect this bug:
> https://wiki.documentfoundation.org/Bibisect

"the fact that older versions of LibreOffice did not trigger it is likely pure luck" 

- I do not understand what this means exactly: does it mean that this might have happened in 3.5 and older, and that was just by chance that it did not? and that it might happen? I do not think it will ever happen in fact. I have installed on my machine the 3.5 version from deb, and 'locally' I have installed for testing 3.3.1 and 3.2.0 (I was not able to make older versions work in this way and am not able to test before 3.2). The reported problem did not appeared at all.  I could test all the 3.4.x versions as well. But that will not happen. No matter what the problem is here, it is strictly related to 3.6 and newer versions.
Comment 10 cipricus 2013-06-10 17:18:28 UTC
I have tested  	4.1.0.0.beta2 (from here: http://downloadarchive.documentfoundation.org/libreoffice/old/).

The same problem.
Comment 11 cipricus 2013-06-10 18:55:13 UTC
As expected, OpenOffice 3.4.1 (latest) is not affected.
Comment 12 Paddy Landau 2013-06-18 15:53:00 UTC
I sometimes get a similar issue, unfortunately not easily reproducible. It happens to me even when at 100% zoom. When I minimise and restore the window, it is solved.
Comment 13 Lorenzo 2013-07-02 16:18:01 UTC
Hello,

  I have the exact same problem. I see it in Calc (which is the part of LO that I use). I was also using 3.6.something and then 4.x.x and it's the same. I am using Ubuntu 12.04. 

  What 'force' to refresh the window (Calc in my case) is switching to another application with Alt+Tab, back and forth. It happens with vertical and horizontel scrolling. 

   Thank you in advance. 

   Best,

         Lorenzo


Tech info:

Version 4.0.4.2 (Build ID: 400m0(Build:2))

java version "1.7.0_25"
Java(TM) SE Runtime Environment (build 1.7.0_25-b15)
Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)


lspci | grep VGA

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI M96 [Mobility Radeon HD 4650]


uname -a
Linux  3.5.0-34-generic #55~precise1-Ubuntu SMP Fri Jun 7 16:25:50 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 14 Alexander Shikov 2013-07-24 10:49:29 UTC
I confirm this bug.
For me it happens with calc on any zoom level: scrolling completely distorts
document. Playing with options like "Use hardware acceleration", "Use anti-aliasing" does not resolve an issue.

I'm using LO 4.0.4 compiled from ports tree on FreeBSD 10-CURRENT.
Configure options --enable-gtk3 or --enable-gtk have no any effect.

It seems that bug does not depend on graphical adapter, I see the same behavior
on remote X terminal.
Comment 15 Maxim Monastirsky 2013-09-08 16:08:10 UTC

*** This bug has been marked as a duplicate of bug 58358 ***
Comment 16 Robinson Tryon (qubit) 2015-12-17 07:15:50 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]