Bug 65646 - FORMATTING: Wrong display of a table contents
Summary: FORMATTING: Wrong display of a table contents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-11 09:58 UTC by olafbond
Modified: 2016-04-17 07:49 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example 01.doc file (29.00 KB, application/msword)
2013-06-11 09:58 UTC, olafbond
Details
Screenshot of corrupted table (57.17 KB, image/jpeg)
2013-06-20 16:40 UTC, jolay
Details

Note You need to log in before you can comment on or make changes to this bug.
Description olafbond 2013-06-11 09:58:11 UTC
Created attachment 80674 [details]
Example 01.doc file

Problem description: Content of a table cells is shifted.

Steps to reproduce: Open a supplied example 01.doc.

Current behavior: In a Writer 4.0.3 yellow field is under green and green is shifted out of the table.

Expected behavior: Yellow data must be under yellow. Green must be under green.

              
Operating System: Windows 7
Version: 4.0.3.3 release
Comment 1 jolay 2013-06-20 16:40:27 UTC
Created attachment 81123 [details]
Screenshot of corrupted table
Comment 2 jolay 2013-06-20 16:48:49 UTC
This bug is there on openSUSE 12.3:
uname -a
Linux 3.8.9-5-desktop #1 SMP PREEMPT x86_64 GNU/Linux

zypper info libreoffice-writer
Repository: LibreOffice:Stable
Name: libreoffice-writer
Version: 4.0.3.3.4-1.1
Arch: x86_64
Vendor: obs://build.opensuse.org/LibreOffice
Installed: Yes
Status: up-to-date

I opened someone's DOCX in LibreOffice, modified the table (everything was fine...), save in DOC 2003 (not DOCX) and reopened later.
  
See screenshot:
The content of the first column is mixed with those of the other columns "randomly", leaving empty cells.
The titles of the columns shift to right, the last one (WE) is written the first cell of the next row.
The numbers in percentage are not in their respective places. I am not sure about their right places, may be following the sequence of emptied cells.
Some text format changes.

Expected : 
Second column title should be "AA", last column "WE" (capitalized letters)
The cells contain numbers in percentage
Comment 3 olafbond 2013-06-26 11:40:14 UTC
Windows 8
LO 4.0.4.2
The samr problem
Comment 4 retired 2013-07-03 14:30:30 UTC
When I open the example 01.doc file from bug reporter I do see that the formatting  of the table indeed gets distorted (see screenshot 01 docfile in word and LO).

Jolay: your screenshot is also helpful but without the doc file that screenshot was created from, we won't be able to reproduce and then fix the issue. So if you can, please attach the doc file containing the table in question.

Setting to NEW., OS to ALL.
Comment 5 olafbond 2015-03-04 07:04:38 UTC
Still on 4.4.1.2
Comment 6 tommy27 2016-04-16 07:22:36 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.5 or 5.1.2 https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 

3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-04-16
Comment 7 olafbond 2016-04-17 07:49:21 UTC
LO 5.1.2.2 
Windows 10