Download it now!
Bug 65672 - Copy-Paste from Visio leads to strange effects
Summary: Copy-Paste from Visio leads to strange effects
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: needsVisio
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-12 12:00 UTC by A. Stucki
Modified: 2016-01-15 09:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip with Visio Source, Visio screenshot, Writer screenshot (559.76 KB, application/zip)
2013-06-12 12:00 UTC, A. Stucki
Details
ODT file w/ Visio drawing inserted (50.44 KB, application/vnd.oasis.opendocument.text)
2013-06-13 15:28 UTC, A. Stucki
Details
OPs Visio .VSD drawing OLE inserted into Writer (355.99 KB, application/vnd.oasis.opendocument.text)
2015-08-16 15:01 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A. Stucki 2013-06-12 12:00:22 UTC
Created attachment 80723 [details]
Zip with Visio Source, Visio screenshot, Writer screenshot

When inserting drawing via clipboard from Visio (2010) to Writer (this worked before 3.6!), strange effects occur, both via copy and copy special.
I attached the original and result as screenshots (LO master-2013-06-11), also the Visio file. Any Writer file will produce the error, but I can add one one request.
Andy
Comment 1 Michael Meeks 2013-06-12 12:46:52 UTC
Any chance of the resulting writer document too save as ODF ? ultimately this will be an EMF+ meta-file rendering bug of the preview of the OLE object that is stored there, and that's the file we'll end up fixing :-)

Thanks ! ( and confirming it looks plausible ;-)
Comment 2 A. Stucki 2013-06-13 15:28:53 UTC
Created attachment 80782 [details]
ODT file w/ Visio drawing inserted

Writer odt with Visio copied: note that after saving, the inserted image is an empty frame (see screenshot for how it looked before reopening)
Comment 3 V Stuart Foote 2015-08-16 15:01:20 UTC
Created attachment 117942 [details]
OPs Visio .VSD drawing OLE inserted into Writer

Draw opens the Visio .VSD with good fidelity, minor font and style issues--but legible.  Likewise Insert OLE object renders with good fidelity, so libvisio is handling things correclty.

However, copy paste -> special looks to be an issue.

When the .VSD is opened in Draw, while it shows good fidelity, the Copy and Paste Special -> More Options -> "Draw 8" paste is truncating the bottom edge of the converted Visio object. The Visio object is otherwise legible.

Don't have Viso to work with so not sure about filter for Copy -> Paste Special there.

Attached .ODT from current 5.0.1.1 release, on Windows 10 Pro 64-bit.

Would say resolved fixed. Changing component from Draw to libvisio filter.
Comment 4 V Stuart Foote 2015-08-16 15:07:34 UTC
Added a needsVisio whiteboard item.

This needs to be checked with Visio drawing open in a Visio instance, and use LibreOffice Paste Special -> More options to judge fidelity of the filter import directly from Visio.

OLE linking of the .VSD Drawing with libvisio is otherwise pretty good.
Comment 5 Fridrich Strba 2016-01-15 09:16:28 UTC
This has nothing to do with how the visio filter operates. What Writer is rendering if you don't click on the OLE object is a replacement EMF+ image of this object. So, any problem with that rendering is actually problem of the EMF+ renderer.
Nevertheless, the last attached file looks like the issue is fixed. Closing it then.