Bug 65686 - EDITING Data > Validity broken (for list entries at least)
Summary: EDITING Data > Validity broken (for list entries at least)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.0.0.beta1
Hardware: All All
: high critical
Assignee: Markus Mohrhard
URL:
Whiteboard: target:4.2.0 target:4.1.2 target:6.2.0
Keywords: regression
: 65582 67480 67686 68100 68693 68873 69077 69706 69714 69904 69996 70004 70136 70274 72569 (view as bug list)
Depends on:
Blocks: mab4.1
  Show dependency treegraph
 
Reported: 2013-06-12 18:06 UTC by Cor Nouws
Modified: 2018-07-23 15:57 UTC (History)
27 users (show)

See Also:
Crash report or crash signature:


Attachments
sample ods file (6.54 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-07-02 12:19 UTC, Jaise James
Details
Screenshot to illustrate the bug with comparisons (1.26 MB, application/vnd.oasis.opendocument.graphics)
2013-07-10 11:12 UTC, surbun
Details
Screenshot to illustrate the bug with comparisons (1.26 MB, application/vnd.oasis.opendocument.graphics)
2013-07-10 11:15 UTC, surbun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2013-06-12 18:06:27 UTC
- spreadsheet
- Data > Validity
- Select Allow List
- Enter Entries Aap Noot Mies
- OK
 > cell shows list dropdown control
   but is disabled
   also Alt+down does not work

- again open Data > Validity
 > there are empty lines in the list Entries
Comment 1 Cor Nouws 2013-06-12 18:07:09 UTC
works at least fine in 4.0.3
Comment 2 Jaise James 2013-07-02 12:19:33 UTC
Created attachment 81876 [details]
sample ods file

Cell validity is not working for me also.

I have attached a sample ods file. Yellow is a validity cell with drop down list. I have entered 4 items. If I go to menu Data--> Validity --> Criteria --> List

Cursor moves will inside list in Criteria --> List , but no value shows in the list. Actually I have enter 10, 20, 30, 40 in downward order.

It is not possible to get drop down list values in cell.
Comment 3 Jaise James 2013-07-02 12:20:26 UTC
Libreoffice version used is 4.1 rc1
Comment 4 surbun 2013-07-10 11:12:48 UTC
Created attachment 82269 [details]
Screenshot to illustrate the bug with comparisons
Comment 5 surbun 2013-07-10 11:15:44 UTC
Created attachment 82270 [details]
Screenshot to illustrate the bug with comparisons

Hello,

I confirm this bug. I'm using the LibO 4.1.0.2 RC2 version.

Yet, I tried to do the same thing using cell range. It seems that all datas in the dropdown menu are there. See attached file.

Hope that this bug will be fixed before the final release of this version.

Cheer

Bunty
Comment 6 GerardF 2013-07-31 20:08:36 UTC
*** Bug 65582 has been marked as a duplicate of this bug. ***
Comment 7 m.a.riosv 2013-08-02 22:05:00 UTC
*** Bug 67686 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Suo 2013-08-03 06:21:03 UTC
Confirm in LibreOffice 4.1.0.4.

Validity for "Allow: cell range" is fine, only have problem for "List" entries.
Comment 9 reddish 2013-08-05 14:53:39 UTC
Confirm the bug in LibreOffice 4.1.0.4.

The "list" option in data validity does not show the selection list when clicking at the arrow. Other validation methods seem to work OK. 

OS: Windows XP
Comment 10 drewsus 2013-08-11 21:32:23 UTC
Can confirm all of the above running Ubuntu 13.04 using both the stock Repos and the PPA. 

Libreoffice is 4.1.0.4 Build ID: 410m0(Build:4)
Comment 11 vivAce 2013-08-15 04:51:14 UTC
*** Bug 68100 has been marked as a duplicate of this bug. ***
Comment 12 koukasio 2013-08-20 00:37:50 UTC
Confirm in LibreOffice 4.1.0.4
Comment 13 tommy27 2013-08-22 13:08:04 UTC
I raise the importance level of this issue.
with this regression professional use of Calc is impossible.
Comment 14 vivAce 2013-08-22 13:15:07 UTC
I changed the version from 4.1.0.1.beta1 to 4.1.0.4 release, since a beta version might be expected to be buggy, however numerous people confirm this bug in the normal release, including me.
Comment 15 Cor Nouws 2013-08-22 14:02:48 UTC
@vivAce
When you want to _raise_ the version number, pls read the comment that the site gives to you before clicking save changes ;)
Comment 16 vivAce 2013-08-23 04:13:01 UTC
@Cor. Sorry. Newby to bugzilla. I'm not what I am supposed to read before saving changes. I checked but couldn't find anything. Could you please fill me in?
Comment 17 tommy27 2013-08-25 13:43:30 UTC
to db@tasit.net

again, please guys do not change version field...
it should indicate the first version the bug appeared (in this case 4.1.0.0 beta) and not the last one where it's still reproducibile (4.1.1.2 rc)
Comment 18 GerardF 2013-08-29 13:05:31 UTC
*** Bug 68693 has been marked as a duplicate of this bug. ***
Comment 19 SURCOUF 2013-09-03 02:29:33 UTC
I installed the Version: 4.2.0.0.alpha0+
Build ID: 5a684a041f10fe20512dd5aef6552531165dfa44.
I unfortunately found the same bug.
I hope that this information can help for finding a solution for this bug.

Cheer
Comment 20 m.a.riosv 2013-09-03 22:41:07 UTC
*** Bug 68873 has been marked as a duplicate of this bug. ***
Comment 21 burnuser 2013-09-06 08:33:12 UTC
Confirm this bug on LO 4.1.1.2
Comment 22 Jeff 2013-09-06 21:55:08 UTC
I can confirm that I'm having the same problem.

Using LibreOffice Version: 4.1.1.2, Build ID: 410m0(Build:2)
Comment 23 Commit Notification 2013-09-07 11:08:20 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cb460bf3ca6beab2478d29398ddfb6276ac19b04

fix validity dialog with lists, fdo#65686



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Markus Mohrhard 2013-09-07 11:32:24 UTC
*** Bug 67480 has been marked as a duplicate of this bug. ***
Comment 25 Commit Notification 2013-09-07 12:25:34 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0b0cea7fd774d1fd9c66eab3026940dc4a8899cc&h=libreoffice-4-1

fix validity dialog with lists, fdo#65686


It will be available in LibreOffice 4.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 26 Jorendc 2013-09-07 23:58:53 UTC
*** Bug 69077 has been marked as a duplicate of this bug. ***
Comment 27 Commit Notification 2013-09-09 08:41:17 UTC
Markus Mohrhard committed a patch related to this issue.
It has been pushed to "libreoffice-4-1-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=61d74e6758cae039593de0d358860fd08227db80&h=libreoffice-4-1-2

fix validity dialog with lists, fdo#65686


It will be available already in LibreOffice 4.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 Stanislav Horacek 2013-09-23 14:40:51 UTC
*** Bug 69706 has been marked as a duplicate of this bug. ***
Comment 29 Stanislav Horacek 2013-09-23 14:45:40 UTC
*** Bug 69714 has been marked as a duplicate of this bug. ***
Comment 30 ign_christian 2013-09-29 00:57:54 UTC
*** Bug 69904 has been marked as a duplicate of this bug. ***
Comment 31 ign_christian 2013-10-01 13:23:57 UTC
*** Bug 69996 has been marked as a duplicate of this bug. ***
Comment 32 GerardF 2013-10-01 21:03:10 UTC
*** Bug 70004 has been marked as a duplicate of this bug. ***
Comment 33 ign_christian 2013-10-04 14:51:46 UTC
*** Bug 70136 has been marked as a duplicate of this bug. ***
Comment 34 m.a.riosv 2013-10-08 21:45:43 UTC
*** Bug 70274 has been marked as a duplicate of this bug. ***
Comment 35 m.a.riosv 2013-12-10 21:14:46 UTC
*** Bug 72569 has been marked as a duplicate of this bug. ***
Comment 36 Commit Notification 2018-07-23 15:57:26 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4897a75b4703d658f94f88caae6a66375fd73b08

uitest for bug tdf#65686

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.