Bug 65835 - [FILEOPEN] Very slow import for xslx file
Summary: [FILEOPEN] Very slow import for xslx file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.3.3 release
Hardware: x86-64 (AMD64) Linux (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-16 16:21 UTC by sdaniele78
Modified: 2014-03-12 16:29 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
File Excel slow to open (179.99 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2013-06-16 16:21 UTC, sdaniele78
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sdaniele78 2013-06-16 16:21:44 UTC
Created attachment 80917 [details]
File Excel slow to open

We use the attached Excel file everyday with M$ Excel. I tryied to import it with Calc and import is very slow: it take 10/15 seconds instead of 2 seconds with M$ Excel.
If I convert it in .ods format and try to reopen is quick.
Comment 1 m.a.riosv 2013-06-16 21:57:31 UTC
Hi sdaniele78, 

when I save in xlsx with:
LibreOffice Version 4.0.4.2 (Build ID: 9e9821abd0ffdbc09cd8c52eaa574fa09eb08f2)

arrays formulas lose their array condition.
Comment 2 sdaniele78 2013-06-17 20:05:57 UTC
Hi mariosv,
I tryed and you are right: I first save in .ods, then open .ods and save in .xlsx and arrays formulas lose their array condition.
I suppose we need to create a new bug.
Comment 3 sdaniele78 2013-06-17 20:12:56 UTC
Mariosv, 
bug alwady present here:
https://bugs.freedesktop.org/show_bug.cgi?id=61157
Comment 4 Xisco Faulí 2014-03-12 16:29:01 UTC
I close this bug report as RESOLVED WORKFORME because Calc opens this document in a few seconds:
Tested again in Windows 7 Enterprise with:
   - Libreoffice 4.1.4.2 Build  ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
   - Libreoffice 4.2.1.1 Build  ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b
   - Libreoffice 4.3.0.0.alpha0 ID: 9aa241f0370ab22096a9b1d70040130743448a65

Feel free to open this bug report again if you find that the bug is still reproducible under some special circumstances, etc.