Bug 65864 - Wrong background in svg-polygons
Summary: Wrong background in svg-polygons
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.3.2 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.4.0 target:5.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-17 14:15 UTC by Schorsch
Modified: 2016-10-25 19:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Image from geoserver (915.31 KB, image/svg+xml)
2013-06-17 14:15 UTC, Schorsch
Details
screenshot from LO (215.77 KB, image/png)
2013-06-17 14:16 UTC, Schorsch
Details
Image showing some lines (49.21 KB, image/svg+xml)
2013-06-20 08:00 UTC, Schorsch
Details
Image with some polygons from geoserver (52.06 KB, image/svg+xml)
2013-06-20 08:15 UTC, Schorsch
Details
Screenshot from LO, with additional black polygons (64.88 KB, image/png)
2013-06-20 08:16 UTC, Schorsch
Details
expected result in Firefox (63.95 KB, image/png)
2013-06-20 08:17 UTC, Schorsch
Details
screenshot for attachment 81903 (117.96 KB, image/png)
2013-09-24 10:49 UTC, Christina Rossmanith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Schorsch 2013-06-17 14:15:52 UTC
Created attachment 80953 [details]
Image from geoserver

We export svg-images from a wms-system (geoserver with batik). They are correct in inkscape or firefox but if we open them in LO the look is very ugly. All areas have a black background- as it is not intendet to be.
Comment 1 Schorsch 2013-06-17 14:16:59 UTC
Created attachment 80954 [details]
screenshot from LO
Comment 2 ign_christian 2013-06-20 03:59:10 UTC
I can confirm with LO 4.0.4.2 (Win7 32bit), white background change to black.

@Schorsch, perhaps you could also search similar bug that have been reported before..whether it's a duplicate?
Comment 3 Schorsch 2013-06-20 08:00:50 UTC
Created attachment 81092 [details]
Image showing some lines
Comment 4 Schorsch 2013-06-20 08:03:03 UTC
https://bugs.freedesktop.org/show_bug.cgi?id=37072 shows a similiar problem.
I changed the attachment with a simpler one.
Comment 5 Schorsch 2013-06-20 08:15:51 UTC
Created attachment 81093 [details]
Image with some polygons from geoserver
Comment 6 Schorsch 2013-06-20 08:16:39 UTC
Created attachment 81094 [details]
Screenshot from LO, with additional black polygons
Comment 7 Schorsch 2013-06-20 08:17:21 UTC
Created attachment 81095 [details]
expected result in Firefox
Comment 8 Schorsch 2013-06-20 08:35:39 UTC
There are some unwanted areas in LO-Draw - they are black. All other areas are well.
Comment 9 Christina Rossmanith 2013-09-24 10:49:34 UTC
Created attachment 86438 [details]
screenshot for attachment 81903 [details]

The image is displayed correctly when opened via Insert->Picture->From File

Version: 4.2.0.0.alpha0+
Build ID: f4d3954fc6106b3ae0ee16ab0fcde15d8cb945e3
Linux (Ubuntu)
Comment 10 Schorsch 2014-04-08 12:33:04 UTC
this is true, but it takes a long time. The example document is only a small part of a bigger SVG file. Opening is fast, insert is slow.
Comment 11 Schorsch 2014-06-05 09:12:38 UTC
With Beta 1 of LO 4.3 the problem persists.
The wrong background are ClipRegions. See https://issues.apache.org/ooo/show_bug.cgi?id=124313
Comment 12 Schorsch 2014-06-05 09:18:21 UTC
With version 4.2.4 the image is no longer displayed correctly when opened via Insert->Picture->From File
Comment 13 Adolfo Jayme 2014-10-11 04:39:05 UTC
Christina Roßmanith has committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e27d23d7e665cc0aeac8fc9ea2236bf8bc088ff

fdo#65864: dont't traverse defs-nodes when in shape writing mode



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Schorsch 2014-10-13 12:35:59 UTC
Version: 4.3.4.0.0+
Build ID: b3e96abc32623891a7147c9f8fa6477ffcddd643
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-10-13_09:24:43:

Insert->Picture->From File : works fine with small images, with bigger images consumes a lot of memory - crashes

File->Open : black background
Comment 15 Schorsch 2015-01-22 13:21:16 UTC
in Version: 4.4.0.2 the problem is gone, SVG is working fine.
Thanks!
Comment 16 Xisco Faulí 2015-08-19 15:37:26 UTC
I confirm that this issue can no longer be reproduced with

Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-ES (es_ES)

on Windows 7 (64-bit)

Tested Insert->Picture->From File and File->Open.

Thus, I close it as RESOLVED WORKSFORME
Comment 17 Commit Notification 2015-11-07 21:32:24 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3056a6b6e39b57c66ebaf5210264b689f02f5fc3

SVG: tdf#95332 defs can contain shapes so fix tdf#65864 in...

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.