Download it now!
Bug 65983 - EDITING: Freezing writer after opening a document with some frames
Summary: EDITING: Freezing writer after opening a document with some frames
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: perf
Depends on:
Blocks:
 
Reported: 2013-06-20 20:41 UTC by Ricard
Modified: 2019-01-11 20:07 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Document which causes the error with some frames and pictures in the frame and frames in the frame. (73.14 KB, application/vnd.oasis.opendocument.text)
2013-06-20 20:41 UTC, Ricard
Details
this document works fine. It has the nearly the same context as the one which males problems (76.05 KB, application/vnd.oasis.opendocument.text)
2013-07-30 20:23 UTC, Ricard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ricard 2013-06-20 20:41:30 UTC
Created attachment 81132 [details]
Document which causes the error with some frames and pictures in the frame and frames in the frame.

Problem description: 
The program freezes after opening a textfile with some frames with text and frames placed in other frames, and pictures in the frame. 

Steps to reproduce:
1. open the document, 
2. wait for a few seconds or do something in the text
3. 

Current behavior:
the whole program freezes.

Expected behavior:
work with the text in the frames

              
Operating System: Ubuntu
Version: 4.0.4.2 release
Comment 1 Ricard 2013-06-20 20:46:06 UTC
Hi
I tested it with different versions of libreoffice and also openoffice. The result is always the same.
Also I tested it with windows and ubuntu and mint OS. It doesn't matter.
I changed the memory setting in options, also that doesn't help.
So I need help how to fix this.
Thanks
Comment 2 Joel Madero 2013-06-21 01:01:55 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
As I've been able to confirm this problem I am marking as:

Updated version to 4.0.3.3 release because I can confirm at least this far back. Version is the oldest version we see the problem - probably around since before branch off but currently I only have 4.0.3.3

New (confirmed)
Major - some serious performance issues here but, pretty intense document with so many frames - probably interesting to dissect a bit
High

CCing Michael Stahl - Michael, this one yours by chance? You can open the document but it just freezes up, CPU spikes high. 16 pages of frames but the document itself is pretty small

Keywords - 

Whiteboard Status - perf

@Ricard - have you tried presentation? Seems like it might fit your needs from the quick look I saw of the document before freeze

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 3 Ricard 2013-07-30 20:23:24 UTC
Created attachment 83331 [details]
this document works fine. It has the nearly the same context as the one which males problems

Hi,
At he weckend I tested the document on 4.1.0.4 and it crashes as the last ones too.

thanks for your response and testing Joel. Now I put an attachment that works fine with a lot of frames too.
You ask me if I will better use Impress for that, but I do not share this, because at the End this will be an Book, and I like to print it with the book-print.
I've made this formating because of the autors which don#t know a lot of formating and don't know th other programs except writer. 

The content of the file is, that there are 2 frames on each side, one on top the other on bottom. The top one can grow to bottom,if more text is filled in.
The bottom one is growing to top if more text is filled in.
Each frame has to frames in it, a header and a footer which schould be on the top and on the bottom of each frame(without importance of th hight of the big frame), with or without text. At least there are 2 pictures, one in the header, and one in the footer of the frame.

I hope this helps for finding a solucion.
Sorry for my poor english
Richard
Comment 4 tommy27 2013-09-10 18:45:49 UTC
*** Bug 69186 has been marked as a duplicate of this bug. ***
Comment 5 tommy27 2013-09-10 18:56:27 UTC
not reproducible under Win7 64bit using 4.1.1.2
I can open the file, edit and save it without crashes.
maybe Linux specific bug?
Comment 6 Robinson Tryon (qubit) 2013-10-19 00:11:07 UTC
Remove comma from whiteboard.
Comment 7 Julien Nabet 2014-08-10 15:40:45 UTC
With pc Debian x86-64 with master sources updated today, I could reproduce the problem.
Comment 8 RickWriter 2015-02-19 16:47:24 UTC
Having similar experience using Windows 7, 64-bit CPU, 8 G RAM running LibrfeOffice 4.3.5.2  Opening a document and attempting to add a frame to it results in complete lockdown of LO. Operation is normal until clicking Insert > Frame.
Comment 9 RickWriter 2015-02-19 17:14:21 UTC
I was able to recover some functionality by resetting my profile per these instructions:
https://wiki.documentfoundation.org/Documentation/UserProfile
Comment 10 Robinson Tryon (qubit) 2015-12-10 02:02:52 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-09-01 11:19:37 UTC Comment hidden (obsolete)
Comment 12 Xisco Faulí 2019-01-11 20:07:23 UTC
Issue no longer reproduced in

Version: 6.3.0.0.alpha0+
Build ID: a0210c5c5e8fd47b55567a8b18788d57d2b7decb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

nor in

Version: 6.1.4.2
Build ID: 1:6.1.4-0ubuntu0.16.04.1~lo2
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

[Improvement found by office-interoperability-tools]